summaryrefslogtreecommitdiff
path: root/app-office/worklog-assistant-bin/worklog-assistant-bin-2.3.3900.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-20 12:05:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-20 12:05:24 +0100
commitda7ae1dd1fccb6b3c0e4763ab983ad96d57bf463 (patch)
tree0a7a1b7b3ad60c3b21c697e75908b256fc9ed6b1 /app-office/worklog-assistant-bin/worklog-assistant-bin-2.3.3900.ebuild
parentb6cfc0c19effe2d9f7b8ab303cd00636f16da253 (diff)
gentoo auto-resync : 20:04:2024 - 12:05:23
Diffstat (limited to 'app-office/worklog-assistant-bin/worklog-assistant-bin-2.3.3900.ebuild')
-rw-r--r--app-office/worklog-assistant-bin/worklog-assistant-bin-2.3.3900.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-office/worklog-assistant-bin/worklog-assistant-bin-2.3.3900.ebuild b/app-office/worklog-assistant-bin/worklog-assistant-bin-2.3.3900.ebuild
new file mode 100644
index 000000000000..1d0c08bba197
--- /dev/null
+++ b/app-office/worklog-assistant-bin/worklog-assistant-bin-2.3.3900.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit unpacker
+
+DESCRIPTION="Hassle-free time tracking for JIRA self-hosted and OnDemand"
+HOMEPAGE="https://worklogassistant.com"
+SRC_URI="https://worklogassistant.com/downloads/${PN%-bin}-v2_${PV}_amd64.deb"
+S=${WORKDIR}
+
+LICENSE="worklog-assistant"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+RESTRICT="fetch bindist strip"
+
+QA_PREBUILT="opt/Worklog Assistant/*"
+
+src_prepare() {
+ default
+
+ rm -r etc/ || die
+}
+
+src_install() {
+ mv * "${ED}" || die
+
+ dosym -r "/opt/Worklog Assistant/bin/Worklog Assistant" /opt/bin/WorklogAssistant
+}