summaryrefslogtreecommitdiff
path: root/app-office/worklog-assistant-bin/worklog-assistant-bin-2.1.3580.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-office/worklog-assistant-bin/worklog-assistant-bin-2.1.3580.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-office/worklog-assistant-bin/worklog-assistant-bin-2.1.3580.ebuild')
-rw-r--r--app-office/worklog-assistant-bin/worklog-assistant-bin-2.1.3580.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-office/worklog-assistant-bin/worklog-assistant-bin-2.1.3580.ebuild b/app-office/worklog-assistant-bin/worklog-assistant-bin-2.1.3580.ebuild
new file mode 100644
index 000000000000..268081df608c
--- /dev/null
+++ b/app-office/worklog-assistant-bin/worklog-assistant-bin-2.1.3580.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit unpacker
+
+MY_PN="${PN%-bin}"
+
+DESCRIPTION="Hassle-free time tracking for JIRA self-hosted and OnDemand"
+HOMEPAGE="https://worklogassistant.com"
+SRC_URI="https://worklogassistant.com/downloads/${MY_PN}-v2_${PV}_amd64.deb"
+
+LICENSE="worklog-assistant"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="fetch bindist strip"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-desktop.patch"
+)
+
+src_prepare() {
+ default
+
+ rm -r etc/ || die
+ rm _gpgbuilder || die
+}
+
+src_install() {
+ mv * "${ED}" || die
+
+ dosym "/opt/Worklog Assistant/bin/Worklog Assistant" /opt/bin/WorklogAssistant
+}