summaryrefslogtreecommitdiff
path: root/app-office/unoconv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-15 17:25:28 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-15 17:25:28 +0000
commit6b933047f46efec1aa747570f945344254227457 (patch)
treea12a4b87b38f954c4de435272cf4b90d721df5e8 /app-office/unoconv
parentf45955e60d4da9b7f4a1088c98042f9c06669039 (diff)
gentoo resync : 15.12.2017
Diffstat (limited to 'app-office/unoconv')
-rw-r--r--app-office/unoconv/Manifest3
-rw-r--r--app-office/unoconv/unoconv-0.8.2.ebuild42
-rw-r--r--app-office/unoconv/unoconv-99999999.ebuild41
3 files changed, 44 insertions, 42 deletions
diff --git a/app-office/unoconv/Manifest b/app-office/unoconv/Manifest
index fe09719ac35d..7801d001d51c 100644
--- a/app-office/unoconv/Manifest
+++ b/app-office/unoconv/Manifest
@@ -1,5 +1,6 @@
AUX timeout.patch 460 BLAKE2B 66cb2918b2ad85cb987ecae492626a0ca06344cac4e9fab1f6a141bcb7822356936439e2239ac586aed8a163e297a5b563e51d382e372c2435256933a4ca3612 SHA512 00ccee1c2040149432565abf4cc0bc8966801202a88c75f246d4b4c986dd43288f30045d4e966c973efa946532eec1f07a6bdff0b9307bd9c12475c9309f3fa5
DIST unoconv-0.7.tar.gz 96151 BLAKE2B dcdb797728db36c33be9aff447a28dddc8918fb3a496fd718d6dd9ec22a49c395ddaf0130b99aa09d8ed9b2516795c1aaeb58fe8d906bb004a2192eae0df1fab SHA512 3b0837e11f22733e0fbef93dc6aeabd0e2d3d59b6c35a6f7b29b86506a5842bcbffb3e889864d6e14c1e53dd306354690a699257fe60f36ce1d4455ab52b5df7
+DIST unoconv-0.8.2.tar.gz 104072 BLAKE2B 1ac16159f939a06cc75f3ff23f5aa7f1c4d49a41d4cce5e9c5866714ef1b3b969f94c074d36fff19d6af22375d5598033fb69761a09d3e60b81d794841c0e0d8 SHA512 cd6a4d06559895c0aebb5fda51ca86928474dd0ca0aa908e81762643186c29cf8436c889eedbb18bc74ed6016414d1aa831cd034614244d5aae677a6b4cdd4c9
EBUILD unoconv-0.7.ebuild 808 BLAKE2B f75e791e48c11b5cb5bcc6f7476fd8cb5bee3ae36bf1ee586ba2cce1e651cdb24428a8afdcfae4b61d0942be0017231e400eecf3491bec5794ce891cd1df594e SHA512 f37b64e4fb44504282de0a173020add59a94474bb89d886b690f73f0311af607f8c0499f5078e5e0f0b7a4ecd5be7412c2b29b7d65b20e72b402fb2c68ac3f89
-EBUILD unoconv-99999999.ebuild 959 BLAKE2B 374862459f9aad69158901fcf55b084409c6d653ba65679fa7c61f089a7c389a8381fccc878f7eaa260b3ce0f67ab55c1ad4ce87bc8ba8ff67ec07b48696a18e SHA512 be39559a03aac0864a126a3e84843351f1e354d6c1404cb20602520e4c2c3c17873337893a45f62947f016fe87b972b3e7d7283a7dbfb419ba76029ded239a89
+EBUILD unoconv-0.8.2.ebuild 825 BLAKE2B 2b79e24cc84d72b07c964df05f9dd9fcf2e741d5a8d07f1a4f26adff7db21c2b633830a49f35114d062e644d773aa9d69f9fbabd005490823ad912ed9934c3a0 SHA512 fcf44130f76a07627040f34c52685a30414f5ec6e35112b667a061a49e653dbe765ce22f05f5df67a9ba30a19af8c5f36d8d58c6fdf876844941f8ad785d2798
MISC metadata.xml 429 BLAKE2B c863daa05c0d7d265b60a04e0b1336067296b3854c83aa2c08891bbfe0d3fd45971312b6385b50c7ccb47676b65e97afee953a675176643c4bde348a6a3f0162 SHA512 3875bd4f015c8ffc902a3aedf042cd46cbe86f4ef6dfd1a493d3d7c171bf12248763e64d1f448800fa571157d3e5adac0aa191c9ad40667762ed17eadf3840ed
diff --git a/app-office/unoconv/unoconv-0.8.2.ebuild b/app-office/unoconv/unoconv-0.8.2.ebuild
new file mode 100644
index 000000000000..15bab5d0ef54
--- /dev/null
+++ b/app-office/unoconv/unoconv-0.8.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit eutils python-single-r1
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DESCRIPTION="Convert between document formats supported by Libreoffice"
+HOMEPAGE="http://dag.wieers.com/home-made/unoconv/"
+SRC_URI="https://github.com/dagwieers/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+ !app-text/odt2txt
+ virtual/ooo
+"
+
+src_prepare() {
+ epatch "${FILESDIR}/timeout.patch"
+ eapply_user
+ python_fix_shebang .
+}
+
+src_compile() { :; }
+
+src_install() {
+ emake -j1 doc-install install install-links DESTDIR="${D}" || die
+
+ dodoc ChangeLog CHANGELOG.md README.adoc || die
+}
diff --git a/app-office/unoconv/unoconv-99999999.ebuild b/app-office/unoconv/unoconv-99999999.ebuild
deleted file mode 100644
index 38c911aa3f85..000000000000
--- a/app-office/unoconv/unoconv-99999999.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
-EGIT_REPO_URI="https://github.com/dagwieers/unoconv.git"
-[[ ${PV} == 9999* ]] && SCM_ECLASS="git-r3"
-inherit python-single-r1 ${SCM_ECLASS}
-unset SCM_ECLASS
-
-DESCRIPTION="Convert between document formats supported by Libreoffice"
-HOMEPAGE="http://dag.wieers.com/home-made/unoconv/"
-[[ ${PV} == 9999* ]] || SRC_URI="http://dev.gentooexperimental.org/~scarabeus/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-[[ ${PV} == 9999* ]] || \
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND=""
-RDEPEND="${DEPEND}
- ${PYTHON_DEPS}
- !app-text/odt2txt
- virtual/ooo
-"
-
-DOCS=( ChangeLog CHANGELOG.md README.adoc )
-
-PATCHES=( "${FILESDIR}/timeout.patch" )
-
-src_compile() { :; }
-
-src_install() {
- emake doc-install install install-links DESTDIR="${D}" || die
- einstalldocs
- python_fix_shebang .
-}