summaryrefslogtreecommitdiff
path: root/app-office/scribus/scribus-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /app-office/scribus/scribus-9999.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'app-office/scribus/scribus-9999.ebuild')
-rw-r--r--app-office/scribus/scribus-9999.ebuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/app-office/scribus/scribus-9999.ebuild b/app-office/scribus/scribus-9999.ebuild
index ac7b913c7f8e..2fc0d1910082 100644
--- a/app-office/scribus/scribus-9999.ebuild
+++ b/app-office/scribus/scribus-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
PYTHON_REQ_USE="tk?"
-inherit cmake-utils desktop flag-o-matic python-single-r1 subversion xdg
+inherit cmake desktop flag-o-matic python-single-r1 subversion xdg
DESCRIPTION="Desktop publishing (DTP) and layout program"
HOMEPAGE="https://www.scribus.net/"
@@ -77,7 +77,7 @@ PATCHES=(
)
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
rm -r codegen/cheetah scribus/third_party/hyphen || die
@@ -109,8 +109,6 @@ src_configure() {
local mycmakeargs=(
-DHAVE_PYTHON=ON
- -DPYTHON_INCLUDE_PATH=$(python_get_includedir)
- -DPYTHON_LIBRARY=$(python_get_library_path)
-DWANT_DISTROBUILD=ON
-DDOCDIR="${EPREFIX}"/usr/share/doc/${PF}/
-DWITH_BOOST=$(usex boost)
@@ -123,11 +121,11 @@ src_configure() {
-DWITH_PODOFO=$(usex pdf)
-DWANT_NOTEMPLATES=$(usex !templates)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
if ! use tk; then
rm "${ED}"/usr/share/scribus/scripts/{FontSample,CalendarWizard}.py || die