summaryrefslogtreecommitdiff
path: root/app-office/pybliographer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-17 09:07:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-17 09:07:15 +0000
commit9bd54251864651f49e673a08aec9ef79cfe08f04 (patch)
treebac28788ab54849c5d28edb190a687167737e736 /app-office/pybliographer
parent6b933047f46efec1aa747570f945344254227457 (diff)
gentoo resync : 17.12.2017
Diffstat (limited to 'app-office/pybliographer')
-rw-r--r--app-office/pybliographer/Manifest2
-rw-r--r--app-office/pybliographer/pybliographer-1.2.18.ebuild67
2 files changed, 69 insertions, 0 deletions
diff --git a/app-office/pybliographer/Manifest b/app-office/pybliographer/Manifest
index 951e64455562..f941b6f24d96 100644
--- a/app-office/pybliographer/Manifest
+++ b/app-office/pybliographer/Manifest
@@ -1,3 +1,5 @@
DIST pybliographer-1.2.15.tar.gz 1859977 BLAKE2B e658f76e7f766beec598d0397f10e7613b8a529d7f1eeccda6364bc93bfb33bb5b9e121b9edcd4bc62dd414bca0ffb4684792baf36228522c9d509c59b0f8833 SHA512 f4b3478f60f042ebc7538f044a8c4014fda5202576e3f894b31c79430400e834c59f859f895efa187a89016f4e2625ee6be20751f31843e179fbdfb54ba65330
+DIST pybliographer-1.2.18.tar.gz 2174899 BLAKE2B 4723a01d386a1da6f1de6b730e4e38ef1dedfeb7a72310f40fd7475710fd92236bdb484e102bf93340c8b826ddda0353e143cc741cd6b57acbedd82e40e4181b SHA512 b4a97d7e0aec3b4d7c68169d4d8799911b4da0591e819a67429c45d2b451be6be129214631770cf26f2083a935b55575d35c4f3b11ea74a9b39e55feea376204
EBUILD pybliographer-1.2.15-r1.ebuild 1760 BLAKE2B 9d16a553f03bd625d09fccafbd2a455d9fa03246c9c6dc9720f876dbb1aff6965dbca9ff747f312c61e994e6117ccdc2a74591b122ea1807517682ac8ca3f7d6 SHA512 9dab7c720e87b3e53a578b996ba5aeb80dcf0801d890ffb3c57d878f8349d603cb7bf9871c0f7642d278b7d0ef89ef4aaa4bc291542c049554c05471972a9b1c
+EBUILD pybliographer-1.2.18.ebuild 1785 BLAKE2B 847e8a96a1504084ef11da467c834be14db9ea92c90eb574c3019222401296b3471ab74fcf08045bb0b16bfefaba0539b032ed2c55771b3f7553edec7397cfe3 SHA512 1b24b5c5fc46d575436dfc644329220a79e798e81fadcca5977336a0d55d02cf73d3a5391093dd47cac7e00e85b99dccd0021b09a35ad04d0b40db7cbe1cb5b3
MISC metadata.xml 798 BLAKE2B 186a835eadc561bbb17ce369742b5c4d27ce31b3de5ee5d3e2d4ec8c81dee3e96c8c3c86c50fc3d77136738551f74f9346825a754ab4401d6c212057ebd73a76 SHA512 9719f3d541a00da1445210482b9b4f6cfc104b59629b472e50ca2869bdaed6f3a3cf7ff1e28b06806407db368c6c998d46c1e22919f4e4c6cafa9dca1808c2b1
diff --git a/app-office/pybliographer/pybliographer-1.2.18.ebuild b/app-office/pybliographer/pybliographer-1.2.18.ebuild
new file mode 100644
index 000000000000..db2f51439e8d
--- /dev/null
+++ b/app-office/pybliographer/pybliographer-1.2.18.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_EAUTORECONF="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Pybliographer is a tool for working with bibliographic databases"
+HOMEPAGE="http://pybliographer.org/"
+SRC_URI="mirror://sourceforge/pybliographer/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=app-text/recode-3.6-r1
+ app-text/rarian
+ dev-libs/glib:2
+ dev-python/gconf-python:2[${PYTHON_USEDEP}]
+ dev-python/gnome-vfs-python:2[${PYTHON_USEDEP}]
+ dev-python/libgnome-python:2[${PYTHON_USEDEP}]
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ >=dev-python/python-bibtex-1.2.5[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ app-text/yelp-tools
+"
+
+src_prepare() {
+ # Workaround for bug 487204.
+ sed -i \
+ -e 's:\$(srcdir)/::g' \
+ tests/Makefile.am || die "sed failed"
+
+ # Install Python modules into site-packages directories.
+ find -name Makefile.am | xargs sed -i \
+ -e "/^pybdir[[:space:]]*=[[:space:]]*/s:\$(datadir):$(python_get_sitedir):" || die "sed failed"
+ sed -i \
+ -e "s:\${datadir}/@PACKAGE@:$(python_get_sitedir)/@PACKAGE@:" \
+ etc/installer.in || die "sed failed"
+ sed -i \
+ -e "s:gladedir = \$(datadir):gladedir = $(python_get_sitedir):" \
+ Pyblio/GnomeUI/glade/Makefile.am || die "sed failed"
+
+ # Fix shebang manually as otherwise python_fix_shebang gets confused
+ sed -i -e 's: @python_path@:/usr/bin/python2:' pybliographer.py || die
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-depchecks \
+ --disable-update-desktop-database
+}
+
+src_install() {
+ gnome2_src_install
+ python_fix_shebang "${D}"
+}