summaryrefslogtreecommitdiff
path: root/app-office/planner
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-office/planner
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-office/planner')
-rw-r--r--app-office/planner/Manifest3
-rw-r--r--app-office/planner/metadata.xml8
-rw-r--r--app-office/planner/planner-0.14.6_p20130520.ebuild72
3 files changed, 83 insertions, 0 deletions
diff --git a/app-office/planner/Manifest b/app-office/planner/Manifest
new file mode 100644
index 000000000000..78190be9e695
--- /dev/null
+++ b/app-office/planner/Manifest
@@ -0,0 +1,3 @@
+DIST planner-0.14.6_p20130520.tar.xz 4200624 BLAKE2B 4dd3965a3091fe69d9ac125745f7d3ac54cbe1d81f794c0dded02c0983867d2469848af7f74f1eb745a2e2c42c79be7955d6790f0b263faa5ee821bc28c6a339 SHA512 d658b68c96742340a06a9e96d7910f70fb296cb7a19cc335afdcbec01b36326b1574522155cf19fec012363e1e4d4120c35e1319c699613833be2eb0fa999024
+EBUILD planner-0.14.6_p20130520.ebuild 1899 BLAKE2B 69b6f445a17a8fb14ad2a8ececfa98e7fb4f172764dbc371d7345836258d5896c1a81e694f3632c741f7a8887612ddd13d9d6962e94a2840783cee62b977eb9d SHA512 baa0be3c34624e8bb59e55a2e79e1712027f706957ee97d50b3b4a50857bb57bab9b27ab6eb134dcd823eb650d6921c6289a1428a44edb0a7f25af3cddcbee58
+MISC metadata.xml 259 BLAKE2B 32f8c5208a55a1dda504b7df969127393a2c70e672aba383fcdc870de8fe778366d3dde3c3313bd043068d2e7831d1e18bad6fb428e82266fc2a630104e0a193 SHA512 fbef629394690b3a5608abc6344816f6acf1e8e2663f29949fd14a662c628f16fee77a1ec1641066806d143fb94c1571bc5b46b829dc53620af6956377fe15cc
diff --git a/app-office/planner/metadata.xml b/app-office/planner/metadata.xml
new file mode 100644
index 000000000000..4cbddcaa19ad
--- /dev/null
+++ b/app-office/planner/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-office/planner/planner-0.14.6_p20130520.ebuild b/app-office/planner/planner-0.14.6_p20130520.ebuild
new file mode 100644
index 000000000000..df665c4c9d4f
--- /dev/null
+++ b/app-office/planner/planner-0.14.6_p20130520.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Project manager for Gnome"
+HOMEPAGE="https://wiki.gnome.org/action/show/Apps/Planner"
+SRC_URI="https://dev.gentoo.org/~eva/distfiles/${PN}/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha amd64 ~ppc ~sparc x86"
+
+IUSE="eds examples python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ >=dev-libs/glib-2.6:2
+ >=x11-libs/gtk+-2.14:2
+ >=gnome-base/libgnomecanvas-2.10
+ >=gnome-base/libgnomeui-2.10
+ >=gnome-base/libglade-2.4:2.0
+ >=gnome-base/gconf-2.6:2
+ >=dev-libs/libxml2-2.6.27:2
+ >=dev-libs/libxslt-1.1.23
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-python/pygtk-2.6:2[${PYTHON_USEDEP}] )
+ eds? (
+ >=gnome-extra/evolution-data-server-3.6:=
+ >=mail-client/evolution-3.6 )
+"
+DEPEND="${RDEPEND}
+ app-text/rarian
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35.5
+ gnome-base/gnome-common
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${PN}-0.14.6"
+
+src_configure() {
+ # FIXME: disable eds backend for now, it fails, upstream bug #654005
+ # We need to set compile-warnings to a different value as it doesn't use
+ # standard macro: https://bugzilla.gnome.org/703067
+ gnome2_src_configure \
+ $(use_enable python) \
+ $(use_enable python python-plugin) \
+ $(use_enable eds) \
+ --disable-eds-backend \
+ --with-database=no \
+ --disable-update-mimedb \
+ --enable-compile-warnings=yes
+ #$(use_enable eds eds-backend)
+}
+
+src_install() {
+ # error: relink `libstorage-mrproject-1.la' with the above command before installing it
+ # Try to drop workaround on next snapshot or bump
+ MAKEOPTS="${MAKEOPTS} -j1" gnome2_src_install \
+ sqldocdir="\$(datadir)/doc/${PF}" \
+ sampledir="\$(datadir)/doc/${PF}/examples"
+
+ if ! use examples; then
+ rm -rf "${D}/usr/share/doc/${PF}/examples"
+ fi
+}