summaryrefslogtreecommitdiff
path: root/app-office/planner
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-29 22:01:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-29 22:01:57 +0100
commit009897642a869d630779716efc51af1554f72867 (patch)
tree879100d35e2fd1f39b32b68b2abe220f156b3a20 /app-office/planner
parent9cd7e710ac676c1a318d09e665ca3558bb5c5323 (diff)
gentoo auto-resync : 29:10:2022 - 22:01:57
Diffstat (limited to 'app-office/planner')
-rw-r--r--app-office/planner/Manifest4
-rw-r--r--app-office/planner/metadata.xml3
-rw-r--r--app-office/planner/planner-0.14.6_p20130520-r3.ebuild66
-rw-r--r--app-office/planner/planner-9999.ebuild71
4 files changed, 143 insertions, 1 deletions
diff --git a/app-office/planner/Manifest b/app-office/planner/Manifest
index b08f2bb81239..d554097a710d 100644
--- a/app-office/planner/Manifest
+++ b/app-office/planner/Manifest
@@ -1,3 +1,5 @@
DIST planner-0.14.6_p20130520.tar.xz 4200624 BLAKE2B 4dd3965a3091fe69d9ac125745f7d3ac54cbe1d81f794c0dded02c0983867d2469848af7f74f1eb745a2e2c42c79be7955d6790f0b263faa5ee821bc28c6a339 SHA512 d658b68c96742340a06a9e96d7910f70fb296cb7a19cc335afdcbec01b36326b1574522155cf19fec012363e1e4d4120c35e1319c699613833be2eb0fa999024
EBUILD planner-0.14.6_p20130520-r2.ebuild 1663 BLAKE2B 02c3c3765d6da0d1468a5f9788155ea90b63a75446c49415bbd1e74c83110f3eb1ca455cb0459b3108b479f7dc6f32baf5b21ae18da3f367b14bc5cb0f3ecf4e SHA512 0a476057b17d1467ec184e872f1afe9d43014c255099a4eeb2850a10005515b741b7d2d9c53ccf9f40c5660a8ae721fa37ac2a0a7fe1c99f5231a867834697e3
-MISC metadata.xml 260 BLAKE2B 74a7980ab34785ba7920342b0a2708af439bed09b7ffdc1ae3ca6cbbaba8b7dbd7a6894375c6d5adf00819685f44f58b1e069dcd1062a70e99f0dbcfe39dc3d3 SHA512 f4c15c784194c80663c49692140afcfef3450b722254b99b2bd7fd0d7a08c57b463afcfa3b5609e799d0b2d6ff6451172eace91e93b886856d2591d491585c0c
+EBUILD planner-0.14.6_p20130520-r3.ebuild 1553 BLAKE2B 7dd77bf104b383b923bf8f0fe58d99f8aa93bf9892e3f1b12e0cdf9a2cc487c4117cf7d11090b7bc8f7f8f3fd68fb25bcee0743efe694db67f6fc48a97dda5a8 SHA512 cdd083f521556ebb39797fff2431e42220cadaf66e9fa9ce3e14c6039c0cafc9a31818e346786ede330b3003ddbe5ae4a3ff191c08e1e492bc4e1795524d96bb
+EBUILD planner-9999.ebuild 1397 BLAKE2B 2002f4e43f243d0481c8e7941b7febfaf4b3de3c84a826bb35c27eb2d2b474043416dbeb588dfe7b09f7c7bc55b42080a21fd87174bbe018106dc8acd350adea SHA512 9f875495c7acae63b918653525bb165786892603e1794f0ba66cc91409a0ccdc0da0fa4aa46200328e828f8ed46d04cdfd858d28fd0a0d7bb1a3dc7125fe70cd
+MISC metadata.xml 329 BLAKE2B e73fe3ba4cdcb7472c304d190b2694978625c03e75abecca4626274d69f81ae58566fdd8682080a4c2b662c6f0906cf777b60f0b04117cca486dea233006a658 SHA512 d56d87e51a82aee5b18458d050f95f8e60130cf0bf9e98a52b5ccd0296fe183c6b0291e59554cbe1813e955bb0772fae58c826404b1b0fad1a500839ff301d80
diff --git a/app-office/planner/metadata.xml b/app-office/planner/metadata.xml
index c6e394b17a27..3a8e42950cb7 100644
--- a/app-office/planner/metadata.xml
+++ b/app-office/planner/metadata.xml
@@ -5,4 +5,7 @@
<email>gnome@gentoo.org</email>
<name>Gentoo GNOME Desktop</name>
</maintainer>
+ <use>
+ <flag name="libgda">Database/GDA support</flag>
+ </use>
</pkgmetadata>
diff --git a/app-office/planner/planner-0.14.6_p20130520-r3.ebuild b/app-office/planner/planner-0.14.6_p20130520-r3.ebuild
new file mode 100644
index 000000000000..a7e96491e139
--- /dev/null
+++ b/app-office/planner/planner-0.14.6_p20130520-r3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2
+
+DESCRIPTION="Project manager for Gnome"
+HOMEPAGE="https://wiki.gnome.org/Apps/Planner"
+if [[ "${PV}" == "9999" ]] ; then
+ EGIT_REPO_URI="https://gitlab.gnome.org/World/planner.git"
+ inherit git-r3
+ SRC_URI=""
+else
+ SRC_URI="https://dev.gentoo.org/~eva/distfiles/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+fi
+
+SLOT="0"
+LICENSE="GPL-2"
+
+IUSE="examples"
+
+RDEPEND="
+ >=dev-libs/glib-2.6:2
+ >=x11-libs/gtk+-2.24:2
+ >=gnome-base/gconf-2.10:2
+ >=gnome-base/libgnomecanvas-2.10
+ >=gnome-base/libglade-2.4:2.0
+ >=dev-libs/libxml2-2.6.27:2
+ >=dev-libs/libxslt-1.1.23
+"
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ dev-util/gtk-doc-am
+ app-text/docbook-xml-dtd:4.1.2
+ >=dev-util/intltool-0.35.5
+ gnome-base/gnome-common
+ virtual/pkgconfig
+ app-text/rarian
+"
+
+S="${WORKDIR}/${PN}-0.14.6"
+src_configure() {
+ # FIXME: disable eds backend for now, it fails, upstream bug #654005
+ # FIXME: disable eds for now, bug #784086
+ # We need to set compile-warnings to a different value as it doesn't use
+ # standard macro: https://bugzilla.gnome.org/703067
+ gnome2_src_configure \
+ --disable-python \
+ --disable-python-plugin \
+ --disable-eds \
+ --disable-eds-backend \
+ --with-database=no \
+ --disable-update-mimedb \
+ --enable-compile-warnings=yes
+}
+
+src_install() {
+ gnome2_src_install
+ mv "${ED}"/usr/share/doc/planner "${ED}"/usr/share/doc/${PF} || die
+ if ! use examples; then
+ rm -rf "${D}/usr/share/doc/${PF}/examples"
+ fi
+}
diff --git a/app-office/planner/planner-9999.ebuild b/app-office/planner/planner-9999.ebuild
new file mode 100644
index 000000000000..b3239ac6b40b
--- /dev/null
+++ b/app-office/planner/planner-9999.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Project manager for Gnome"
+HOMEPAGE="https://wiki.gnome.org/Apps/Planner"
+if [[ "${PV}" == "9999" ]] ; then
+ EGIT_REPO_URI="https://gitlab.gnome.org/World/planner.git"
+ inherit git-r3
+ SRC_URI=""
+else
+ KEYWORDS="~amd64"
+fi
+
+SLOT="0"
+LICENSE="GPL-2+"
+IUSE="examples gtk-doc libgda" # eds
+
+RDEPEND="
+ >=dev-libs/glib-2.50:2
+ >=x11-libs/gtk+-3.22:3
+ >=dev-libs/libxml2-2.6.27:2
+ >=dev-libs/libxslt-1.1.23
+ libgda? ( >=gnome-extra/libgda-1.0:5 )
+"
+ # eds support is broken for now
+ # eds? (
+ # >=gnome-extra/evolution-data-server-3.6:=
+ # )
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ gtk-doc? (
+ dev-util/gtk-doc
+ app-text/docbook-xml-dtd:4.1.2
+ )
+ virtual/pkgconfig
+ sys-devel/gettext
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature libgda database-gda)
+ # $(meson_feature eds)
+ -Deds=disabled # upstream says it's broken
+ $(meson_use examples)
+ $(meson_use gtk-doc gtk_doc)
+ -Dsimple-priority-scheduling=false # upstream says it's experimental
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if use examples; then
+ mv "${ED}"/usr/share/doc/planner "${ED}"/usr/share/doc/${PF} || die
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}