summaryrefslogtreecommitdiff
path: root/app-office/lyx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-17 20:03:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-17 20:03:52 +0000
commit4935506e9a5cbfabd37c64093eac5f36c2ff0017 (patch)
treeaf9dd93ea349eacaf28286c7c45c7a083b0b7c31 /app-office/lyx
parent434d713861b70f6c6563d6ee50a8e64f14c970d9 (diff)
gentoo resync : 17.02.2018
Diffstat (limited to 'app-office/lyx')
-rw-r--r--app-office/lyx/Manifest1
-rw-r--r--app-office/lyx/lyx-2.2.3-r3.ebuild187
2 files changed, 188 insertions, 0 deletions
diff --git a/app-office/lyx/Manifest b/app-office/lyx/Manifest
index c09b2524c246..3edc4f2a151a 100644
--- a/app-office/lyx/Manifest
+++ b/app-office/lyx/Manifest
@@ -4,4 +4,5 @@ DIST lyx-2.2.3.tar.xz 15501856 BLAKE2B 08606f0c18d9cb5891bd7d612361597e3efc7e785
EBUILD lyx-2.1.5-r1.ebuild 4110 BLAKE2B b2e1a28dc3a86d58e44e8b6a2ed00123c2047c21eb7703a3b35d476b6fa40dc10d28f98240ba4a4943cab15c57a66327d93cf613ddff381156f47b32fc5684ea SHA512 e75260bbde4c3de28071e3d1fd15c49435cc9edc2fd0e48cf4ecee09b783fb698dae23e5489ee0dbc8de53501e1fb4624e7359a948b110342855a6c5c48fa8b2
EBUILD lyx-2.2.3-r1.ebuild 4399 BLAKE2B 754fed823766e2927b7dabec8f8488974a17a2b7141e9b3d15f05128ede7f32a720ff35f09741607833d5bfe48bb5a10647c2150edab8c4f21d9e2d3b8d93592 SHA512 8ab5677b4759e000dc913e869234abcb3c3de155f069f007c19be932722c5a9a23cf8d646a921b82d2e063518de312d30adcd564d73f13a81dd3e04ade9f82d2
EBUILD lyx-2.2.3-r2.ebuild 4369 BLAKE2B a1d9af492e94b1471f8755756cebfb057eebf98f4cfe4c1b16d8b3e520aaee384fe8175cd44ee7e58ecf25b0ce566a1713250e340287d673c2b8fe4c6ba35d01 SHA512 23f0ff39ee3efc573663e6769ecad71b215d2893428170abf346c606e9506667ad0657a4673300da736abefa920cc21b31a8868729d0d9dbf67ddeea7eb13093
+EBUILD lyx-2.2.3-r3.ebuild 4392 BLAKE2B 08334757610b0d7624e5c60e4451e7047acd962b0492bfadebfefa30e238e09e6555a043956e7ce9c2e6c2290cedc9210d97c054f0819c97e1bf8c263a65ea57 SHA512 fe4301072c27b0a251506ec8c6a2525a76b233a5e18032f2642a5cc81af26ea1668cf9d5b6012aade0a95c03e466b567207ebc86acfb91fd9959cc0da0ecb39f
MISC metadata.xml 1760 BLAKE2B 8a223f94b48a92104942b9ae94c2746da8628c260fc597a836ae3b468bbe277b6383af960883fcd731f2ad288cc34d2ed6a58c118e1bfbdd3c2b766e99514328 SHA512 416c99a6d19a9e736a546c4f939cc5238de5027f1151d49d1bed800a5b2a026868d4197198e86c250b77be568f45f94ace125d83700316a5b001e21ed48b91b4
diff --git a/app-office/lyx/lyx-2.2.3-r3.ebuild b/app-office/lyx/lyx-2.2.3-r3.ebuild
new file mode 100644
index 000000000000..fbb69f057bf9
--- /dev/null
+++ b/app-office/lyx/lyx-2.2.3-r3.ebuild
@@ -0,0 +1,187 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit gnome2-utils xdg-utils flag-o-matic font python-single-r1 qmake-utils toolchain-funcs multilib desktop
+
+MY_P="${P/_}"
+
+S="${WORKDIR}/${MY_P}"
+FONT_S="${S}/lib/fonts"
+FONT_SUFFIX="ttf"
+DESCRIPTION="WYSIWYM frontend for LaTeX, DocBook, etc."
+HOMEPAGE="https://www.lyx.org/"
+SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/2.2.x/${MY_P}.tar.xz
+ ftp://ftp.lyx.org/pub/lyx/devel/lyx-2.2/${MY_P}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos ~x86-macos"
+IUSE="aspell cups debug docbook dia dot enchant gnumeric html +hunspell +latex monolithic-build nls +qt5 rcs rtf subversion svg l10n_he"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-libs/boost:=
+ dev-texlive/texlive-fontsextra
+ sys-apps/file
+ sys-libs/zlib
+ virtual/imagemagick-tools[png,svg?]
+ aspell? ( app-text/aspell )
+ cups? ( net-print/cups )
+ dia? ( app-office/dia )
+ docbook? ( app-text/sgmltools-lite )
+ dot? ( media-gfx/graphviz )
+ enchant? ( app-text/enchant )
+ gnumeric? ( app-office/gnumeric )
+ html? ( dev-tex/html2latex )
+ hunspell? ( app-text/hunspell )
+ latex? (
+ app-text/dvipng
+ app-text/ghostscript-gpl
+ app-text/noweb
+ app-text/ps2eps
+ app-text/texlive
+ dev-tex/chktex
+ dev-tex/dvipost
+ dev-texlive/texlive-fontsrecommended
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-pictures
+ || ( dev-texlive/texlive-mathscience dev-texlive/texlive-science )
+ || ( dev-texlive/texlive-plaingeneric dev-texlive/texlive-genericextra )
+ || (
+ dev-tex/hevea
+ dev-tex/latex2html
+ dev-tex/tex4ht[java]
+ dev-tex/tth
+ )
+ )
+ l10n_he? ( dev-tex/culmus-latex )
+ !qt5? (
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ )
+ rcs? ( dev-vcs/rcs )
+ rtf? (
+ app-text/unrtf
+ dev-tex/html2latex
+ dev-tex/latex2rtf
+ )
+ subversion? ( dev-vcs/subversion )
+ svg? ( || ( gnome-base/librsvg media-gfx/inkscape ) )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+ !qt5? ( dev-qt/qtsvg:4 )
+ qt5? (
+ dev-qt/qtconcurrent:5
+ dev-qt/qtx11extras:5
+ )
+"
+
+DOCS=( ANNOUNCE NEWS README RELEASE-NOTES UPGRADING )
+
+PATCHES=( "${FILESDIR}"/2.1-python.patch )
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ font_pkg_setup
+}
+
+src_prepare() {
+ default
+ sed "s:python -tt:${EPYTHON} -tt:g" -i lib/configure.py || die
+}
+
+src_configure() {
+ tc-export CXX
+ #bug 221921
+ export VARTEXFONTS=${T}/fonts
+
+ econf \
+ $(use_with aspell) \
+ $(use_enable debug) \
+ $(use_with enchant) \
+ $(use_with hunspell) \
+ $(use_enable monolithic-build) \
+ $(use_enable nls) \
+ $(use_enable qt5) \
+ --with-qt-dir=$(usex qt5 $(qt5_get_libdir)/qt5 $(qt4_get_libdir)) \
+ --disable-stdlib-debug \
+ --without-included-boost \
+ --with-packaging=posix
+}
+
+src_install() {
+ default
+
+ if use l10n_he ; then
+ echo "\bind_file cua" > "${T}"/hebrew.bind
+ echo "\bind \"F12\" \"language hebrew\"" >> "${T}"/hebrew.bind
+
+ insinto /usr/share/lyx/bind
+ doins "${T}"/hebrew.bind
+ fi
+
+ newicon -s 32 "${S}/development/Win32/packaging/icons/lyx_32x32.png" ${PN}.png
+ doicon -s 48 "${S}/lib/images/lyx.png"
+ doicon -s scalable "${S}/lib/images/lyx.svg"
+
+ # fix for bug 91108
+ if use latex ; then
+ dosym ../../../lyx/tex /usr/share/texmf-site/tex/latex/lyx
+ fi
+
+ # fonts needed for proper math display, see also bug #15629
+ font_src_install
+
+ python_fix_shebang "${ED}"/usr/share/${PN}
+
+ if use hunspell ; then
+ dosym ../myspell /usr/share/lyx/dicts
+ dosym ../myspell /usr/share/lyx/thes
+ fi
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ font_pkg_postinst
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+
+ # fix for bug 91108
+ if use latex ; then
+ texhash
+ fi
+
+ # instructions for RTL support. See also bug 168331.
+ if use l10n_he || has he ${LINGUAS} || has ar ${LINGUAS} ; then
+ elog
+ elog "Enabling RTL support in LyX:"
+ elog "If you intend to use a RTL language (such as Hebrew or Arabic)"
+ elog "You must enable RTL support in LyX. To do so start LyX and go to"
+ elog "Tools->Preferences->Language settings->Language"
+ elog "and make sure the \"Right-to-left language support\" is checked"
+ elog
+ fi
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+
+ if use latex ; then
+ texhash
+ fi
+}