summaryrefslogtreecommitdiff
path: root/app-office/ledger
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-office/ledger
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-office/ledger')
-rw-r--r--app-office/ledger/Manifest5
-rw-r--r--app-office/ledger/files/50ledger-gentoo-3.1.1.el5
-rw-r--r--app-office/ledger/files/ledger-3.1.1-boost.patch22
-rw-r--r--app-office/ledger/ledger-3.1.1.ebuild134
-rw-r--r--app-office/ledger/metadata.xml10
5 files changed, 176 insertions, 0 deletions
diff --git a/app-office/ledger/Manifest b/app-office/ledger/Manifest
new file mode 100644
index 000000000000..d638b9ecadaf
--- /dev/null
+++ b/app-office/ledger/Manifest
@@ -0,0 +1,5 @@
+AUX 50ledger-gentoo-3.1.1.el 166 BLAKE2B f833556da775338829a7dbb288b89f267cbc9723b82fe21a502e96253a132043a12b3737c208f025635cfa8edf8e3d406bc236ad8debf708a66fca3edb162446 SHA512 d5e2450d19d5d24e2db22429fa2ee8d46ae7284c91b1f2ed6eb32a0e6b70e1996f4b2f41812084b0330011d33fbcb2da11bf2d5b9f28a157f4c05d1106c418d5
+AUX ledger-3.1.1-boost.patch 774 BLAKE2B e201dbf7d7af357081112518cf6b615162802307fd708d58df59ad79f12aaf19c3f2ff4645e025145e6afe6078b48f6df27d4128cd71e12e7605c976a4650aa0 SHA512 7f7eaa69ef377df1e9e449981c446ea52ef1d2311a9d96e325bf067af702f0361b05d70d6d52bdeefc7c9471cb68eceaa6fae313976e9b9676110b4e97198ba8
+DIST ledger-3.1.1.tar.gz 842364 BLAKE2B 83f9008f6daf4da39ece192388e0231719bc7297d2a911f1209662f57d2963b9ea09a5b6de9450ed29c5973efa47d9d6a250e052c155d9ba742cdb3ee075f341 SHA512 3f81b98a414cdfc0e272de4e958770149fb1acc8bda880d270e1459ce35294a220c52820bb9af49a751ac3a80b878f81fc7799ba41e0a1be43eba72081351bf5
+EBUILD ledger-3.1.1.ebuild 3207 BLAKE2B 7a6764868596f6ba5d807a06abb17123a86ecca02e977d5c5f983b41176f6f5a48947acb0e2084459f44615cb52efe5b0669f1304e7bdc7ec7e86a335fd2efb1 SHA512 d8543a0877eb080b97c01eb5306ad2967dab2cf5d522875cc03d07d4b6f899aaa01cb0333e5e0aaba8341939e09207a4f19acfa62c1ea0c1c67d6afd9b413fde
+MISC metadata.xml 306 BLAKE2B 58c3d0307a4358f50e8ede8ddf3f598a55ad03dd9af3351b4f15a46465a844c24f9d5966ee5fbbcb9a68d65eb509a18a87aa95400094539475f65493e34f1839 SHA512 c83b1be9474bbfa3296040c56bf14e22afd214835a44907bcb4db2a8047f05e1fe49b1d1ebe5bcd72fe5ed2f27c832d20169aa813f0d9bd619fc1f7a1c5e15cb
diff --git a/app-office/ledger/files/50ledger-gentoo-3.1.1.el b/app-office/ledger/files/50ledger-gentoo-3.1.1.el
new file mode 100644
index 000000000000..1c2c5bde2f8b
--- /dev/null
+++ b/app-office/ledger/files/50ledger-gentoo-3.1.1.el
@@ -0,0 +1,5 @@
+
+;;; app-office/ledger site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'ledger-mode "ledger-mode" "A mode for editing ledger data files." t)
diff --git a/app-office/ledger/files/ledger-3.1.1-boost.patch b/app-office/ledger/files/ledger-3.1.1-boost.patch
new file mode 100644
index 000000000000..b69a42a50113
--- /dev/null
+++ b/app-office/ledger/files/ledger-3.1.1-boost.patch
@@ -0,0 +1,22 @@
+From 1856b8c4902498843f4da37a7aaeb2ce85acc1d3 Mon Sep 17 00:00:00 2001
+From: Denis <dkasak@users.noreply.github.com>
+Date: Mon, 12 Sep 2016 12:49:40 +0200
+Subject: [PATCH] Fix compilation error with boost 1.61
+
+---
+ src/item.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/item.h b/src/item.h
+index ca16d87b3..4dc6df7e6 100644
+--- a/src/item.h
++++ b/src/item.h
+@@ -92,7 +92,7 @@ class item_t : public supports_flags<uint_least16_t>, public scope_t
+
+ typedef std::pair<optional<value_t>, bool> tag_data_t;
+ typedef std::map<string, tag_data_t,
+- function<bool(string, string)> > string_map;
++ std::function<bool(string, string)> > string_map;
+
+ state_t _state;
+ optional<date_t> _date;
diff --git a/app-office/ledger/ledger-3.1.1.ebuild b/app-office/ledger/ledger-3.1.1.ebuild
new file mode 100644
index 000000000000..f04a61c0cd2b
--- /dev/null
+++ b/app-office/ledger/ledger-3.1.1.ebuild
@@ -0,0 +1,134 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit check-reqs cmake-utils elisp-common python-single-r1
+
+DESCRIPTION="A double-entry accounting system with a command-line reporting interface"
+HOMEPAGE="https://www.ledger-cli.org/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="amd64 x86"
+SLOT="0"
+IUSE="doc emacs python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+SITEFILE=50${PN}-gentoo-${PV}.el
+
+CHECKREQS_MEMORY=8G
+
+RDEPEND="
+ dev-libs/boost:=[python?]
+ dev-libs/gmp:0=
+ dev-libs/mpfr:0=
+ emacs? ( virtual/emacs )
+ python? (
+ dev-libs/boost:=[${PYTHON_USEDEP}]
+ dev-python/cheetah
+ ${PYTHON_DEPS}
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/utfcpp
+ doc? (
+ sys-apps/texinfo
+ virtual/texi2dvi
+ dev-texlive/texlive-fontsrecommended
+ )
+"
+
+PATCHES=( "${FILESDIR}/${P}-boost.patch" ) # bug 609108
+
+# Building with python integration seems to fail without 8G available
+# RAM(!) Since the memory check in check-reqs doesn't count swap, it
+# may be unfair to fail the build entirely on the memory test alone.
+# Therefore check-reqs_pkg_pretend is deliberately omitted so that we
+# ewarn but not eerror.
+pkg_pretend() {
+ :
+}
+
+pkg_setup() {
+ if use python; then
+ check-reqs_pkg_setup
+ python-single-r1_pkg_setup
+ fi
+}
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # Want to type "info ledger" not "info ledger3"
+ sed -i -e 's/ledger3/ledger/g' \
+ doc/ledger3.texi \
+ doc/CMakeLists.txt \
+ test/CheckTexinfo.py \
+ tools/cleanup.sh \
+ tools/gendocs.sh \
+ tools/prepare-commit-msg \
+ tools/spellcheck.sh \
+ || die "Failed to update info file name in file contents"
+
+ mv doc/ledger{3,}.texi || die "Failed to rename info file name"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_build emacs EMACSLISP)
+ $(cmake-utils_use_build doc DOCS)
+ $(cmake-utils_use_build doc WEB_DOCS)
+ $(cmake-utils_use_use python PYTHON)
+ -DCMAKE_INSTALL_DOCDIR=/usr/share/doc/${PF}
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ use doc && cmake-utils_src_make doc
+}
+
+src_install() {
+ # Prevent installing ledger.so into python site-packages. It's an
+ # unnecessary copy of libledger.so and generates security warnings.
+ sed -i -e '/python/d' ../${P}_build/src/cmake_install.cmake \
+ || die "Failed to disable installation of ledger.so"
+
+ cmake-utils_src_install
+
+ # This source dir appears to include some helper code for serving
+ # reports to a browser ("ledger server"). I can't quite get it to
+ # work and the docs say it's a work-in-progress. It's a little
+ # interesting, though, so I'll leave these installed as a preview of
+ # features to come.
+ if use python; then
+ mv python ${PN} || die "Couldn't rename python module static files dir"
+ python_domodule ${PN}
+ fi
+
+ use emacs && elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+
+ einfo
+ einfo "Since version 3, vim support is released separately."
+ einfo "See https://github.com/ledger/vim-ledger"
+ einfo
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
+
+# rainy day TODO:
+# - IUSE test
+# - EAPI=6
diff --git a/app-office/ledger/metadata.xml b/app-office/ledger/metadata.xml
new file mode 100644
index 000000000000..e43b674f1de7
--- /dev/null
+++ b/app-office/ledger/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>stasibear@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ledger/ledger</remote-id>
+ </upstream>
+</pkgmetadata>