summaryrefslogtreecommitdiff
path: root/app-office/ledger/ledger-3.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /app-office/ledger/ledger-3.1.2.ebuild
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'app-office/ledger/ledger-3.1.2.ebuild')
-rw-r--r--app-office/ledger/ledger-3.1.2.ebuild28
1 files changed, 7 insertions, 21 deletions
diff --git a/app-office/ledger/ledger-3.1.2.ebuild b/app-office/ledger/ledger-3.1.2.ebuild
index 15695c673914..38cba372bc38 100644
--- a/app-office/ledger/ledger-3.1.2.ebuild
+++ b/app-office/ledger/ledger-3.1.2.ebuild
@@ -5,27 +5,24 @@ EAPI=6
PYTHON_COMPAT=( python2_7 )
-inherit check-reqs cmake-utils elisp-common python-single-r1
+inherit check-reqs cmake-utils python-single-r1
DESCRIPTION="A double-entry accounting system with a command-line reporting interface"
HOMEPAGE="https://www.ledger-cli.org/"
SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
SLOT="0"
IUSE="debug doc emacs python"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RESTRICT="test"
-SITEFILE=50${PN}-gentoo.el
-
CHECKREQS_MEMORY=8G
RDEPEND="
dev-libs/boost:=[python?]
dev-libs/gmp:0=
dev-libs/mpfr:0=
- emacs? ( virtual/emacs )
python? (
dev-libs/boost:=[${PYTHON_USEDEP}]
dev-python/cheetah
@@ -42,8 +39,6 @@ DEPEND="
)
"
-PATCHES=()
-
# Building with python integration seems to fail without 8G available
# RAM(!) Since the memory check in check-reqs doesn't count swap, it
# may be unfair to fail the build entirely on the memory test alone.
@@ -82,8 +77,6 @@ src_prepare() {
|| die "Failed to update info file name in file contents"
mv doc/ledger{3,}.texi || die "Failed to rename info file name"
-
- eapply_user
}
src_configure() {
@@ -108,21 +101,14 @@ src_compile() {
src_install() {
cmake-utils_src_install
-
- use emacs && elisp-site-file-install "${FILESDIR}/${SITEFILE}"
}
pkg_postinst() {
- use emacs && elisp-site-regen
-
- einfo
- einfo "Since version 3, vim support is released separately."
- einfo "See https://github.com/ledger/vim-ledger"
- einfo
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
+ elog
+ elog "Since version 3, vim support is released separately."
+ elog "See https://github.com/ledger/vim-ledger"
+ elog
+ elog "For Emacs mode, emerge app-emacs/ledger-mode"
}
# rainy day TODO: