summaryrefslogtreecommitdiff
path: root/app-office/kmymoney/kmymoney-5.0.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-25 19:33:39 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-28 08:31:11 +0100
commitad6182343997a405079870a2fe91c4e0c6b94595 (patch)
tree4aa7483cd0ad7de54338afc8e7971417abe1dd81 /app-office/kmymoney/kmymoney-5.0.6.ebuild
parente8f81810baa21f490d6910e8e2d424546b72a333 (diff)
gentoo resync : 25.09.2019
Diffstat (limited to 'app-office/kmymoney/kmymoney-5.0.6.ebuild')
-rw-r--r--app-office/kmymoney/kmymoney-5.0.6.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/app-office/kmymoney/kmymoney-5.0.6.ebuild b/app-office/kmymoney/kmymoney-5.0.6.ebuild
index 86b2bc4fc862..e7469b835648 100644
--- a/app-office/kmymoney/kmymoney-5.0.6.ebuild
+++ b/app-office/kmymoney/kmymoney-5.0.6.ebuild
@@ -20,7 +20,7 @@ if [[ ${KDE_BUILD_TYPE} = release ]]; then
fi
LICENSE="GPL-2"
-IUSE="activities addressbook calendar holidays ofx quotes webkit weboob"
+IUSE="activities addressbook calendar hbci holidays ofx quotes webkit weboob"
REQUIRED_USE="weboob? ( ${PYTHON_REQUIRED_USE} )"
@@ -66,6 +66,10 @@ COMMON_DEPEND="
$(add_kdeapps_dep kidentitymanagement)
)
calendar? ( dev-libs/libical:= )
+ hbci? (
+ >=net-libs/aqbanking-5.8.2
+ >=sys-libs/gwenhywfar-4.20.2[qt5]
+ )
holidays? ( $(add_frameworks_dep kholidays) )
ofx? ( dev-libs/libofx )
webkit? (
@@ -99,8 +103,8 @@ src_configure() {
$(cmake-utils_use_find_package addressbook KF5Akonadi)
$(cmake-utils_use_find_package addressbook KF5Contacts)
$(cmake-utils_use_find_package addressbook KF5IdentityManagement)
- -DENABLE_KBANKING=OFF
-DENABLE_LIBICAL=$(usex calendar)
+ -DENABLE_KBANKING=$(usex hbci)
$(cmake-utils_use_find_package holidays KF5Holidays)
-DENABLE_OFXIMPORTER=$(usex ofx)
-DENABLE_WEBENGINE=$(usex !webkit)