summaryrefslogtreecommitdiff
path: root/app-office/kmymoney/files/kmymoney-4.8.0-alkimia-detect.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-office/kmymoney/files/kmymoney-4.8.0-alkimia-detect.patch
reinit the tree, so we can have metadata
Diffstat (limited to 'app-office/kmymoney/files/kmymoney-4.8.0-alkimia-detect.patch')
-rw-r--r--app-office/kmymoney/files/kmymoney-4.8.0-alkimia-detect.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-office/kmymoney/files/kmymoney-4.8.0-alkimia-detect.patch b/app-office/kmymoney/files/kmymoney-4.8.0-alkimia-detect.patch
new file mode 100644
index 000000000000..628e7c87538e
--- /dev/null
+++ b/app-office/kmymoney/files/kmymoney-4.8.0-alkimia-detect.patch
@@ -0,0 +1,29 @@
+Some 8 cmake patches were necessary to get libalkimia detection right.
+This just copies the current state of 4.8 branch.
+
+--- a/CMakeLists.txt 2016-10-26 12:17:23.390317411 +0200
++++ b/CMakeLists.txt 2016-10-26 12:17:53.750544101 +0200
+@@ -110,14 +110,21 @@
+ add_custom_target(apidoc ${DOXYGEN} ${CMAKE_CURRENT_BINARY_DIR}/kmymoney.doxygen)
+ endif(DOXYGEN_FOUND)
+
+-find_package(LibAlkimia 4.3.2 REQUIRED)
++find_package(LibAlkimia REQUIRED)
+ #TODO: remove when LibAlkimia minimum version will be raised
+ if (NOT LIBALKIMIA_LIBRARIES AND LIBALKIMIA_LIBRARY)
+ # LibAlkimia 4.3.2 does not properly define LIBALKIMIA_LIBRARIES
+ find_package(GMP REQUIRED)
+ set(LIBALKIMIA_LIBRARIES ${GMP_LIBRARIES} ${LIBALKIMIA_LIBRARY} )
+ endif()
+-
++# make sure we have the matching version of LibAlkimia (not too new)
++if(${LibAlkimia_FOUND})
++ if (DEFINED ${LibAlkimia_VERSION})
++ if (NOT "${LibAlkimia_VERSION}" VERSION_LESS "6.0.0")
++ message(FATAL_ERROR "This version of KMyMoney requires LibAlkimia < 6.0.0 and does not work with the installed version of LibAlkimia")
++ endif()
++ endif()
++endif()
+ # check for PkgConfig
+ find_package(PkgConfig)
+