summaryrefslogtreecommitdiff
path: root/app-office/impressive
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
commitf78108598211053d41752a83e0345441bb9014ae (patch)
treedd2fc7ae0a1aea7bda4942ab0c453d1e55284b37 /app-office/impressive
parentdc45b83b28fb83e9659492066e347b8dc60bc9e3 (diff)
gentoo resync : 11.02.2018
Diffstat (limited to 'app-office/impressive')
-rw-r--r--app-office/impressive/Manifest2
-rw-r--r--app-office/impressive/impressive-0.12.0.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/app-office/impressive/Manifest b/app-office/impressive/Manifest
index 38cedfa318e3..559c2cec11a2 100644
--- a/app-office/impressive/Manifest
+++ b/app-office/impressive/Manifest
@@ -1,3 +1,5 @@
DIST Impressive-0.11.2.tar.gz 198391 BLAKE2B e0157a910b61c7dbe0796193b3d18f533210de50568d835e5204a848a5ac4978ab228b633d5137fb068af09a88d0c50fc2dbbb02b9b0d1a32a99f9de220ac1de SHA512 cabb52612f65ddadfb080e3db6417680a1aa9724fe45d8b78a1206b6508a8b60c5e5a7c218ff0f90e62adcd498aabe625837164fc547604dfd7aba425db87dd6
+DIST Impressive-0.12.0.tar.gz 209514 BLAKE2B aef0c793c85c680c65399cfcef56488c558ec49a8246d55bacc05a2e1fa0de51d548ddcf67788d36a4de91d62495a623269976345f99d63d25f3ae8bc9efdbd8 SHA512 3425d9d53c8c3ff6d5de0a3466bbf5c94f257390b4929ba12547ba930099de67db4f4d77d4ef4e3e10f8f723478569a74042553f64cf95e236931c7aabb70f0a
EBUILD impressive-0.11.2.ebuild 1207 BLAKE2B c73ead27403b1bb04f82e179f0a9a3b7d9f9b15ac70b710a7c118c381f89707156ac7a794c63440958d91cf1ea627b1db662f80978d3ace4c1194bf5076b7c6d SHA512 ff208fa50780c520dbb3bc1e29e448ef02edad0036576ceb9a3afe017f811345b6e2d156811bdf5c77c6512096e781b5e75cb602daa194871be81a83ff3a397c
+EBUILD impressive-0.12.0.ebuild 1265 BLAKE2B baed9b95cc4d0a9682bdd31b549053ffa009c08114cdab0324c038927742f53921cfe671601728291f1211affbab946f49242b226ba7d518ca41031de5b53965 SHA512 6adecd2c3e2d1658f379739c0a715b2f5fc8d5b93a035d8a4ecfdcfcbecb582d6b77ee7ba7bc14cbc4a65d87b9c46daf4338bf7902aa2c44d49da890419ff78f
MISC metadata.xml 333 BLAKE2B 145c89f4cff6275c14079657c04fd3806149b7d24e497df4673a09e868b2deb9cd3fea9bd888765aa7a7301148d71db47dd1a4100695cc5fbf6e268dd72c81ac SHA512 2c4d3cf1dbcadd548b1999c81105be623a9347e0ec290f21be1333ecf64649d75e3a3f6ddcbf61cefbb80a5053897aa94abaf976bdf5a2d0a18135e760e70a23
diff --git a/app-office/impressive/impressive-0.12.0.ebuild b/app-office/impressive/impressive-0.12.0.ebuild
new file mode 100644
index 000000000000..6f865b6ac5e2
--- /dev/null
+++ b/app-office/impressive/impressive-0.12.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-r1
+
+MY_PN="Impressive"
+
+DESCRIPTION="Stylish way of giving presentations with Python"
+HOMEPAGE="http://impressive.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}/${PV%b}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${PYTHON_DEPS}
+ dev-python/pygame[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ x11-apps/xrandr
+ app-text/mupdf
+ || ( media-fonts/dejavu media-fonts/corefonts )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DOCS=(
+ changelog.txt
+ demo.pdf
+)
+HTML_DOCS=(
+ impressive.html
+)
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_install() {
+ default
+ python_foreach_impl python_doscript ${PN}.py
+ doman impressive.1
+}
+
+pkg_postinst() {
+ elog "The experience with ${PN} can be enhanced by folowing packages:"
+ optfeature "starting web or e-mail hyperlinks from PDF documents" x11-misc/xdg-utils
+ optfeature "sound and video playback" media-video/ffmpeg
+ optfeature "sound and video playback" media-video/mplayer
+ optfeature "sound and video playback" media-video/mplayer2
+ optfeature "extraction of PDF page titles" app-text/pdftk
+}