summaryrefslogtreecommitdiff
path: root/app-office/impressive
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-21 20:47:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-21 20:47:17 +0000
commit4ab6db5717ef23f29320d4c6fb9ebdb8dec1f193 (patch)
treef7640b8b96a04499f1ce44a2cad122d45a8373bd /app-office/impressive
parent48bdeb0db9c7ffed22c6eb859ee40b55ba598b86 (diff)
gentoo resync : 21.12.2017
Diffstat (limited to 'app-office/impressive')
-rw-r--r--app-office/impressive/Manifest2
-rw-r--r--app-office/impressive/impressive-0.11.2.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/app-office/impressive/Manifest b/app-office/impressive/Manifest
index 4ad20f69d2dd..5efd8a23d7a8 100644
--- a/app-office/impressive/Manifest
+++ b/app-office/impressive/Manifest
@@ -1,5 +1,7 @@
DIST Impressive-0.10.5.tar.gz 166707 BLAKE2B 2d5ef9d05d82a22af037fda0e0b01252d513ee0686f9ab21f1d24cf86b4e0a5043aaf7f16b3d9d8a6773b110f716948c184a058845d7595155a40410821c8ccf SHA512 3939188d45ac7a617a56be72e72c98923c23073bee2c3c1b7b81fc2e26ce415ceffdf5456d754f921e488181d8edb7df96ad90e6923b2425c49e38da75c02f20
DIST Impressive-0.11.0b.tar.gz 195138 BLAKE2B daa8e7bc17ec028a9c858688182a4cd6426004aaec24b7ea1574cd415a7f43f0d8a0ae43b01089d66a66c16b316439454341a3f6c2d366768a351ba2fff85b93 SHA512 c4038ed7b71ac79078922ee0e24ce3bef4b0384d8d468291f0283266fe8a849825f5798ec1260e40ac12659a8a7cf5325e3aca0e2475b1c483d3ce830f4bc70f
+DIST Impressive-0.11.2.tar.gz 198391 BLAKE2B e0157a910b61c7dbe0796193b3d18f533210de50568d835e5204a848a5ac4978ab228b633d5137fb068af09a88d0c50fc2dbbb02b9b0d1a32a99f9de220ac1de SHA512 cabb52612f65ddadfb080e3db6417680a1aa9724fe45d8b78a1206b6508a8b60c5e5a7c218ff0f90e62adcd498aabe625837164fc547604dfd7aba425db87dd6
EBUILD impressive-0.10.5.ebuild 1055 BLAKE2B e004b2eae93fd347426be12630d2479cc795de7ded0c5035f2ff9cf209c5ff121a0f228b1449b60b854e53e0aef0a857f756c4fee7ded31a031db1eea2f65cb0 SHA512 ae386fbff67cbdb3c0771e36fd6f6d6bc9e36e75249b84fb94b384043a340a6a4cff28f9e3838d98dea4addf9d59b7ad8afe248afabab520ad03a7ad25a63bf6
EBUILD impressive-0.11.0b-r1.ebuild 1569 BLAKE2B 1bb6419133a543493ac336227053696a973e6260a0e63ae9c857a710ba7d38094b1992da33fa75031bdf090f39b4e9e7dadcb2f09a2a40b71433baad7ccc8adf SHA512 908f2fea69536f8e93dda6f856d7d5cd297f178e684d01b28b5a925cb19258bfd653d876c84db3f5dcdc75fae2dae8f28d5162e988a34d1d6931e23bf5331c73
+EBUILD impressive-0.11.2.ebuild 1207 BLAKE2B c73ead27403b1bb04f82e179f0a9a3b7d9f9b15ac70b710a7c118c381f89707156ac7a794c63440958d91cf1ea627b1db662f80978d3ace4c1194bf5076b7c6d SHA512 ff208fa50780c520dbb3bc1e29e448ef02edad0036576ceb9a3afe017f811345b6e2d156811bdf5c77c6512096e781b5e75cb602daa194871be81a83ff3a397c
MISC metadata.xml 333 BLAKE2B 145c89f4cff6275c14079657c04fd3806149b7d24e497df4673a09e868b2deb9cd3fea9bd888765aa7a7301148d71db47dd1a4100695cc5fbf6e268dd72c81ac SHA512 2c4d3cf1dbcadd548b1999c81105be623a9347e0ec290f21be1333ecf64649d75e3a3f6ddcbf61cefbb80a5053897aa94abaf976bdf5a2d0a18135e760e70a23
diff --git a/app-office/impressive/impressive-0.11.2.ebuild b/app-office/impressive/impressive-0.11.2.ebuild
new file mode 100644
index 000000000000..14227452dabf
--- /dev/null
+++ b/app-office/impressive/impressive-0.11.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-r1
+
+MY_PN="Impressive"
+
+DESCRIPTION="Stylish way of giving presentations with Python"
+HOMEPAGE="http://impressive.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}/${PV%b}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${PYTHON_DEPS}
+ dev-python/pygame[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ x11-apps/xrandr
+ app-text/mupdf
+ || ( media-fonts/dejavu media-fonts/corefonts )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DOCS=(
+ changelog.txt
+ demo.pdf
+)
+HTML_DOCS=(
+ impressive.html
+)
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_install() {
+ default
+ python_foreach_impl python_doscript ${PN}.py
+ doman impressive.1
+}
+
+pkg_postinst() {
+ elog "The experience with ${PN} can be enhanced by folowing packages:"
+ optfeature "starting web or e-mail hyperlinks from PDF documents" x11-misc/xdg-utils
+ optfeature "sound and video playback" media-video/mplayer
+ optfeature "sound and video playback" media-video/mplayer2
+ optfeature "extraction of PDF page titles" app-text/pdftk
+}