summaryrefslogtreecommitdiff
path: root/app-office/impressive
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /app-office/impressive
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'app-office/impressive')
-rw-r--r--app-office/impressive/Manifest2
-rw-r--r--app-office/impressive/impressive-0.13.1.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/app-office/impressive/Manifest b/app-office/impressive/Manifest
index 3893cb813b13..e4d06dca5997 100644
--- a/app-office/impressive/Manifest
+++ b/app-office/impressive/Manifest
@@ -1,3 +1,5 @@
DIST Impressive-0.13.0-beta2.tar.gz 311905 BLAKE2B fb912ada1f44b2af9bd1eed4c7e1d4bfae5ba42449a9b1a154500a9d892c1070c9da127c8c3cbd35ce033a768a00db359deb1a045996cfeb7253f92d289aed82 SHA512 45c094d30e898a1843869cdcd490315c8280bbe2f5cc58f7695be2f0876075718517a502af16e040981b3f3a8fd955000d9ff76e20850b4bedf52c0d2bbd098e
+DIST Impressive-0.13.1.tar.gz 215989 BLAKE2B 6591e5fa2c34e7e6f2283b9b6f8cce7485fc8932eea571af96c895bbe23202af195eec0318272667d5656f3aed7a88a21a20397224c7c0cc7c9252364d832371 SHA512 f6221337f9dd79f552fb083e1ea7484aeadec1f8d8e05b4e1b7f6a94037b5026022819b346968dea67dbdb1b646d0571a7aeef26f15c25bee88c5b9c2791cf2b
EBUILD impressive-0.13.0_beta2.ebuild 1111 BLAKE2B ab86830dcaebf3e0a5d31576bad253de2acb682f1ce26136567a4454cc65872cd8994cc022f1899f3e5a47ee6403d95697d807436f458abe403d4eca18c541d7 SHA512 f3472955cce7e0432637c9bc419a388af645a2ffff187020914117da60c941b862b880a34f8af8c37b5eb4ad77396103b11a2f988d7084c2cd5ec6e920f906b0
+EBUILD impressive-0.13.1.ebuild 1111 BLAKE2B 509a9692bedee47a6ea2020c623f7c13f15fc0308341b19ac3f3f651f96183115fa0d813f931729488ba0fe0654298f2e01984b68a164745630b1c4c8b54263d SHA512 f03bab1beb8e4b14715e76044a8999ec66a3baa266bc1e725a1a02ce6d28f472cf86e5f127d586c1d9bd7cef72ef4d258e00be923d52aae750c145f8c0ce270c
MISC metadata.xml 334 BLAKE2B 089a7116fcde8065143cfbea3f87f29e676572c8ca9b4e6f2f12c613e7ed58a14fd611b1d55ec8ca3076e2ed852a941dd31b83988440031ad4c338f5b34ed5a2 SHA512 a1b63c4ed0631ff2762219e836519b753840e847cd79423eb14a84b2617fae29b0be16b1dac30c3a8c4589fe1c027c06a2fdff3f7f23909d8b7913b057736623
diff --git a/app-office/impressive/impressive-0.13.1.ebuild b/app-office/impressive/impressive-0.13.1.ebuild
new file mode 100644
index 000000000000..298f8cb868f6
--- /dev/null
+++ b/app-office/impressive/impressive-0.13.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit optfeature python-r1
+
+DESCRIPTION="Stylish way of giving presentations with Python"
+HOMEPAGE="http://impressive.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN^}/${PV/_/-}/${PN^}-${PV/_/-}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ app-text/mupdf
+ dev-python/pygame[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ x11-apps/xrandr
+ || (
+ media-fonts/dejavu
+ media-fonts/corefonts
+ )
+"
+
+DOCS=( changelog.txt demo.pdf )
+HTML_DOCS=( impressive.html )
+
+S="${WORKDIR}/${PN^}-${PV/_/-}"
+
+src_install() {
+ default
+ python_foreach_impl python_doscript ${PN}.py
+ doman impressive.1
+}
+
+pkg_postinst() {
+ optfeature "starting web or e-mail hyperlinks from PDF documents" x11-misc/xdg-utils
+ optfeature "sound and video playback" media-video/ffmpeg
+ optfeature "sound and video playback" media-video/mplayer
+ optfeature "extraction of PDF page titles" app-text/pdftk
+}