summaryrefslogtreecommitdiff
path: root/app-office/gnumeric
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
commitf78108598211053d41752a83e0345441bb9014ae (patch)
treedd2fc7ae0a1aea7bda4942ab0c453d1e55284b37 /app-office/gnumeric
parentdc45b83b28fb83e9659492066e347b8dc60bc9e3 (diff)
gentoo resync : 11.02.2018
Diffstat (limited to 'app-office/gnumeric')
-rw-r--r--app-office/gnumeric/Manifest2
-rw-r--r--app-office/gnumeric/gnumeric-1.12.38.ebuild64
2 files changed, 66 insertions, 0 deletions
diff --git a/app-office/gnumeric/Manifest b/app-office/gnumeric/Manifest
index 6941c28b4f03..3a38220ab6ba 100644
--- a/app-office/gnumeric/Manifest
+++ b/app-office/gnumeric/Manifest
@@ -1,3 +1,5 @@
DIST gnumeric-1.12.35.tar.xz 20019316 BLAKE2B 45e0097c37c05dc6295994434b9d181f447a1edca2080f699f5bd73112e794014449fe863890389f6d17370f834e9a79c1f3a1e094d3556de09956a712b63088 SHA512 0781c0d003342653a7cb57d2f23d1222903f18fdce15f4276250aae66239fc5f0da6472d900a59d29b511fbf55b529f7923a68f346752cd242775d52f99aba11
+DIST gnumeric-1.12.38.tar.xz 19807364 BLAKE2B 5b250991d2a635334d1799b421733a50cbe5dc92c3b792f0c8f3635a37bb72601f62e444ed7cb705ae7456b804fd16e8ab7c1b6567db27a9f12b4b5407b30e1b SHA512 71cf29355b865a3c0f966482ef0cbc90553326fcdc10103762d6c35c1f932371b5dffa3d3d89cd575d3f202ba041e4caaf987db08051b700757ea165508ea217
EBUILD gnumeric-1.12.35.ebuild 1481 BLAKE2B 00e05f12dfbbe7e2fd1b0dcfa7c1e976dbeda972e26f5837753f12498a0d9e66ee2470551a961850c0b0cfab4f948bdf6763d5a895119e6ed3ac5b2543f5e1c3 SHA512 46a82a1ea94eefe58396928f2c81d342fd56e4b6f11b5492f914980efd80dd80f0366346a1e29d1a32a299780af9cd95d6cacefa01b8df39a8bbe3624224a49c
+EBUILD gnumeric-1.12.38.ebuild 1483 BLAKE2B 348c5face71c7d5b3fdb17542e9e10e5fedbcdd9e288b1a026ea2f74983aaa7e4dcdd3e0b310707739ad2d16459daa6755abcffd632d46a6f0cb8c90445a87c2 SHA512 8b209d8b0614a5f587daa8dabbbfbf39d1be558191abd0d169bf9fda53315cdad74dfef24f6a0113956f65eef87877814fb1a177d00834abcde003c9c4dfa4e9
MISC metadata.xml 465 BLAKE2B c246609f5d6b20c968faeb36a0c6e33df41ae8a373360ed003541fdf816ff9399f62ababfc4aea5c557bcf9dac83a71357ce9e789ca08d94e83cdeda83aaa275 SHA512 753783aee82021a573093a0ecb7807bdf56d037032fb1afa5559db44b1d06f72bdf9aedfead48cae9917d78aaa7c39d19e528946ef45b51fd6cf5357b9b020fa
diff --git a/app-office/gnumeric/gnumeric-1.12.38.ebuild b/app-office/gnumeric/gnumeric-1.12.38.ebuild
new file mode 100644
index 000000000000..4c5b03f89eb7
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-1.12.38.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 flag-o-matic python-single-r1
+
+DESCRIPTION="The GNOME Spreadsheet"
+HOMEPAGE="http://www.gnumeric.org/"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="+introspection libgda perl python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# Missing gnome-extra/libgnomedb required version in tree
+# but its upstream is dead and will be dropped soon.
+
+# lots of missing files, also fails tests due to 80-bit long story
+# upstream bug #721556
+RESTRICT="test"
+
+RDEPEND="
+ app-arch/bzip2
+ sys-libs/zlib
+ >=dev-libs/glib-2.38.0:2
+ >=gnome-extra/libgsf-1.14.33:=
+ >=x11-libs/goffice-0.10.38:0.10
+ >=dev-libs/libxml2-2.4.12:2
+ >=x11-libs/pango-1.24.0:=
+
+ >=x11-libs/gtk+-3.8.7:3
+ x11-libs/cairo:=[svg]
+
+ introspection? ( >=dev-libs/gobject-introspection-1:= )
+ perl? ( dev-lang/perl:= )
+ python? ( ${PYTHON_DEPS}
+ >=dev-python/pygobject-3:3[${PYTHON_USEDEP}] )
+ libgda? ( gnome-extra/libgda:5[gtk] )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35.0
+ app-text/yelp-tools
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --with-zlib \
+ $(use_with libgda gda) \
+ $(use_enable introspection) \
+ $(use_with perl) \
+ $(use_with python)
+}