summaryrefslogtreecommitdiff
path: root/app-office/gnumeric
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
commitb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (patch)
tree911928b566777494d08ebe2c16cb64f15af71901 /app-office/gnumeric
parent61f10f985e19dfe20a4d9552902625edd5b6eabb (diff)
gentoo resync : 24.06.2021
Diffstat (limited to 'app-office/gnumeric')
-rw-r--r--app-office/gnumeric/Manifest2
-rw-r--r--app-office/gnumeric/gnumeric-1.12.50.ebuild93
2 files changed, 95 insertions, 0 deletions
diff --git a/app-office/gnumeric/Manifest b/app-office/gnumeric/Manifest
index 3c3288d750b9..0cb656c2641c 100644
--- a/app-office/gnumeric/Manifest
+++ b/app-office/gnumeric/Manifest
@@ -1,3 +1,5 @@
DIST gnumeric-1.12.49.tar.xz 18057896 BLAKE2B 75ae1683feb7f37cdff4cb5fbec04b0f241e4590236ea68706180853c1a950092bf0d902652d65288b42dba13c384e1ac364cefb32b9d60c37a9948d9d7fc8eb SHA512 047d625aee3a15dd8881f2e11cc7c67d211d40be86ec018517d1b3140ff4bd031fb2cb86e48f1f6ee22432aa1f39c978bad5fd5bf5c6a1be9aa53411136429ed
+DIST gnumeric-1.12.50.tar.xz 18062104 BLAKE2B 46d15e5fe540cce904de07b263707d7fd8c29d9a2611105cdb117a3acd6693651e588b4d281038b48fbc36bba100d162c2c2ab1be589ea206272155cbd9046df SHA512 d5896cb8390c99fb3871c722116cc085b93b788fab91bf44d24f20228b8290170a0adc906160a6aa46431ae43b04079621c370dcda42658fa9ae3c1d8baf1730
EBUILD gnumeric-1.12.49.ebuild 2292 BLAKE2B b4ed27e762e99bdfb954c4779b442583e4dbfb721af03cd77567073b3673cfa73e7e4bd3b30a03dc9106b034897384a63225b8c31790227d06192aa156110f5e SHA512 c29a402fbb48e7f566203f3bbc85a9be15a152b954f78e5ca155f87862fab5007a69e90c1b7f4a3b9aa03c04183b04f41f5764721601fc1f814640f9db8666c5
+EBUILD gnumeric-1.12.50.ebuild 2294 BLAKE2B 17a7af8994d49197577a7b48014b213f6ea1ba3138d2d6a6ea2f58241d140d6f4c14f277e1bfd6df88d4c3537c3366c6323397817e5d64cf2c57d4c124102d84 SHA512 cc5b717029d0975d6a88064a51a06c6626382c86543de20b6f040b19d4dd37eb97f69e520439f9b395717d432b10902f44195f476b71f91750babe44caaa355e
MISC metadata.xml 519 BLAKE2B 07b0ba6ff606de990d5fb97de46aa20f0581ab63f789f2238446e6f87dc93283a0873dfec3ee4a3fd38372aa3fa17e50349abffbd5eb5cc73d4cbdbffe1e5592 SHA512 a03730e0ccc7c2fb4df57f0d63da93e9254c8df99594a26215ff9919302919eb0bfdd21622b9d73f84011c5cd28397cc0b5b2add2fce0624d7a59fc1877601d3
diff --git a/app-office/gnumeric/gnumeric-1.12.50.ebuild b/app-office/gnumeric/gnumeric-1.12.50.ebuild
new file mode 100644
index 000000000000..63de219a0b6a
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-1.12.50.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit gnome.org libtool python-r1 xdg
+
+DESCRIPTION="The GNOME Spreadsheet"
+HOMEPAGE="http://www.gnumeric.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+introspection libgda perl"
+REQUIRED_USE="introspection? ( ${PYTHON_REQUIRED_USE} )"
+
+# Missing gnome-extra/libgnomedb required version in tree
+# but its upstream is dead and will be dropped soon.
+
+# lots of missing files, also fails tests due to 80-bit long story
+# upstream bug #721556
+RESTRICT="test"
+
+# Gnumeric has two python components
+# 1. The python loader for loading python-based plugins.
+# This component is pure python 2 and a port "is not currently being worked on".
+# 2. The python gobject-based introspection API. This component is compatible
+# with python 3.
+# Component 1. can only be re-enabled once someone has ported the upstream
+# codebase to python 3.
+# https://gitlab.gnome.org/GNOME/gnumeric/issues/419#note_618852
+RDEPEND="
+ app-arch/bzip2
+ sys-libs/zlib
+ >=dev-libs/glib-2.40.0:2
+ >=gnome-extra/libgsf-1.14.33:=
+ >=x11-libs/goffice-0.10.50:0.10
+ >=dev-libs/libxml2-2.4.12:2
+ >=x11-libs/pango-1.24.0:=
+
+ >=x11-libs/gtk+-3.8.7:3
+ x11-libs/cairo:=[svg]
+
+ introspection? (
+ ${PYTHON_DEPS}
+ >=dev-libs/gobject-introspection-1:=
+ )
+ perl? ( dev-lang/perl:= )
+ libgda? ( gnome-extra/libgda:5[gtk] )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.5
+ app-text/yelp-tools
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # Manage gi overrides ourselves
+ sed '/SUBDIRS/ s/introspection//' -i Makefile.{am,in} || die
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --disable-gtk-doc \
+ --disable-maintainer-mode \
+ --disable-schemas-compile \
+ --disable-static \
+ --without-psiconv \
+ --without-python \
+ --with-zlib \
+ $(use_with libgda gda) \
+ $(use_enable introspection) \
+ $(use_with perl)
+}
+
+src_install() {
+ default
+ dodoc HACKING MAINTAINERS
+
+ if use introspection; then
+ python_moduleinto gi.overrides
+ python_foreach_impl python_domodule introspection/gi/overrides/Gnm.py
+ fi
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}