summaryrefslogtreecommitdiff
path: root/app-office/gnumeric
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-23 06:54:34 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-23 06:54:34 +0000
commit9a1d1c6b10a4640cea10e7040ed173cf593f4cab (patch)
tree10b7aaa9608311a4b8a7561c6a8da3003ebb061d /app-office/gnumeric
parentdefbebad0d311b0ce0694b17989a9f26cf000250 (diff)
gentoo auto-resync : 23:01:2023 - 06:54:34
Diffstat (limited to 'app-office/gnumeric')
-rw-r--r--app-office/gnumeric/Manifest2
-rw-r--r--app-office/gnumeric/gnumeric-1.12.54.ebuild94
2 files changed, 96 insertions, 0 deletions
diff --git a/app-office/gnumeric/Manifest b/app-office/gnumeric/Manifest
index a11d79f629a7..baddb8a87c8f 100644
--- a/app-office/gnumeric/Manifest
+++ b/app-office/gnumeric/Manifest
@@ -1,3 +1,5 @@
DIST gnumeric-1.12.53.tar.xz 18125272 BLAKE2B 6c25107977492391152c403d2ad6fef79161bc9045660090e12cdd281e5832b4f9e414a0ef5e67f93c10ca789097b510fafed712dcea5b6210f67428a2dc7dd7 SHA512 6e9d7b12f9448c75d39985984fac9880c61583fbac10ad9070f5ec7a5bd573874d79e13372d9a185616a5cdb5f53d3f67aeda6ca4bae33e3f5ca0a2160045d7b
+DIST gnumeric-1.12.54.tar.xz 18127208 BLAKE2B e9ca517d9d305ec0bbd9d1755b2f510b88e4b9311684f83b20edf804eb885ca7951411a44ff15d7b2ff33b9b938a304532f81839c0da75413c08822b51ad2a9c SHA512 6d390373fcd85ee7090a3eaf6a3fc84b7cb3545c5b64ada59fc3c3bfe04b387a08597bdf85e53bd59e11bfd7d40e8f239eff3fd5e5ec775649836507975e7567
EBUILD gnumeric-1.12.53-r1.ebuild 2369 BLAKE2B da511944ca6b23eb1e76d9a6ee1c7a45efedbdadea8b08cd9ae96dc4eefa709c786124eb6ad258ebcd74df3947e1d9d136f1f7c5dd03b1357b75ea8807aa4a87 SHA512 fd5917b5adad8d7a967393353517a3b5dc599c2429c968504a89abc927ea65bd562f7e28ca584770f52c128111cfab63abfbdf3ceb0d75789c090464d8cb4b17
+EBUILD gnumeric-1.12.54.ebuild 2370 BLAKE2B 1597143ef8e5d1cf3d2c02099ce427ad8d01fe4e67543b595b4fddcb747380651106434e26a5f32be20b8b1578114e9026ec4a31feade6535a6b8a1cb431c8be SHA512 e7f5327b600b4dc3cf8a029b357e722341dbb604e75e853241da47fba0a996a83c61f88f0db06eb97520f26c5e17a5921be20d4f973065ca11ccd9ae27f0d266
MISC metadata.xml 627 BLAKE2B 6704cf7889bf073ee97e1af9145395462f326aa44ad6fa04f4cc4908bbde8a486518c0f11e3a9ab887835c0af862868b8a86ca29191ac1bdf179aa060c621020 SHA512 451313a3c0d62af5f647bcdce0ac76bf1948189bb70c555f6aa871245bf3ce62b0ad306c8835a7c42b24333c3e9ce449a209d3d6967e487ec061792969092107
diff --git a/app-office/gnumeric/gnumeric-1.12.54.ebuild b/app-office/gnumeric/gnumeric-1.12.54.ebuild
new file mode 100644
index 000000000000..ed5f860e947f
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-1.12.54.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit autotools gnome.org python-r1 xdg
+
+DESCRIPTION="The GNOME Spreadsheet"
+HOMEPAGE="http://www.gnumeric.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+introspection libgda perl"
+REQUIRED_USE="introspection? ( ${PYTHON_REQUIRED_USE} )"
+
+# Missing gnome-extra/libgnomedb required version in tree
+# but its upstream is dead and will be dropped soon.
+
+# lots of missing files, also fails tests due to 80-bit long story
+# upstream bug #721556
+RESTRICT="test"
+
+# Gnumeric has two python components
+# 1. The python loader for loading python-based plugins.
+# This component is pure python 2 and a port "is not currently being worked on".
+# 2. The python gobject-based introspection API. This component is compatible
+# with python 3.
+# Component 1. can only be re-enabled once someone has ported the upstream
+# codebase to python 3.
+# https://gitlab.gnome.org/GNOME/gnumeric/issues/419#note_618852
+RDEPEND="
+ app-arch/bzip2
+ sys-libs/zlib
+ >=dev-libs/glib-2.40.0:2
+ >=gnome-extra/libgsf-1.14.33:=
+ >=x11-libs/goffice-0.10.51:0.10[introspection?]
+ >=dev-libs/libxml2-2.4.12:2
+ >=x11-libs/pango-1.24.0:=
+
+ >=x11-libs/gtk+-3.8.7:3
+ x11-libs/cairo:=[svg(+)]
+
+ introspection? (
+ ${PYTHON_DEPS}
+ >=dev-libs/gobject-introspection-1:=
+ )
+ perl? ( dev-lang/perl:= )
+ libgda? ( gnome-extra/libgda:5[gtk] )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.5
+ app-text/yelp-tools
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # Manage gi overrides ourselves
+ sed '/SUBDIRS/ s/introspection//' -i Makefile.{am,in} || die
+
+ # Changed from 'elibtoolize' for bug # 791610
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-gtk-doc \
+ --disable-maintainer-mode \
+ --disable-schemas-compile \
+ --disable-static \
+ --without-psiconv \
+ --without-python \
+ --with-zlib \
+ $(use_with libgda gda) \
+ $(use_enable introspection) \
+ $(use_with perl)
+}
+
+src_install() {
+ default
+ dodoc HACKING MAINTAINERS
+
+ if use introspection; then
+ python_moduleinto gi.overrides
+ python_foreach_impl python_domodule introspection/gi/overrides/Gnm.py
+ fi
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}