summaryrefslogtreecommitdiff
path: root/app-office/gnumeric
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-22 05:27:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-22 05:27:18 +0100
commit992aa50a54a56c9e705ca4e85d809ec8989d74a2 (patch)
tree163a97df1174c6bc492ee86ad54667f5267306cf /app-office/gnumeric
parentce5c22ea4ab2c848cb8e0fe7be18977d51f5f0bb (diff)
gentoo auto-resync : 22:09:2022 - 05:27:18
Diffstat (limited to 'app-office/gnumeric')
-rw-r--r--app-office/gnumeric/Manifest2
-rw-r--r--app-office/gnumeric/gnumeric-1.12.53.ebuild94
2 files changed, 96 insertions, 0 deletions
diff --git a/app-office/gnumeric/Manifest b/app-office/gnumeric/Manifest
index 20bf0625a444..e2d2ccf2e904 100644
--- a/app-office/gnumeric/Manifest
+++ b/app-office/gnumeric/Manifest
@@ -1,4 +1,6 @@
AUX gnumeric-1.12.52-slibtool.patch 1489 BLAKE2B aff4a76659bbe81f178baeadea9967870e6a5c38f960bce1287951056eae038cf3c34c7f1e8f7b65aa5999ec9a1474d9e8732b89d432b68ce015dcc96d7a0c27 SHA512 805507509d8fa5702734b74f7c3004001ab3c84e22e14773025b2b53015d3b01bb8acfe7094812e5ad4fac73f8c3e04f2a1d78f99f619bf0f16607d2da0f02aa
DIST gnumeric-1.12.52.tar.xz 18115444 BLAKE2B 6d8489c27b6f7bd0ffad7d255b606a48ca9660dd38973e4bb529d38797a3029db4a0a399e40f69c84ddf33b96d27cfc184fd079fbe16590b92e056c1a836b037 SHA512 3baa2d2c4ed5f740429454f988ea527991febf38f49df17f0d88affe501c676bae95149fb0cdb4b369ef8d32247c1f4fe4c0eeab9a60329e1332aaf9c566f868
+DIST gnumeric-1.12.53.tar.xz 18125272 BLAKE2B 6c25107977492391152c403d2ad6fef79161bc9045660090e12cdd281e5832b4f9e414a0ef5e67f93c10ca789097b510fafed712dcea5b6210f67428a2dc7dd7 SHA512 6e9d7b12f9448c75d39985984fac9880c61583fbac10ad9070f5ec7a5bd573874d79e13372d9a185616a5cdb5f53d3f67aeda6ca4bae33e3f5ca0a2160045d7b
EBUILD gnumeric-1.12.52.ebuild 2423 BLAKE2B 760e90aa2225771c84c6ba69fe018e6f74a832cbadd6d49b9068d9d2d7ac6cd659877fff1b6535a4a345f3b798d517ea5ba884112a7bf487f29c41ddbe601e7b SHA512 8140135fa451576eb3a80d561a96c5d723c46950d5c8c774356384bdac46b8ed42448a499a91384b1c4d92f35968b862a72108c66aeed6d48d7dec10ab23bffd
+EBUILD gnumeric-1.12.53.ebuild 2367 BLAKE2B 50c71f16a28d35a0f19a83ec4791d5f46cbdf527c2b2e5c9b41730fba54753b9c8040f3e3fb05fd43e2d8c9fa969a8ac255321789e922e9e7b201d81597b7a6a SHA512 9f9e676822840d087f2b1bcca95977f2363a683a8994c09b478637d70666eddadc4d1c9160a7e4822681ed127099f8d6c3e1eb54327358088f931ac230dd3389
MISC metadata.xml 520 BLAKE2B cdd4d61e6b2192b820c122370c47ea2ff0c8b4130474a1273f59ccb83d74decccc174632d0a605b17c5d2efd3312409f4afeb45b66adb332b5c5b1fbce305ef9 SHA512 50a15120cea4f1b2cdadac5819bd215175fb4e9e468647f2228b229c1b50fc01c3a35f125b2404ab0c45e4174c028e39873bb91c8a53f7cbb8d0ec488b5c96e7
diff --git a/app-office/gnumeric/gnumeric-1.12.53.ebuild b/app-office/gnumeric/gnumeric-1.12.53.ebuild
new file mode 100644
index 000000000000..2f621517609c
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-1.12.53.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit autotools gnome.org python-r1 xdg
+
+DESCRIPTION="The GNOME Spreadsheet"
+HOMEPAGE="http://www.gnumeric.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+introspection libgda perl"
+REQUIRED_USE="introspection? ( ${PYTHON_REQUIRED_USE} )"
+
+# Missing gnome-extra/libgnomedb required version in tree
+# but its upstream is dead and will be dropped soon.
+
+# lots of missing files, also fails tests due to 80-bit long story
+# upstream bug #721556
+RESTRICT="test"
+
+# Gnumeric has two python components
+# 1. The python loader for loading python-based plugins.
+# This component is pure python 2 and a port "is not currently being worked on".
+# 2. The python gobject-based introspection API. This component is compatible
+# with python 3.
+# Component 1. can only be re-enabled once someone has ported the upstream
+# codebase to python 3.
+# https://gitlab.gnome.org/GNOME/gnumeric/issues/419#note_618852
+RDEPEND="
+ app-arch/bzip2
+ sys-libs/zlib
+ >=dev-libs/glib-2.40.0:2
+ >=gnome-extra/libgsf-1.14.33:=
+ >=x11-libs/goffice-0.10.51:0.10[introspection?]
+ >=dev-libs/libxml2-2.4.12:2
+ >=x11-libs/pango-1.24.0:=
+
+ >=x11-libs/gtk+-3.8.7:3
+ x11-libs/cairo:=[svg]
+
+ introspection? (
+ ${PYTHON_DEPS}
+ >=dev-libs/gobject-introspection-1:=
+ )
+ perl? ( dev-lang/perl:= )
+ libgda? ( gnome-extra/libgda:5[gtk] )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.5
+ app-text/yelp-tools
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # Manage gi overrides ourselves
+ sed '/SUBDIRS/ s/introspection//' -i Makefile.{am,in} || die
+
+ # Changed from 'elibtoolize' for bug # 791610
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-gtk-doc \
+ --disable-maintainer-mode \
+ --disable-schemas-compile \
+ --disable-static \
+ --without-psiconv \
+ --without-python \
+ --with-zlib \
+ $(use_with libgda gda) \
+ $(use_enable introspection) \
+ $(use_with perl)
+}
+
+src_install() {
+ default
+ dodoc HACKING MAINTAINERS
+
+ if use introspection; then
+ python_moduleinto gi.overrides
+ python_foreach_impl python_domodule introspection/gi/overrides/Gnm.py
+ fi
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}