summaryrefslogtreecommitdiff
path: root/app-office/gnumeric
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-17 17:37:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-17 17:37:38 +0000
commit95580151e6cfe563d6c0550936c7fd92e24a6acf (patch)
treed6303b8b93da47cdce9e5f980e29b1f0d4fd83be /app-office/gnumeric
parentf8deb4f754798d63fb6b82178452ee846df8475f (diff)
gentoo auto-resync : 17:02:2024 - 17:37:38
Diffstat (limited to 'app-office/gnumeric')
-rw-r--r--app-office/gnumeric/Manifest2
-rw-r--r--app-office/gnumeric/gnumeric-1.12.57.ebuild93
2 files changed, 95 insertions, 0 deletions
diff --git a/app-office/gnumeric/Manifest b/app-office/gnumeric/Manifest
index e55f94fc01e2..183b7a6a4dc1 100644
--- a/app-office/gnumeric/Manifest
+++ b/app-office/gnumeric/Manifest
@@ -1,5 +1,7 @@
DIST gnumeric-1.12.55.tar.xz 18157492 BLAKE2B 6c084f681e33f00af80cc11dbddf33166877ca30480ae6fc6b65a0ef06271c634e2ba24af55df4c6b306833e2611e959dcbd8b117c97bbf46598419ed4d124e4 SHA512 04127a353d5109e3a31d9a3bd42d6d177366cc6c5d900516b4c8a7a8fcaecc71bd4e2e94876719246841070964b393af97988cafbd6313cea135c1757889e878
DIST gnumeric-1.12.56.tar.xz 18125644 BLAKE2B 0b43ed53dd544dda76ae1401d329f8b029f16117dafb4c2f939c1c48bf61d035e17692485df4034ce77a63031c5477aefd307a04d756c3017fed47354acb4f8a SHA512 badcba4cb08627628c216e4f2429c361d3d8ec7f653b6dda8a451356c798dc0cf323348c0272696a02bd47dd97b95bde0e7b23551cc0f63d8bf470dca219be0d
+DIST gnumeric-1.12.57.tar.xz 18149400 BLAKE2B d268cd2ac260e13be51bca53f4456b9db4d67376c34d15dd6483c1c697f6418120fc31630894fe037979a46277d557fd7b66f226d92d8ab414d87c9c5e27b53f SHA512 67886aff17338c41997cb71d2ee8fcac0f3b9dfc4ef1897b50866844e002ba7867f263daa3aadcaa10ba29746795fad0a4f852bdc22cdd4bc41293c952b69e9d
EBUILD gnumeric-1.12.55.ebuild 2331 BLAKE2B 31bea8d1d8fd1d5826aae9c2be5db02069170d12cbdb2207df749fbcc14a72c2851f173e8483202e10aba2015995ca579006e3fa2fc329285db49fbe92d755a8 SHA512 6954e002b2eb7959d8522825f744eaf24db1c6443f53490fc73de398e0af23725453212ae74eb84d681be73a571b5e0d409c7132ca02c40ffba8d69e5a037311
EBUILD gnumeric-1.12.56.ebuild 2332 BLAKE2B 8f618ee6a7647f317a9eb13bff2d0e955d77e7983d754f19ea3e78c2497ce17da3c896ea55feabc82e2751387ac6582d49bd4130e6162ecba865242916054bff SHA512 6ef6b46f06297ed4c5ef4273ea1ea46b72ceb77b28102618bb5d97b50084ade88db3837ee504c8e8d2bf180f24122d224773d44c129705d9e18ed754f9616867
+EBUILD gnumeric-1.12.57.ebuild 2330 BLAKE2B c620bbff10e3812deb1b837778dd12811f8277fbc5408ad90cf7fd670704cd66b4d3d0074b54a5a9d8646adece4be4f7ed72e9df4fa2d627f7277e784fe242a6 SHA512 379effb5c97d9f1b884362bc62f611f884e3a0a7c29f103d859ba8ba7668724a2bc1277cbb956f6382ed2851734f9f68b4a672eefa894c02b38bbae22f5d8513
MISC metadata.xml 627 BLAKE2B 6704cf7889bf073ee97e1af9145395462f326aa44ad6fa04f4cc4908bbde8a486518c0f11e3a9ab887835c0af862868b8a86ca29191ac1bdf179aa060c621020 SHA512 451313a3c0d62af5f647bcdce0ac76bf1948189bb70c555f6aa871245bf3ce62b0ad306c8835a7c42b24333c3e9ce449a209d3d6967e487ec061792969092107
diff --git a/app-office/gnumeric/gnumeric-1.12.57.ebuild b/app-office/gnumeric/gnumeric-1.12.57.ebuild
new file mode 100644
index 000000000000..3292eef94050
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-1.12.57.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit gnome.org libtool python-r1 xdg
+
+DESCRIPTION="The GNOME Spreadsheet"
+HOMEPAGE="http://www.gnumeric.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+introspection libgda perl"
+REQUIRED_USE="introspection? ( ${PYTHON_REQUIRED_USE} )"
+
+# Missing gnome-extra/libgnomedb required version in tree
+# but its upstream is dead and will be dropped soon.
+
+# lots of missing files, also fails tests due to 80-bit long story
+# upstream bug #721556
+RESTRICT="test"
+
+# Gnumeric has two python components
+# 1. The python loader for loading python-based plugins.
+# This component is pure python 2 and a port "is not currently being worked on".
+# 2. The python gobject-based introspection API. This component is compatible
+# with python 3.
+# Component 1. can only be re-enabled once someone has ported the upstream
+# codebase to python 3.
+# https://gitlab.gnome.org/GNOME/gnumeric/issues/419#note_618852
+RDEPEND="
+ app-arch/bzip2
+ sys-libs/zlib
+ >=dev-libs/glib-2.40.0:2
+ >=gnome-extra/libgsf-1.14.33:=
+ >=x11-libs/goffice-0.10.55:0.10[introspection?]
+ >=dev-libs/libxml2-2.4.12:2
+ >=x11-libs/pango-1.24.0:=
+
+ >=x11-libs/gtk+-3.8.7:3
+ x11-libs/cairo:=[svg(+)]
+
+ introspection? (
+ ${PYTHON_DEPS}
+ >=dev-libs/gobject-introspection-1:=
+ )
+ perl? ( dev-lang/perl:= )
+ libgda? ( gnome-extra/libgda:5[gtk] )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.5
+ app-text/yelp-tools
+ dev-build/gtk-doc-am
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # Manage gi overrides ourselves
+ sed '/SUBDIRS/ s/introspection//' -i Makefile.{am,in} || die
+
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --disable-gtk-doc \
+ --disable-maintainer-mode \
+ --disable-schemas-compile \
+ --disable-static \
+ --without-psiconv \
+ --without-python \
+ --with-zlib \
+ $(use_with libgda gda) \
+ $(use_enable introspection) \
+ $(use_with perl)
+}
+
+src_install() {
+ default
+ dodoc HACKING MAINTAINERS
+
+ if use introspection; then
+ python_moduleinto gi.overrides
+ python_foreach_impl python_domodule introspection/gi/overrides/Gnm.py
+ fi
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}