summaryrefslogtreecommitdiff
path: root/app-office/gnumeric
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /app-office/gnumeric
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'app-office/gnumeric')
-rw-r--r--app-office/gnumeric/Manifest2
-rw-r--r--app-office/gnumeric/gnumeric-1.12.47.ebuild93
2 files changed, 95 insertions, 0 deletions
diff --git a/app-office/gnumeric/Manifest b/app-office/gnumeric/Manifest
index 98fd19c19b16..e19c18548b86 100644
--- a/app-office/gnumeric/Manifest
+++ b/app-office/gnumeric/Manifest
@@ -1,3 +1,5 @@
DIST gnumeric-1.12.46.tar.xz 18282960 BLAKE2B f10fd8620dd2b865a4205b93f68ba78a07b94e72a147692bf875747cb8f128c54fad38e33162770d71422aed659f77b156679ca2f65836530c02b56cc2351ac6 SHA512 b3b3befe79f3ec8db6d7d9c80a1eed5293f5c0a9ca1d8dd131320eb031952b296147c51df1c775c6f9a0c466912e5523360373ee0b6e453e928929394ab517ea
+DIST gnumeric-1.12.47.tar.xz 18309764 BLAKE2B 8b800a6749d208a445abfc7189618abb20907118f274b313cf81436ab3665d50edeab4c49b03adea505448138bd32b8d3efcd041eba54342d9fb293c574cac08 SHA512 f6298fee752b062672acc20e18388d7424719d69ce9586888f33be07ca92bbd7d99e46b98e9ab2a546d1954d3113b59a5105d46c4e8a13e65e1ae9acc38391ab
EBUILD gnumeric-1.12.46.ebuild 2291 BLAKE2B f9c948c25c38cab4435375f8354661a5d3770a6af23960d0e1f63405982052afc44386945b4f5563ae1583888b61df42582bd33cae4f5caeb056126fdd525189 SHA512 e7e00f6701c132b636fc61be08323f59b9c92009d3fdd16fccd4bf6d4e0212c1c8e9d2ee405e2257bc84933bd804c3647a07882b890f710d2d8a7d04bb7f99b4
+EBUILD gnumeric-1.12.47.ebuild 2293 BLAKE2B 455908346275cb6a29e0443ef6b8e913441c03d112495e06735d12330666d7ed64ce7ab1caaa4630be35605c0e056213de95edad0348cc7b41291038b2ba63ae SHA512 67857e31f358494977057ff671844ba65a3a5abb0521a75b5b3af752d26d39d865ad299aa766cd13d0f6ebf5dfe1a302babdb4e5d7909f85041ce07f24fabfa3
MISC metadata.xml 519 BLAKE2B 07b0ba6ff606de990d5fb97de46aa20f0581ab63f789f2238446e6f87dc93283a0873dfec3ee4a3fd38372aa3fa17e50349abffbd5eb5cc73d4cbdbffe1e5592 SHA512 a03730e0ccc7c2fb4df57f0d63da93e9254c8df99594a26215ff9919302919eb0bfdd21622b9d73f84011c5cd28397cc0b5b2add2fce0624d7a59fc1877601d3
diff --git a/app-office/gnumeric/gnumeric-1.12.47.ebuild b/app-office/gnumeric/gnumeric-1.12.47.ebuild
new file mode 100644
index 000000000000..1321853ea988
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-1.12.47.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit gnome.org libtool python-r1 xdg
+
+DESCRIPTION="The GNOME Spreadsheet"
+HOMEPAGE="http://www.gnumeric.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+introspection libgda perl"
+REQUIRED_USE="introspection? ( ${PYTHON_REQUIRED_USE} )"
+
+# Missing gnome-extra/libgnomedb required version in tree
+# but its upstream is dead and will be dropped soon.
+
+# lots of missing files, also fails tests due to 80-bit long story
+# upstream bug #721556
+RESTRICT="test"
+
+# Gnumeric has two python components
+# 1. The python loader for loading python-based plugins.
+# This component is pure python 2 and a port "is not currently being worked on".
+# 2. The python gobject-based introspection API. This component is compatible
+# with python 3.
+# Component 1. can only be re-enabled once someone has ported the upstream
+# codebase to python 3.
+# https://gitlab.gnome.org/GNOME/gnumeric/issues/419#note_618852
+RDEPEND="
+ app-arch/bzip2
+ sys-libs/zlib
+ >=dev-libs/glib-2.40.0:2
+ >=gnome-extra/libgsf-1.14.33:=
+ >=x11-libs/goffice-0.10.46:0.10
+ >=dev-libs/libxml2-2.4.12:2
+ >=x11-libs/pango-1.24.0:=
+
+ >=x11-libs/gtk+-3.8.7:3
+ x11-libs/cairo:=[svg]
+
+ introspection? (
+ ${PYTHON_DEPS}
+ >=dev-libs/gobject-introspection-1:=
+ )
+ perl? ( dev-lang/perl:= )
+ libgda? ( gnome-extra/libgda:5[gtk] )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.5
+ app-text/yelp-tools
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # Manage gi overrides ourselves
+ sed '/SUBDIRS/ s/introspection//' -i Makefile.{am,in} || die
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --disable-gtk-doc \
+ --disable-maintainer-mode \
+ --disable-schemas-compile \
+ --disable-static \
+ --without-psiconv \
+ --without-python \
+ --with-zlib \
+ $(use_with libgda gda) \
+ $(use_enable introspection) \
+ $(use_with perl)
+}
+
+src_install() {
+ default
+ dodoc HACKING MAINTAINERS
+
+ if use introspection; then
+ python_moduleinto gi.overrides
+ python_foreach_impl python_domodule introspection/gi/overrides/Gnm.py
+ fi
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
+}