summaryrefslogtreecommitdiff
path: root/app-office/gnumeric
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-office/gnumeric
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-office/gnumeric')
-rw-r--r--app-office/gnumeric/Manifest5
-rw-r--r--app-office/gnumeric/gnumeric-1.12.38.ebuild64
-rw-r--r--app-office/gnumeric/gnumeric-1.12.39.ebuild64
-rw-r--r--app-office/gnumeric/metadata.xml14
4 files changed, 147 insertions, 0 deletions
diff --git a/app-office/gnumeric/Manifest b/app-office/gnumeric/Manifest
new file mode 100644
index 000000000000..50cad8267b1c
--- /dev/null
+++ b/app-office/gnumeric/Manifest
@@ -0,0 +1,5 @@
+DIST gnumeric-1.12.38.tar.xz 19807364 BLAKE2B 5b250991d2a635334d1799b421733a50cbe5dc92c3b792f0c8f3635a37bb72601f62e444ed7cb705ae7456b804fd16e8ab7c1b6567db27a9f12b4b5407b30e1b SHA512 71cf29355b865a3c0f966482ef0cbc90553326fcdc10103762d6c35c1f932371b5dffa3d3d89cd575d3f202ba041e4caaf987db08051b700757ea165508ea217
+DIST gnumeric-1.12.39.tar.xz 20040688 BLAKE2B 5d99da20b567a939208881b962de3c79ab115a24953dc04d6c882e9a54946e5c5fbd32808a8006e396d70bc9a2a9783b20106536da1c19f7ed7dccd3b12c2fff SHA512 8ae09ea857989e65a8fe2070b30c2309d82daa4142816ef3a1b107035aea0d71498d84eaeeaa870a1587e3785146fad3304321a531c75f6e2f200def53a8e898
+EBUILD gnumeric-1.12.38.ebuild 1481 BLAKE2B b276ce951f9fe55b64c122dbbeef2bba20cfa60c8401c0f6d334a7578b7fb4d4470e79ff811072720e0523235ecf164cc1384a7fa31baed9eef09737413d9e8a SHA512 3d07d4c973902f3b8ad45bb5ceb0c7173ea7d6ee90e604043d04457dbab7b82d29c223f4a1b87e402eac5d1668ed3a631cafa535cbe7b7485639bb9a53ff0c4f
+EBUILD gnumeric-1.12.39.ebuild 1483 BLAKE2B 348c5face71c7d5b3fdb17542e9e10e5fedbcdd9e288b1a026ea2f74983aaa7e4dcdd3e0b310707739ad2d16459daa6755abcffd632d46a6f0cb8c90445a87c2 SHA512 8b209d8b0614a5f587daa8dabbbfbf39d1be558191abd0d169bf9fda53315cdad74dfef24f6a0113956f65eef87877814fb1a177d00834abcde003c9c4dfa4e9
+MISC metadata.xml 465 BLAKE2B c246609f5d6b20c968faeb36a0c6e33df41ae8a373360ed003541fdf816ff9399f62ababfc4aea5c557bcf9dac83a71357ce9e789ca08d94e83cdeda83aaa275 SHA512 753783aee82021a573093a0ecb7807bdf56d037032fb1afa5559db44b1d06f72bdf9aedfead48cae9917d78aaa7c39d19e528946ef45b51fd6cf5357b9b020fa
diff --git a/app-office/gnumeric/gnumeric-1.12.38.ebuild b/app-office/gnumeric/gnumeric-1.12.38.ebuild
new file mode 100644
index 000000000000..95cec2e6148d
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-1.12.38.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 flag-o-matic python-single-r1
+
+DESCRIPTION="The GNOME Spreadsheet"
+HOMEPAGE="http://www.gnumeric.org/"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd"
+
+IUSE="+introspection libgda perl python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# Missing gnome-extra/libgnomedb required version in tree
+# but its upstream is dead and will be dropped soon.
+
+# lots of missing files, also fails tests due to 80-bit long story
+# upstream bug #721556
+RESTRICT="test"
+
+RDEPEND="
+ app-arch/bzip2
+ sys-libs/zlib
+ >=dev-libs/glib-2.38.0:2
+ >=gnome-extra/libgsf-1.14.33:=
+ >=x11-libs/goffice-0.10.38:0.10
+ >=dev-libs/libxml2-2.4.12:2
+ >=x11-libs/pango-1.24.0:=
+
+ >=x11-libs/gtk+-3.8.7:3
+ x11-libs/cairo:=[svg]
+
+ introspection? ( >=dev-libs/gobject-introspection-1:= )
+ perl? ( dev-lang/perl:= )
+ python? ( ${PYTHON_DEPS}
+ >=dev-python/pygobject-3:3[${PYTHON_USEDEP}] )
+ libgda? ( gnome-extra/libgda:5[gtk] )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35.0
+ app-text/yelp-tools
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --with-zlib \
+ $(use_with libgda gda) \
+ $(use_enable introspection) \
+ $(use_with perl) \
+ $(use_with python)
+}
diff --git a/app-office/gnumeric/gnumeric-1.12.39.ebuild b/app-office/gnumeric/gnumeric-1.12.39.ebuild
new file mode 100644
index 000000000000..4c5b03f89eb7
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-1.12.39.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 flag-o-matic python-single-r1
+
+DESCRIPTION="The GNOME Spreadsheet"
+HOMEPAGE="http://www.gnumeric.org/"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="+introspection libgda perl python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# Missing gnome-extra/libgnomedb required version in tree
+# but its upstream is dead and will be dropped soon.
+
+# lots of missing files, also fails tests due to 80-bit long story
+# upstream bug #721556
+RESTRICT="test"
+
+RDEPEND="
+ app-arch/bzip2
+ sys-libs/zlib
+ >=dev-libs/glib-2.38.0:2
+ >=gnome-extra/libgsf-1.14.33:=
+ >=x11-libs/goffice-0.10.38:0.10
+ >=dev-libs/libxml2-2.4.12:2
+ >=x11-libs/pango-1.24.0:=
+
+ >=x11-libs/gtk+-3.8.7:3
+ x11-libs/cairo:=[svg]
+
+ introspection? ( >=dev-libs/gobject-introspection-1:= )
+ perl? ( dev-lang/perl:= )
+ python? ( ${PYTHON_DEPS}
+ >=dev-python/pygobject-3:3[${PYTHON_USEDEP}] )
+ libgda? ( gnome-extra/libgda:5[gtk] )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35.0
+ app-text/yelp-tools
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --with-zlib \
+ $(use_with libgda gda) \
+ $(use_enable introspection) \
+ $(use_with perl) \
+ $(use_with python)
+}
diff --git a/app-office/gnumeric/metadata.xml b/app-office/gnumeric/metadata.xml
new file mode 100644
index 000000000000..056277a49918
--- /dev/null
+++ b/app-office/gnumeric/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+</maintainer>
+<use>
+ <flag name="libgda">Enable database support through
+ <pkg>gnome-extra/libgda</pkg>.</flag>
+ <flag name="python">Enable python plugin loader.</flag>
+ <flag name="perl">Enable perl plugin loader.</flag>
+</use>
+</pkgmetadata>