summaryrefslogtreecommitdiff
path: root/app-office/calligraplan/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /app-office/calligraplan/files
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'app-office/calligraplan/files')
-rw-r--r--app-office/calligraplan/files/calligraplan-3.1.0-kcalcore-19.08-1.patch46
-rw-r--r--app-office/calligraplan/files/calligraplan-3.1.0-kcalcore-19.08-2.patch84
-rw-r--r--app-office/calligraplan/files/calligraplan-3.1.0-kcalcore-19.08-3.patch33
-rw-r--r--app-office/calligraplan/files/calligraplan-3.1.0-missing-header.patch24
-rw-r--r--app-office/calligraplan/files/calligraplan-3.1.0-unused-deps.patch57
5 files changed, 244 insertions, 0 deletions
diff --git a/app-office/calligraplan/files/calligraplan-3.1.0-kcalcore-19.08-1.patch b/app-office/calligraplan/files/calligraplan-3.1.0-kcalcore-19.08-1.patch
new file mode 100644
index 000000000000..cfe8b552d9dc
--- /dev/null
+++ b/app-office/calligraplan/files/calligraplan-3.1.0-kcalcore-19.08-1.patch
@@ -0,0 +1,46 @@
+From 3a01affd66f8dfdcc124e23595217f3ae5a09723 Mon Sep 17 00:00:00 2001
+From: Dag Andersen <danders@get2net.dk>
+Date: Thu, 20 Jun 2019 10:52:00 +0200
+Subject: ICal: Adapt to api changes in KCalCore
+
+---
+ CMakeLists.txt | 37 +++++++++++-----------
+ src/CMakeLists.txt | 4 +++
+ .../filters/icalendar/export/icalendarexport.cpp | 5 +++
+ 3 files changed, 27 insertions(+), 19 deletions(-)
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 0dabbaf..49fa642 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -75,6 +75,10 @@ if ("${KF5CalendarCore_VERSION}" VERSION_GREATER 5.6.40)
+ set(HAVE_QDATETIME_KCALCORE TRUE)
+ endif()
+
++if ("${KF5CalendarCore_VERSION}" VERSION_GREATER 5.11.42)
++ set(KCALCORE_HAVE_NO_PERSION_PTR TRUE)
++endif()
++
+ if (PLANCHARTDEBUG)
+ add_definitions(-DPLAN_CHART_DEBUG)
+ endif ()
+diff --git a/src/plugins/filters/icalendar/export/icalendarexport.cpp b/src/plugins/filters/icalendar/export/icalendarexport.cpp
+index cd75598..ce29bfe 100644
+--- a/src/plugins/filters/icalendar/export/icalendarexport.cpp
++++ b/src/plugins/filters/icalendar/export/icalendarexport.cpp
+@@ -141,8 +141,13 @@ void ICalendarExport::createTodos(KCalCore::Calendar::Ptr cal, const Node *node,
+ todo->setOrganizer(node->projectNode()->leader());
+ }
+ if ( node->type() != Node::Type_Project && ! node->leader().isEmpty()) {
++#if KCALCORE_HAVE_NO_PERSION_PTR
++ KCalCore::Person p = KCalCore::Person::fromFullName(node->leader());
++ KCalCore::Attendee::Ptr a(new KCalCore::Attendee(p.name(), p.email()));
++#else
+ KCalCore::Person::Ptr p = KCalCore::Person::fromFullName(node->leader());
+ KCalCore::Attendee::Ptr a(new KCalCore::Attendee(p->name(), p->email()));
++#endif
+ a->setRole(KCalCore::Attendee::NonParticipant);
+ todo->addAttendee(a);
+ }
+--
+cgit v1.1
diff --git a/app-office/calligraplan/files/calligraplan-3.1.0-kcalcore-19.08-2.patch b/app-office/calligraplan/files/calligraplan-3.1.0-kcalcore-19.08-2.patch
new file mode 100644
index 000000000000..02c67d5ada73
--- /dev/null
+++ b/app-office/calligraplan/files/calligraplan-3.1.0-kcalcore-19.08-2.patch
@@ -0,0 +1,84 @@
+From a9eaf1c98ed408fd6e8897fa9e2f99ed17db1ebc Mon Sep 17 00:00:00 2001
+From: David Faure <faure@kde.org>
+Date: Tue, 23 Jul 2019 12:26:17 +0200
+Subject: Port to KCalCore API changes
+
+The code is in #if 0, but I tested compilation of this in the calligra
+stable branch:
+https://commits.kde.org/calligra/2d484fda1b31a72659088a4bfce5c3708e923cb0
+
+So you can use KCalCore again if you want :-)
+It's turning into a KF5 framework so the API will be stable from now on.
+
+CCMAIL: danders@get2net.dk
+---
+ .../filters/icalendar/export/icalendarexport.cpp | 20 +++++++++++++++++---
+ 1 file changed, 17 insertions(+), 3 deletions(-)
+
+diff --git a/src/plugins/filters/icalendar/export/icalendarexport.cpp b/src/plugins/filters/icalendar/export/icalendarexport.cpp
+index b21320f..828b641 100644
+--- a/src/plugins/filters/icalendar/export/icalendarexport.cpp
++++ b/src/plugins/filters/icalendar/export/icalendarexport.cpp
+@@ -35,6 +35,7 @@
+ #include <kcalcore/attachment.h>
+ #include <kcalcore/icalformat.h>
+ #include <kcalcore/memorycalendar.h>
++#include <kcalcore_version.h>
+
+ #include <QTextCodec>
+ #include <QByteArray>
+@@ -355,14 +356,15 @@ void ICalendarExport::createTodos(KCalCore::Calendar::Ptr cal, const Node *node,
+ todo->setOrganizer(node->projectNode()->leader());
+ }
+ if ( node->type() != Node::Type_Project && ! node->leader().isEmpty()) {
+-#if KCALCORE_HAVE_NO_PERSION_PTR
++#if KCALCORE_VERSION >= QT_VERSION_CHECK(5, 11, 80)
+ KCalCore::Person p = KCalCore::Person::fromFullName(node->leader());
+- KCalCore::Attendee::Ptr a(new KCalCore::Attendee(p.name(), p.email()));
++ KCalCore::Attendee a(p.name(), p.email());
++ a.setRole(KCalCore::Attendee::NonParticipant);
+ #else
+ KCalCore::Person::Ptr p = KCalCore::Person::fromFullName(node->leader());
+ KCalCore::Attendee::Ptr a(new KCalCore::Attendee(p->name(), p->email()));
+-#endif
+ a->setRole(KCalCore::Attendee::NonParticipant);
++#endif
+ todo->addAttendee(a);
+ }
+ DateTime st = node->startTime(id);
+@@ -381,13 +383,21 @@ void ICalendarExport::createTodos(KCalCore::Calendar::Ptr cal, const Node *node,
+ const QList<Resource*> lst = task->requestedResources();
+ foreach(const Resource *r, lst) {
+ if (r->type() == Resource::Type_Work) {
++#if KCALCORE_VERSION >= QT_VERSION_CHECK(5, 11, 80)
++ todo->addAttendee(KCalCore::Attendee(r->name(), r->email()));
++#else
+ todo->addAttendee(KCalCore::Attendee::Ptr(new KCalCore::Attendee(r->name(), r->email())));
++#endif
+ }
+ }
+ } else {
+ foreach(const Resource *r, s->resources()) {
+ if (r->type() == Resource::Type_Work) {
++#if KCALCORE_VERSION >= QT_VERSION_CHECK(5, 11, 80)
++ todo->addAttendee(KCalCore::Attendee(r->name(), r->email()));
++#else
+ todo->addAttendee(KCalCore::Attendee::Ptr(new KCalCore::Attendee(r->name(), r->email())));
++#endif
+ }
+ }
+
+@@ -398,7 +408,11 @@ void ICalendarExport::createTodos(KCalCore::Calendar::Ptr cal, const Node *node,
+ todo->setPercentComplete(task->completion().percentFinished());
+ }
+ foreach(const Document *doc, node->documents().documents()) {
++#if KCALCORE_VERSION >= QT_VERSION_CHECK(5, 11, 80)
++ todo->addAttachment(KCalCore::Attachment(doc->url().url()));
++#else
+ todo->addAttachment(KCalCore::Attachment::Ptr(new KCalCore::Attachment(doc->url().url())));
++#endif
+ }
+ if (! parent.isNull()) {
+ todo->setRelatedTo(parent->uid(), KCalCore::Incidence::RelTypeParent);
+--
+cgit v1.1
diff --git a/app-office/calligraplan/files/calligraplan-3.1.0-kcalcore-19.08-3.patch b/app-office/calligraplan/files/calligraplan-3.1.0-kcalcore-19.08-3.patch
new file mode 100644
index 000000000000..14cc70ab1c8e
--- /dev/null
+++ b/app-office/calligraplan/files/calligraplan-3.1.0-kcalcore-19.08-3.patch
@@ -0,0 +1,33 @@
+From 2f5505cf03ff865349d06e1d5c39007c52e7cd10 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Fri, 16 Aug 2019 15:49:09 +0200
+Subject: [PATCH] Fix headers after kcalcore->kcalendercore rename happened
+
+---
+ .../filters/icalendar/export/icalendarexport.cpp | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/src/plugins/filters/icalendar/export/icalendarexport.cpp b/src/plugins/filters/icalendar/export/icalendarexport.cpp
+index bb6b097d..729d6e50 100644
+--- a/src/plugins/filters/icalendar/export/icalendarexport.cpp
++++ b/src/plugins/filters/icalendar/export/icalendarexport.cpp
+@@ -31,11 +31,11 @@
+ #include <kptdocuments.h>
+ #include "kptdebug.h"
+
+-#include <kcalcore/attendee.h>
+-#include <kcalcore/attachment.h>
+-#include <kcalcore/icalformat.h>
+-#include <kcalcore/memorycalendar.h>
+-#include <kcalcore_version.h>
++#include <kcalendarcore/attendee.h>
++#include <kcalendarcore/attachment.h>
++#include <kcalendarcore/icalformat.h>
++#include <kcalendarcore/memorycalendar.h>
++#include <kcalendarcore_version.h>
+
+ #include <QTextCodec>
+ #include <QByteArray>
+--
+2.22.1
+
diff --git a/app-office/calligraplan/files/calligraplan-3.1.0-missing-header.patch b/app-office/calligraplan/files/calligraplan-3.1.0-missing-header.patch
new file mode 100644
index 000000000000..4ee031865a39
--- /dev/null
+++ b/app-office/calligraplan/files/calligraplan-3.1.0-missing-header.patch
@@ -0,0 +1,24 @@
+From fe36bf6f0dc1f0c1e927850dd78093cfe3b7aae2 Mon Sep 17 00:00:00 2001
+From: Albert Astals Cid <aacid@kde.org>
+Date: Sun, 28 Jul 2019 00:07:33 +0200
+Subject: Fix compile on CI
+
+src/workpackage/view.h:148:31: error: field m_scheduleActions has incomplete type QMap<QAction*, KPlato::Schedule*>
+---
+ src/workpackage/view.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/workpackage/view.h b/src/workpackage/view.h
+index 6cae32b..cd2fc4e 100644
+--- a/src/workpackage/view.h
++++ b/src/workpackage/view.h
+@@ -24,6 +24,7 @@
+
+ #include <KoView.h>
+
++#include <QMap>
+ #include <QStackedWidget>
+
+ class QPrinter;
+--
+cgit v1.1
diff --git a/app-office/calligraplan/files/calligraplan-3.1.0-unused-deps.patch b/app-office/calligraplan/files/calligraplan-3.1.0-unused-deps.patch
new file mode 100644
index 000000000000..707b6c8cdd5a
--- /dev/null
+++ b/app-office/calligraplan/files/calligraplan-3.1.0-unused-deps.patch
@@ -0,0 +1,57 @@
+From 5924e3ad82b5dfc95acf9f6751946d5f086d9ce7 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Tue, 1 Jan 2019 20:13:57 +0100
+Subject: Drop unused dependencies
+
+Test Plan: Built fine with deps removed.
+
+Reviewers: #calligra:_3.0, danders
+
+Reviewed By: #calligra:_3.0, danders
+
+Subscribers: danders
+
+Differential Revision: https://phabricator.kde.org/D17903
+---
+ CMakeLists.txt | 14 ++------------
+ 1 file changed, 2 insertions(+), 12 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 3cb4b63..a6a3c79 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -121,7 +121,6 @@ find_package(KF5 ${REQUIRED_KF5_VERSION} REQUIRED
+ IconThemes
+ ItemViews
+ JobWidgets
+- KCMUtils
+ KIO
+ Notifications
+ # NotifyConfig
+@@ -169,22 +168,13 @@ find_package(Qt5 ${REQUIRED_QT_VERSION} REQUIRED
+ COMPONENTS
+ Core
+ Gui
+- Network
+ PrintSupport
+- Svg
+ Test
+ Widgets
+ Xml
+ )
+- find_package(Qt5 ${REQUIRED_QT_VERSION} QUIET
+- COMPONENTS
+- DBus
+- OpenGL
+- # Quick
+- # Sql
+- # WebKit
+- # WebKitWidgets
+- )
++ find_package(Qt5DBus ${REQUIRED_QT_VERSION} QUIET)
++
+ # Qt5Declarative was removed in Qt 5.6.0 so search for it in a separate call
+ # Including it in a collected find_package(Qt5 ...) call can lead to a fatal not-found error:
+ # * Qt5 (required version >= 5.3.0)
+--
+cgit v1.1