summaryrefslogtreecommitdiff
path: root/app-office/calcurse
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-office/calcurse
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-office/calcurse')
-rw-r--r--app-office/calcurse/Manifest4
-rw-r--r--app-office/calcurse/calcurse-4.3.0.ebuild43
-rw-r--r--app-office/calcurse/files/calcurse-4.2.1-tinfo.patch21
-rw-r--r--app-office/calcurse/metadata.xml12
4 files changed, 80 insertions, 0 deletions
diff --git a/app-office/calcurse/Manifest b/app-office/calcurse/Manifest
new file mode 100644
index 000000000000..53a09b6fcb62
--- /dev/null
+++ b/app-office/calcurse/Manifest
@@ -0,0 +1,4 @@
+AUX calcurse-4.2.1-tinfo.patch 644 BLAKE2B e304953d56dc8891138e909f0b7b31b85b89a16800a1e8efc64a199cb884b730c3123f902ffe2095d392c41cbf0f65b88d440fff2133816b2763ea74a5e44770 SHA512 099ead1b288717e9d9eff331c2fbb9ff8deb19b1843109549ebdab30e8e59cc9cbb01a89c87e84e9283003ce70fc595e2305936a8a0918b0996b5fab1854cb5f
+DIST calcurse-4.3.0.tar.gz 597490 BLAKE2B 7fe31fc09cae12438173d4846a1e4b0a55f9e9416ab23ffc8b78e9d0f621072d8aca96b4161d5659db088e1007f685228e9669aae2d5606939c6564252826e1d SHA512 d948354b512d406f4915ce37107d3f529031e7698d7b38465913ff37120a93283e01f09f5267ebb19bf39ea133d6fac579b218d6dfd6056003b6222f9038f4b3
+EBUILD calcurse-4.3.0.ebuild 700 BLAKE2B b39cb1fb7507d34fdd3aca5255d27f803e30ecbac408f293c28889106a829674f30088881d4bf39ccef25bb1e6b86c60eca492138a2e872363cf35c898d74ed2 SHA512 8a68cdbee97c475c7813677824c9d04a76d4d62ae7a54532d496c3a413b282dfd84607516801bdbddad65efa653131158e8ede34ecd824ef9e40e8b94ebdd5fc
+MISC metadata.xml 593 BLAKE2B 313dee286f4f73406dc3a9a00c8bb59df524df4ac3ced089fea16522d22d99580972c1e52822df1d4c7b527b3c48dce3b825d662458e6194343ec66f2024f73b SHA512 41f0c2a630723427fb5f4033b928c1dc0e4c7bd08f301240458129b08e9baab02141e214b73a393a8c7af58ef1b6f785f701407e111a49b825e5006078caa9a8
diff --git a/app-office/calcurse/calcurse-4.3.0.ebuild b/app-office/calcurse/calcurse-4.3.0.ebuild
new file mode 100644
index 000000000000..e772e98c93f2
--- /dev/null
+++ b/app-office/calcurse/calcurse-4.3.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils multilib-minimal
+
+DESCRIPTION="a text-based calendar and scheduling application"
+HOMEPAGE="https://calcurse.org/"
+SRC_URI="https://calcurse.org/files/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ppc ppc64"
+
+RDEPEND="
+ sys-libs/ncurses:0="
+
+DEPEND="
+ ${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.2.1-tinfo.patch
+)
+
+# Most tests fail.
+RESTRICT="test"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf
+}
+
+src_compile() {
+ multilib-minimal_src_compile
+}
+
+src_install() {
+ multilib-minimal_src_install
+}
diff --git a/app-office/calcurse/files/calcurse-4.2.1-tinfo.patch b/app-office/calcurse/files/calcurse-4.2.1-tinfo.patch
new file mode 100644
index 000000000000..f3d2aac897e9
--- /dev/null
+++ b/app-office/calcurse/files/calcurse-4.2.1-tinfo.patch
@@ -0,0 +1,21 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -3,7 +3,7 @@
+ #-------------------------------------------------------------------------------
+ AC_PREREQ(2.59)
+ AC_INIT([calcurse],
+- m4_esyscmd([build-aux/git-version-gen .version]),
++ m4_esyscmd_s([cat .version]),
+ [bugs@calcurse.org])
+ AM_INIT_AUTOMAKE
+ #m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
+@@ -51,6 +51,9 @@
+ LIBS="$LIBS -l$available_ncurses"
+ ])
+
++AC_SEARCH_LIBS([cbreak], [tinfow tinfo],,
++ AC_MSG_ERROR([Cannot find a library providing cbreak]))
++
+ AC_CHECK_HEADERS([pthread.h], [
+ AC_CHECK_LIB(pthread, pthread_create, [
+ LIBS="$LIBS -pthread"
diff --git a/app-office/calcurse/metadata.xml b/app-office/calcurse/metadata.xml
new file mode 100644
index 000000000000..d5b9396fdc35
--- /dev/null
+++ b/app-office/calcurse/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>monsieurp@gentoo.org</email>
+</maintainer>
+<longdescription>Calcurse is a text-based personal organizer which helps keeping
+track of events and everyday tasks. It contains a calendar, a 'todo' list, and
+puts your appointments in order. The user interface is configurable, and one can
+choose between different color schemes and layouts. All of the commands are
+documented within an online help system.</longdescription>
+</pkgmetadata>