summaryrefslogtreecommitdiff
path: root/app-office/auto-multiple-choice
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-office/auto-multiple-choice
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-office/auto-multiple-choice')
-rw-r--r--app-office/auto-multiple-choice/Manifest5
-rw-r--r--app-office/auto-multiple-choice/auto-multiple-choice-1.3.0-r1.ebuild95
-rw-r--r--app-office/auto-multiple-choice/files/auto-multiple-choice-1.3.0-conf.patch54
-rw-r--r--app-office/auto-multiple-choice/files/auto-multiple-choice-1.3.0-desktop.patch10
-rw-r--r--app-office/auto-multiple-choice/metadata.xml8
5 files changed, 172 insertions, 0 deletions
diff --git a/app-office/auto-multiple-choice/Manifest b/app-office/auto-multiple-choice/Manifest
new file mode 100644
index 000000000000..406aa0eacbda
--- /dev/null
+++ b/app-office/auto-multiple-choice/Manifest
@@ -0,0 +1,5 @@
+AUX auto-multiple-choice-1.3.0-conf.patch 1889 BLAKE2B aa39f1525f6067e8025094b3c7437f72c11eec7cb5b0fcbbe68388b80c1ff01050f2fc224671e1a6901f52d51e761f2702d17ce0e75f5ca67ffc8d721ef37cb6 SHA512 6c7cce8383dbbb23646b96785b69dd75f6d3e842d6712b3b5741a5151f7dde5a9ee05bd35e3dee374641f453128e8008304cc6001d9a1db707528ecb7b1ba496
+AUX auto-multiple-choice-1.3.0-desktop.patch 637 BLAKE2B bf06b2761d35b669b88a0915a273022045e169e09dd76ca4ae40723d44d57fabb518dec83f811124421cfc82a53cd1435c60c6763b534d6a3ae4449b2bc00de6 SHA512 b1eec21b2f640bfdf7a4d7d956a71b2fa9889a6d5428cc7eedc1352e845477c3a81607d0c1502b4f57967264384aff5dcc2162bb552544b962c383dc7f978ffa
+DIST auto-multiple-choice_1.3.0_sources.tar.gz 4328255 BLAKE2B 7c6337cfa0a12d8dcd9fa640e636c300234ba7e7a34e95a523c5f9836f934da336f6ce792932fffb97b28ae02c577166a3d4d3ea4fd6959786a5c60510b454a2 SHA512 fcfacd071072f5773556c706b6fa0aea4ff3f3752f3a1f40c9e6de7ec870e939adc57e6bd4c90cac80241cc798e02a71c9fc80d9ccf25ad3a10752f937d06da5
+EBUILD auto-multiple-choice-1.3.0-r1.ebuild 2486 BLAKE2B 1c4b23c10a1a39156a08b0b35d8711da08bbf0d2f8964bb1740ecad9eed2fc470ad3011d5456b8f709557a8c06880fc8996c7986d0f512fc1a7075601e7b52bc SHA512 dbbb20f11e87687a7effe92cb50fc0e1362bab557d1fbe76a34ee9c3d60f100e79e8bdae1f53792dab3264bb6cb8ce05299b2e56a0044afe0fe0043616ad5535
+MISC metadata.xml 261 BLAKE2B 25f9632b77cadd3d9a88cbc5d94c57db930ec7ecd88a7c418a6a8ae798335c985956f6ac28efa31351675db2eb27ac9866183916c622fbce4c6160f05e58f281 SHA512 ede311f7ddc41ead154035127d3a679c6847af76712bf0d30a4175daa8c436a9eb78ed80fee67eaf8ee2a194985c8e1059aa80b26591e640999727a8f10ce6e1
diff --git a/app-office/auto-multiple-choice/auto-multiple-choice-1.3.0-r1.ebuild b/app-office/auto-multiple-choice/auto-multiple-choice-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..a3734539e03f
--- /dev/null
+++ b/app-office/auto-multiple-choice/auto-multiple-choice-1.3.0-r1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs perl-functions latex-package
+
+DESCRIPTION="Create and manage multiple choice questionnaries, including automated marking"
+HOMEPAGE="http://home.gna.org/auto-qcm/"
+SRC_URI="http://download.gna.org/auto-qcm/${PN}_${PV}_sources.tar.gz"
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+LANGS="ar es fr ja"
+# we deliberately always install de and en, since this way we dont get a problem
+# with globs and empty directories...
+#
+for lala in ${LANGS}; do
+ IUSE="${IUSE} l10n_${lala}"
+done
+
+CDEPEND="
+ app-text/texlive[dvi2tty,extra,graphics,png,pstricks,science,truetype,xml,X,luatex,xetex,humanities,publishers]
+ app-text/poppler:=
+ dev-perl/XML-LibXML
+ media-libs/netpbm
+ media-libs/opencv
+ l10n_fr? ( app-text/texlive[l10n_fr] )
+ l10n_ja? ( app-text/texlive[l10n_ja] )
+"
+DEPEND="${CDEPEND}
+ app-text/dblatex
+ app-text/docbook-xml-simple-dtd:*
+ app-text/docbook-xsl-stylesheets
+"
+RDEPEND="${CDEPEND}
+ app-text/pdftk
+ dev-lang/perl:=
+ dev-perl/Glib-Object-Introspection
+ dev-perl/Gtk2
+ dev-perl/Gtk2-Notify
+ media-gfx/imagemagick
+ dev-perl/XML-Writer
+ dev-perl/Archive-Zip
+ dev-perl/DBI
+ dev-perl/Text-CSV
+ dev-perl/DBD-SQLite
+ dev-perl/Net-CUPS
+ dev-perl/Email-Address
+ dev-perl/Email-MIME
+ dev-perl/Email-Sender
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.3.0-desktop.patch"
+ "${FILESDIR}/${PN}-1.3.0-conf.patch"
+)
+
+src_prepare() {
+ default
+
+ local la
+ for la in ${LANGS} ; do
+ if ! use l10n_${la} ; then
+ # remove languages that we dont want to install. no error on nonexisting files.
+ rm -vf "I18N/lang/${la}.po"
+ rm -vf "doc/auto-multiple-choice.${la}.in.xml" "doc/doc-xhtml-site.${la}.xsl.in"
+ rm -rvf "doc/html/auto-multiple-choice.${la}" "doc/modeles/${la}"
+ sed -e "s: doc/doc-xhtml-site\\.${la}\\.xsl: :g" -i Makefile || die
+ fi
+ done
+}
+
+src_compile() {
+ perl_set_version
+ export VENDOR_LIB PVR
+ export TEXINPUTS="/usr/share/dblatex/latex/style:/usr/share/dblatex/latex/misc:/usr/share/dblatex/latex/graphics:"
+
+ export MAKEOPTS="-j1"
+ # when doing a parallel build, the package is acting decidedly odd
+ # e.g., the build seems to succeed while actually stuff fails
+ # and subsequent error messages do not have any relation to the real problem
+ # So let's keep this also for easier debugging
+
+ emake \
+ GCC_NETPBM="-I/usr/include/netpbm/ -lnetpbm" \
+ GCC="$(tc-getCC)" \
+ GCC_PP="$(tc-getCXX)"
+}
+
+src_install() {
+ default
+}
diff --git a/app-office/auto-multiple-choice/files/auto-multiple-choice-1.3.0-conf.patch b/app-office/auto-multiple-choice/files/auto-multiple-choice-1.3.0-conf.patch
new file mode 100644
index 000000000000..2e5e0cdd58c0
--- /dev/null
+++ b/app-office/auto-multiple-choice/files/auto-multiple-choice-1.3.0-conf.patch
@@ -0,0 +1,54 @@
+diff -ruN auto-multiple-choice-1.3.0.orig/Makefile.conf auto-multiple-choice-1.3.0/Makefile.conf
+--- auto-multiple-choice-1.3.0.orig/Makefile.conf 2016-03-09 20:17:01.000000000 +0100
++++ auto-multiple-choice-1.3.0/Makefile.conf 2017-01-21 21:55:32.649670839 +0100
+@@ -33,13 +33,13 @@
+ # directory for executable
+ BINDIR=/usr/bin
+ # directory for perl modules
+-PERLDIR=/usr/share/perl5
++PERLDIR=$(VENDOR_LIB)
+ # directory for some AMC executables, not to be used by end-user
+ MODSDIR=/usr/lib/AMC
+ # directory for LaTeX style file
+-TEXDIR=/usr/share/texmf/tex/latex/AMC
++TEXDIR=/usr/share/texmf-site/tex/latex/AMC
+ # directory for LaTeX doc
+-TEXDOCDIR=/usr/share/doc/texmf/AMC/
++TEXDOCDIR=/usr/share/texmf-site/doc/AMC/
+ # directory for man (1) files
+ MAN1DIR=/usr/share/man/man1
+ # directory for desktop file
+@@ -54,7 +54,7 @@
+ # directory for AMC packaged models
+ MODELSDIR=/usr/share/auto-multiple-choice/models
+ # directory for documentation (will use html/auto-multiple-choice.* subdirs for HTML docs)
+-DOCDIR=/usr/share/doc/auto-multiple-choice-doc
++DOCDIR=/usr/share/doc/$(PVR)
+
+ # directory for Shared MIME-info Database
+ SHARED_MIMEINFO_DIR=/usr/share/mime/packages
+@@ -91,8 +91,8 @@
+
+ # INSTALL USER AND GROUP
+
+-ifneq ($(SYSTEM_TYPE),rpm)
+-INSTALL_USER=root
+-INSTALL_GROUP=root
+-endif
++#ifneq ($(SYSTEM_TYPE),rpm)
++#INSTALL_USER=root
++#INSTALL_GROUP=root
++#endif
+
+diff -ruN auto-multiple-choice-1.3.0.orig/doc/Makefile auto-multiple-choice-1.3.0/doc/Makefile
+--- auto-multiple-choice-1.3.0.orig/doc/Makefile 2016-03-14 19:40:45.000000000 +0100
++++ auto-multiple-choice-1.3.0/doc/Makefile 2017-01-21 21:28:29.438603307 +0100
+@@ -64,7 +64,7 @@
+ esac
+
+ %.pdf: %.tex $(BLOCK_IMAGES:.svg=.pdf)
+- export TEXINPUTS=./img_pdf/: ; case $< in \
++ export TEXINPUTS=$(TEXINPUTS):./img_pdf/: ; case $< in \
+ *.ja.tex) \
+ sed -i -e '/setuplocale/a\
+ \\usepackage{xeCJK}\
diff --git a/app-office/auto-multiple-choice/files/auto-multiple-choice-1.3.0-desktop.patch b/app-office/auto-multiple-choice/files/auto-multiple-choice-1.3.0-desktop.patch
new file mode 100644
index 000000000000..3c6225dcc054
--- /dev/null
+++ b/app-office/auto-multiple-choice/files/auto-multiple-choice-1.3.0-desktop.patch
@@ -0,0 +1,10 @@
+--- a/auto-multiple-choice.desktop.in-old 2014-02-11 20:25:42.995456713 +0100
++++ b/auto-multiple-choice.desktop.in 2014-02-11 20:25:54.972456566 +0100
+@@ -10,5 +10,5 @@
+ GenericName[fr]=QCM automatique
+ Comment=Manage multiple choice questionnaires, with automatic marking from papers' scans
+ Comment[fr]=Conception et correction automatique de QCM en LaTeX
+-Keywords=multiple;choice;questionnaire;exam;grading;marking;MCQ;AMC
+-Keywords[fr]=questionnaire;choix;multiple;examen;correction;QCM;AMC
++Keywords=multiple;choice;questionnaire;exam;grading;marking;MCQ;AMC;
++Keywords[fr]=questionnaire;choix;multiple;examen;correction;QCM;AMC;
diff --git a/app-office/auto-multiple-choice/metadata.xml b/app-office/auto-multiple-choice/metadata.xml
new file mode 100644
index 000000000000..603226d54b4d
--- /dev/null
+++ b/app-office/auto-multiple-choice/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>office@gentoo.org</email>
+ <name>Gentoo Office project</name>
+ </maintainer>
+</pkgmetadata>