summaryrefslogtreecommitdiff
path: root/app-mobilephone/qtadb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-mobilephone/qtadb
reinit the tree, so we can have metadata
Diffstat (limited to 'app-mobilephone/qtadb')
-rw-r--r--app-mobilephone/qtadb/Manifest5
-rw-r--r--app-mobilephone/qtadb/metadata.xml18
-rw-r--r--app-mobilephone/qtadb/qtadb-0.8.1.ebuild54
3 files changed, 77 insertions, 0 deletions
diff --git a/app-mobilephone/qtadb/Manifest b/app-mobilephone/qtadb/Manifest
new file mode 100644
index 000000000000..d562cd01ccf2
--- /dev/null
+++ b/app-mobilephone/qtadb/Manifest
@@ -0,0 +1,5 @@
+DIST QtADB_0.8.1_src.zip 1084159 SHA256 732eb8736c2fadddc80c37b47a91589c02e474cf5b0b68393411ffd4611cdb5f SHA512 4bcf28a9442873c3d94c33f5b629c1528efb10a34a6825eb8e596ea6fbb23144a56b64bccc258eaf579ca7d86bd7520f6274d611243290ae6f3bee72021346fa WHIRLPOOL 0970c41c5578ba4a3cb221317de07e8ab22643adeccc7bd104795881a26d69dae07b022e76f6b5e3e4e40136ff0203ef3b24f9c041d51078f2f77f521598d162
+EBUILD qtadb-0.8.1.ebuild 1604 SHA256 c9ad6e10f51c6e0a173cf12bbacb37234cafad2f734d0d413d0a18ef88c90357 SHA512 bc98ecf26ab92204cadfdf25cc67341f5d11e908456f58b70cb75c8a6afbf5c9aa924193c3a811f971f273e0d99a10e7d34e0c2893f604dbc08c32d6bbb2dad5 WHIRLPOOL 9b2f1465459a77d70e428a66b51857210fa201720a04b826eef89892da0c0344a1f3ac40e92c65455bfaa701be49759fc4ddebf06d6c014b38c8f3378d83bec6
+MISC ChangeLog 2428 SHA256 36b12d6f80e5c67ed868f1fb152d55c514e5526e6751f09b53a00a093f41ee78 SHA512 4ac7f96f568826793b16f506140275f328df27080cb0c33fffbf9335289fac54adafcf56adf535ee531b72b38096a9e5542de7ae52c223657f938b965d4ea38a WHIRLPOOL c596b6783388b5035a086ff0a54d64655559cbcba40956f31637266e24df555159b9f29f2d0ba0254d90080f14ece261fcce2705579f28248302bddb732b46bf
+MISC ChangeLog-2015 1146 SHA256 d15861f7936c6f120c9f28f18fc8138794c09787ab4e4940a4aaa31eaa981073 SHA512 e9fb102e1014f752d699420ef848216d993235026707d1eab28cb2a3bb9c87dfd8faeb60fb5a13fa7c63bc224a9abf2c032e4ba5f908797864307fa2a2809d43 WHIRLPOOL 2ff0575723e0d5702ca2a1cbf06e4508afa4d4e34ed670a9fbc871680845df5c16a1a2eab910583c17de15a37dea2d6e8c320668976dcbf57779e30c09e85203
+MISC metadata.xml 587 SHA256 82b2da4f5ed96d4f2e076e1c87792d93bfc2c16a07a3c705a2198afef39d61a8 SHA512 c0a4a87370ea9e3a927d2ae4512ccd8bd7c8e9790145452967648f57501c61b861e90a8c8f296ac837b904613330505cac263475a4a82e0e3f9b6d9b6feedb82 WHIRLPOOL 4c473f2e8fdffd0a69bc7d15634f0a2b6a10fdc0481e99148f1763e5fecf0ef25fbee7160072e12c1af3a034af2b54283e9f5e4954144757bfa9ce292a29795e
diff --git a/app-mobilephone/qtadb/metadata.xml b/app-mobilephone/qtadb/metadata.xml
new file mode 100644
index 000000000000..2d01fe9fa442
--- /dev/null
+++ b/app-mobilephone/qtadb/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+<email>opensource@andmarios.com</email>
+<name>Marios Andreopoulos</name>
+<description>Maintainer. Assign bugs to him</description>
+</maintainer>
+<maintainer type="person">
+<email>hwoarang@gentoo.org</email>
+<name>Markos Chandras</name>
+<description>Proxy maintainer. CC him on bugs</description>
+</maintainer>
+<maintainer type="project">
+<email>proxy-maint@gentoo.org</email>
+<name>Proxy Maintainers</name>
+</maintainer>
+</pkgmetadata>
diff --git a/app-mobilephone/qtadb/qtadb-0.8.1.ebuild b/app-mobilephone/qtadb/qtadb-0.8.1.ebuild
new file mode 100644
index 000000000000..498f747f663a
--- /dev/null
+++ b/app-mobilephone/qtadb/qtadb-0.8.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+inherit eutils readme.gentoo qt4-r2
+
+MY_PN="QtADB"
+MY_P="${MY_PN}_${PV}_src"
+
+DESCRIPTION="Android phone manager via ADB"
+HOMEPAGE="http://qtadb.wordpress.com"
+SRC_URI="http://${PN}.com/${PN}/${MY_P}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-qt/qtgui:4
+ dev-qt/qtdeclarative:4"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/trunk"
+
+pkg_setup() {
+ DISABLE_AUTOFORMATTING="yes"
+ DOC_CONTENTS="
+You will need a working Android SDK installation (adb and aapt executables)
+You can install Android SDK a) through portage (emerge android-sdk-update-manager
+and run android to download the actual sdk), b) manually from
+http://developer.android.com/sdk/index.html or c) just grab the adb, aapt linux
+binaries from http://qtadb.wordpress.com/download/
+adb and aapt executables are in the platform-tools subdir of Android SDK
+
+Also you will need to have ROOT access to your phone along with busybox
+The latter can be found in the Android market
+
+Last, if you want to use the SMS manager of QtADB, you have to install
+QtADB.apk to your device, available here: http://qtadb.wordpress.com/download/
+
+If you have trouble getting your phone connected through usb (driver problem),
+try adbWireless from Android market to get connected through WiFi
+"
+}
+
+src_install() {
+ newicon images/android.png ${PN}.png
+ make_desktop_entry ${MY_PN} "${MY_PN}" ${PN} \
+ "Qt;PDA;Utility;" || die "Desktop entry creation failed"
+ dobin ${MY_PN}
+ readme.gentoo_create_doc
+}