summaryrefslogtreecommitdiff
path: root/app-mobilephone/dfu-util
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-mobilephone/dfu-util
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-mobilephone/dfu-util')
-rw-r--r--app-mobilephone/dfu-util/Manifest4
-rw-r--r--app-mobilephone/dfu-util/dfu-util-0.9.ebuild27
-rw-r--r--app-mobilephone/dfu-util/dfu-util-9999.ebuild27
-rw-r--r--app-mobilephone/dfu-util/metadata.xml11
4 files changed, 69 insertions, 0 deletions
diff --git a/app-mobilephone/dfu-util/Manifest b/app-mobilephone/dfu-util/Manifest
new file mode 100644
index 000000000000..0d92e3326cbf
--- /dev/null
+++ b/app-mobilephone/dfu-util/Manifest
@@ -0,0 +1,4 @@
+DIST dfu-util-0.9.tar.gz 138397 BLAKE2B e3a9db3276204d25fbcdd7d50caacd28a8e043d2781b5f942cd0df343d046870003abeaa1005a2774d03c4198ce96fa2124040987069c5f444e36e4f365a5e0e SHA512 caa7148b7a9004e2b1f7bc4f1a26b48abfe311743bc0eeed1ab57459910371affc39b6fe7e74b7cac6ca9de41a9901b7a970253ca92d7d66d5008f8a11d2c952
+EBUILD dfu-util-0.9.ebuild 611 BLAKE2B 1684c27777969c7aefefa831a4f93b1e58bee27042d2f57d026aaa3cc8a71597211fad44ee5b7763c22ba307bb6fac6b89318ccaf94998673eccc2f9e536774b SHA512 3df4947a9180bdd44cf3125dfa3d4f8cf4aed05b45397a7365a42de045dc7ed3ce12e2f6c1ae5f0fa5b317fcd0501ee8a40dae514af6baaae48df39cd9eea46f
+EBUILD dfu-util-9999.ebuild 613 BLAKE2B f36bfa2685a0c2ae90a0dae5df42f99a181c9314b4c8d952150e76c6144ecf174693157ee897b281213fb570aa085b8197e18b260a09bcbab8102d5664c2d068 SHA512 6cf5538e2f99326a922767631402887324a7395788bc3435ed410d65b8fa0735ac6fb9414e1ff61f8584f128ce1a992dc3ee1df4c97fb1cc540b7db1edd98727
+MISC metadata.xml 329 BLAKE2B 4785e0777c86743251036916ea3c691e828e772a2fd409b666e36607f96a096ae19b14ad6e70fccf55f0415c4d52f25754d597ddd8e11d2b40c73c487abc7fff SHA512 95b30bccd833523adaadcee075c48621d3d9e783a4c1c514711aa67697d2c2e5f8d773ac4760c95a9d92ba9b13d3df448202116696c412afd2a844ce7815f678
diff --git a/app-mobilephone/dfu-util/dfu-util-0.9.ebuild b/app-mobilephone/dfu-util/dfu-util-0.9.ebuild
new file mode 100644
index 000000000000..e0eaa1553ad5
--- /dev/null
+++ b/app-mobilephone/dfu-util/dfu-util-0.9.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.code.sf.net/p/dfu-util/dfu-util"
+ inherit autotools git-r3
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+ KEYWORDS="amd64 x86"
+fi
+
+DESCRIPTION="implements the Host (PC) side of the USB DFU (Device Firmware Upgrade) protocol"
+HOMEPAGE="http://dfu-util.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="virtual/libusb:1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ [[ ${PV} == "9999" ]] && eautoreconf
+}
diff --git a/app-mobilephone/dfu-util/dfu-util-9999.ebuild b/app-mobilephone/dfu-util/dfu-util-9999.ebuild
new file mode 100644
index 000000000000..9c3ac27b12b1
--- /dev/null
+++ b/app-mobilephone/dfu-util/dfu-util-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.code.sf.net/p/dfu-util/dfu-util"
+ inherit autotools git-r3
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="implements the Host (PC) side of the USB DFU (Device Firmware Upgrade) protocol"
+HOMEPAGE="http://dfu-util.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="virtual/libusb:1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ [[ ${PV} == "9999" ]] && eautoreconf
+}
diff --git a/app-mobilephone/dfu-util/metadata.xml b/app-mobilephone/dfu-util/metadata.xml
new file mode 100644
index 000000000000..e7237c8d32c6
--- /dev/null
+++ b/app-mobilephone/dfu-util/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>embedded@gentoo.org</email>
+ <name>Embedded Gentoo</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">dfu-util</remote-id>
+ </upstream>
+</pkgmetadata>