summaryrefslogtreecommitdiff
path: root/app-mobilephone/dfu-util
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-mobilephone/dfu-util
reinit the tree, so we can have metadata
Diffstat (limited to 'app-mobilephone/dfu-util')
-rw-r--r--app-mobilephone/dfu-util/Manifest6
-rw-r--r--app-mobilephone/dfu-util/dfu-util-0.9.ebuild27
-rw-r--r--app-mobilephone/dfu-util/dfu-util-9999.ebuild27
-rw-r--r--app-mobilephone/dfu-util/metadata.xml11
4 files changed, 71 insertions, 0 deletions
diff --git a/app-mobilephone/dfu-util/Manifest b/app-mobilephone/dfu-util/Manifest
new file mode 100644
index 000000000000..edf0ada9edd6
--- /dev/null
+++ b/app-mobilephone/dfu-util/Manifest
@@ -0,0 +1,6 @@
+DIST dfu-util-0.9.tar.gz 138397 SHA256 36428c6a6cb3088cad5a3592933385253da5f29f2effa61518ee5991ea38f833 SHA512 caa7148b7a9004e2b1f7bc4f1a26b48abfe311743bc0eeed1ab57459910371affc39b6fe7e74b7cac6ca9de41a9901b7a970253ca92d7d66d5008f8a11d2c952 WHIRLPOOL 5eff75635854bb77ffde458b7c6c3dbe7d366207eaf340a5a6a8db132d34ca86d545c87a38c97c1c9bf109c2218b2499aa4c3dce374da5def952a39c7d893391
+EBUILD dfu-util-0.9.ebuild 611 SHA256 bd9b4d1a70810c8c9366aba3f03c3a7235b5791eb10307f72cccbcfc3a3cf204 SHA512 3df4947a9180bdd44cf3125dfa3d4f8cf4aed05b45397a7365a42de045dc7ed3ce12e2f6c1ae5f0fa5b317fcd0501ee8a40dae514af6baaae48df39cd9eea46f WHIRLPOOL a2b0314f3e62ed10ffe676da4577cabb4fca84f13479ab80bae21e3568c9915771406464c9ba1b50725db30fc2f13067f7c2484d62fb31b40a0b05d6567bfe68
+EBUILD dfu-util-9999.ebuild 613 SHA256 eae66d3962740cc5268ec2ff33741ccac4d28bb5712dce5c552842e96e6efa55 SHA512 6cf5538e2f99326a922767631402887324a7395788bc3435ed410d65b8fa0735ac6fb9414e1ff61f8584f128ce1a992dc3ee1df4c97fb1cc540b7db1edd98727 WHIRLPOOL 618968ebeb55a1ede65547fd589e00f536feb6d2776c8c7ac0ba59c8504e66f7fcbad8acff4b75742cb4d831c119d3b75f7f1ad6fa4e49442b0528af1e672b51
+MISC ChangeLog 3254 SHA256 a40c8c1b36dbf1ba60bdf1f1c0dc26b8b397645505979379353bfcf87e4a998e SHA512 8fdfdaeab4d87235cc4c748f8d1dccc783598b9b3491c717864e75bf3c5bfc5978a6594afa234437a3127c895174cf28cdd67d5392a82dcef406d46e59cda4e3 WHIRLPOOL 1a5d711d9b67022bdee1829c370efe6de492e2740353b80ffb841490e47afed3a7459059bf1faebe805d1bbd7f06ce29075d181da1e6bc44ba1e9247dc19e4a7
+MISC ChangeLog-2015 2348 SHA256 d5338e9755d84e54b70b0cb6ca1d26dd2ccf367f27046cfdecc538f73182b1bf SHA512 d47500808fbeef9d2b7766570de3c03e89aa5695eac97a5e6f2d7cfbbdf57e3da3662f742184e3084b9cd74c7f07b6752ac4452ad6d159b09fa151b659fe1cf4 WHIRLPOOL e9a75a42d925a70da71c40b5144f9fda0784ffbb22d380e37ce985c62e5d9d3cceb0019a7a5b4411f9b14c89569ef9529df5d5c77c009a9a356925dc1131c07e
+MISC metadata.xml 329 SHA256 1b9803c23b40273f8d89f2dafc38e2b81abc1fe62c178edd43294108dce098cd SHA512 95b30bccd833523adaadcee075c48621d3d9e783a4c1c514711aa67697d2c2e5f8d773ac4760c95a9d92ba9b13d3df448202116696c412afd2a844ce7815f678 WHIRLPOOL 4875f214e29cd77f37094f2b87dc3d1a352ec544069d193732d50f3f80e46937f3eaa439b5cf048bc6161b86addb576aeb3bd6686f12a27e82f8a30cc5427ae3
diff --git a/app-mobilephone/dfu-util/dfu-util-0.9.ebuild b/app-mobilephone/dfu-util/dfu-util-0.9.ebuild
new file mode 100644
index 000000000000..e0eaa1553ad5
--- /dev/null
+++ b/app-mobilephone/dfu-util/dfu-util-0.9.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.code.sf.net/p/dfu-util/dfu-util"
+ inherit autotools git-r3
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+ KEYWORDS="amd64 x86"
+fi
+
+DESCRIPTION="implements the Host (PC) side of the USB DFU (Device Firmware Upgrade) protocol"
+HOMEPAGE="http://dfu-util.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="virtual/libusb:1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ [[ ${PV} == "9999" ]] && eautoreconf
+}
diff --git a/app-mobilephone/dfu-util/dfu-util-9999.ebuild b/app-mobilephone/dfu-util/dfu-util-9999.ebuild
new file mode 100644
index 000000000000..9c3ac27b12b1
--- /dev/null
+++ b/app-mobilephone/dfu-util/dfu-util-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.code.sf.net/p/dfu-util/dfu-util"
+ inherit autotools git-r3
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="implements the Host (PC) side of the USB DFU (Device Firmware Upgrade) protocol"
+HOMEPAGE="http://dfu-util.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="virtual/libusb:1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ [[ ${PV} == "9999" ]] && eautoreconf
+}
diff --git a/app-mobilephone/dfu-util/metadata.xml b/app-mobilephone/dfu-util/metadata.xml
new file mode 100644
index 000000000000..e7237c8d32c6
--- /dev/null
+++ b/app-mobilephone/dfu-util/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>embedded@gentoo.org</email>
+ <name>Embedded Gentoo</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">dfu-util</remote-id>
+ </upstream>
+</pkgmetadata>