summaryrefslogtreecommitdiff
path: root/app-misc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-12 13:33:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-12 13:33:15 +0100
commite4b9f141e31db1e069e3bcf5b1fb81af77b0cace (patch)
treed1879c44ce14e7b9450b0f9c711f653779584754 /app-misc
parentbd3c6f11646b7601637fa3245cf8a363e9fa0034 (diff)
gentoo auto-resync : 12:07:2022 - 13:33:15
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/Manifest.gzbin49262 -> 49261 bytes
-rw-r--r--app-misc/pax-utils/Manifest1
-rw-r--r--app-misc/pax-utils/pax-utils-9999.ebuild79
3 files changed, 80 insertions, 0 deletions
diff --git a/app-misc/Manifest.gz b/app-misc/Manifest.gz
index 19ba168ec870..d2af020e9c73 100644
--- a/app-misc/Manifest.gz
+++ b/app-misc/Manifest.gz
Binary files differ
diff --git a/app-misc/pax-utils/Manifest b/app-misc/pax-utils/Manifest
index e2a0a63eaecf..f27124e12b91 100644
--- a/app-misc/pax-utils/Manifest
+++ b/app-misc/pax-utils/Manifest
@@ -2,4 +2,5 @@ DIST pax-utils-1.3.3.tar.xz 725900 BLAKE2B 17004a4fe57f05e80e0c51a156931975cbaf7
DIST pax-utils-1.3.4.tar.xz 753448 BLAKE2B c105ff568a8e4378cfef5f8b9acb415a850b1e209ea8413cdf518de82e5e925fdba60288557f042bf02d2e075ed5e538175b2078e4dafbe5c54117ed580fd87e SHA512 44a475860823e8b70b1d09d69e5fba3ed8298511d07e1e7b09ce62237cb8b1ecee8fc2fc550d6853d0b9f8db3c350bf78ced49d5f210997b294dc10e36627fcd
EBUILD pax-utils-1.3.3.ebuild 1824 BLAKE2B 4d5e2039ad372c70caf76594938228223c1169e984b3e7cce0dd8f892ad137b910d65a985bf3ba7ab60a1b9a89c7fe04eb7e3c2f0b0436c1371a3717f5fa24a1 SHA512 f9ada3fea1b51dabdb6b12348ba6a245cf31462c3f8d7ad71b3352ad481edd730c697c76a80608abc7379fc66aef5d57ed7068ccf2d94fcdeb5e0ac3c0d8fe4d
EBUILD pax-utils-1.3.4.ebuild 1784 BLAKE2B 5ccaa1d471f9bd9560ff5940d95944226b73262ffcb856df2d07ef22aefe9ff3767a2c97651973f20aa6a31929d121a08700f696a8939897bbbe28f6b05fc50e SHA512 25bd378072743c57a23ea0c5704d25c3a88955ccc62193c7ec641200c16e11dc2f272b1e895260948573e86164c6edae28a29b9e9272aba16d2116b40d29a0ad
+EBUILD pax-utils-9999.ebuild 1905 BLAKE2B 86201a0dfe199516eb4cedcbe743ec55420b7d9665eadb309d81747302072a5c725d1d025138a9cdf5584f95c00fcaa59e6d541b4c458f8faac67e367b49f6ab SHA512 db5455610e0cdec1a4452a8302ed24552b5b693cdc726511f51bbb0072a71573a81a392c2cd47fa7e05eecfbe017c2ede4cdd9105c9d604e414137c9828fc24e
MISC metadata.xml 678 BLAKE2B 347b6f8175b20bfa4f592b41b15f5fa8228fb3e657ab86b4692aef468130e7625e41ec1266a89ed1fb2a81d608eecd957e773863b440afd7bf83873a357ec7ce SHA512 e6739b52ccaf7f8e4d0c3b173c85b368c974fd62b231ce83513c342b9e3148b5b29aa7f985af929d3d07e9d5808ff6aca575b88dd23f0b25bb89d952fa45dc70
diff --git a/app-misc/pax-utils/pax-utils-9999.ebuild b/app-misc/pax-utils/pax-utils-9999.ebuild
new file mode 100644
index 000000000000..cb9ee508e9ae
--- /dev/null
+++ b/app-misc/pax-utils/pax-utils-9999.ebuild
@@ -0,0 +1,79 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Note: if bumping pax-utils because of syscall changes in glibc, please
+# revbump glibc and update the dependency in its ebuild for the affected
+# versions.
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit meson python-single-r1
+
+DESCRIPTION="ELF utils that can check files for security relevant properties"
+HOMEPAGE="https://wiki.gentoo.org/index.php?title=Project:Hardened/PaX_Utilities"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/pax-utils.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz
+ https://dev.gentoo.org/~sam/distfiles/${P}.tar.xz
+ https://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="caps +man python seccomp test"
+
+_PYTHON_DEPS="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/pyelftools[${PYTHON_USEDEP}]
+ ')
+"
+
+RDEPEND="caps? ( >=sys-libs/libcap-2.24 )
+ python? ( ${_PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ caps? ( virtual/pkgconfig )
+ man? ( app-text/xmlto )
+
+ python? ( ${_PYTHON_DEPS} )
+"
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+ test? ( python )
+"
+RESTRICT="
+ !test? ( test )
+"
+
+pkg_setup() {
+ if use test || use python; then
+ python-single-r1_pkg_setup
+ fi
+}
+
+src_configure() {
+ local emesonargs=(
+ "-Dlddtree_implementation=$(usex python python sh)"
+ $(meson_feature caps use_libcap)
+ $(meson_feature man build_manpages)
+ $(meson_use seccomp use_seccomp)
+ $(meson_use test tests)
+
+ # fuzzing is currently broken
+ -Duse_fuzzing=false
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ use python && python_fix_shebang "${ED}"/usr/bin/lddtree
+}