summaryrefslogtreecommitdiff
path: root/app-misc/yq
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-13 22:45:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-13 22:45:20 +0100
commitab7810b87f5bb33b3ed5edd0dbda7f4bcd0cf70d (patch)
treef102e6ba13816f35c909cda970653f5422ee1b0d /app-misc/yq
parent6d478a9cbbd774e9d2743701d0931416e3ab9371 (diff)
gentoo auto-resync : 13:09:2023 - 22:45:20
Diffstat (limited to 'app-misc/yq')
-rw-r--r--app-misc/yq/Manifest1
-rw-r--r--app-misc/yq/files/yq-3.1.1-tomli.patch80
2 files changed, 0 insertions, 81 deletions
diff --git a/app-misc/yq/Manifest b/app-misc/yq/Manifest
index 477af266f985..d556183185ba 100644
--- a/app-misc/yq/Manifest
+++ b/app-misc/yq/Manifest
@@ -1,5 +1,4 @@
AUX yq-2.13.0-tests.patch 746 BLAKE2B 0d769a32a3e80cdc8a49e0f3575ab9da880bb0a916a564261874e6a8775b35c5570e99fad5a902bdf9bbdf5a6bb080a7bf57324aad461fb1ca7d9de4da787808 SHA512 e6bd60877d628e2fac51d5395b03f96a0cf7a5033c72a676dee8fe353425f6cc7ee585404567778d7765459ded0f7f71b6563e2343de9d520b8cde493012af01
-AUX yq-3.1.1-tomli.patch 3537 BLAKE2B 672b7cb6d9418197bd0163fef51f0e141e59bcd9d7529cbe0aee3c10c13196116fdfcbd1c964ba8deae2cb357d0a634a4061d85dc14bec7cb28c6031e15da9f3 SHA512 bc98a46e112145e44d5c480cd22d9ebd7369a6f0208126242acc188ef1574c60ca446b237b26fdde4130e7fedf3a5c73a4f24498c56dc788dc5cee0fe22b4d0f
AUX yq-3.1.2-test.patch 606 BLAKE2B 51d0578f5241400908efed53233a52fb0980e4733ad92e34ffee55e04c86d8bf34433133953420a5c00b6bb9160a5d7296a22fd710d83f7dee2d08b49d363925 SHA512 073395e7a5ed300c20da4747c0f97e7016909b79cb6dbaec482c8f56e8f1cb8dd009e439880726c48c37f148cfb3e9d3121cc072db92b05cc27400ca5ab0a198
DIST yq-3.2.2.tar.gz 30872 BLAKE2B 4386a7972b411159ed909ccdc7c32a878d064ac5101cbddb16b0f1efe37c3791aeefda3b7c18c94e7d79fb01a4a4b43f7fbcc7c55bd275c52e08cc069523c8d3 SHA512 4472006d6997f7d620f71ade53d31e6db4051414c147db4f14cb31e0a16a0d0faf9e5c5a682cec098146bfd4e29f9e62278e4f208487e9e194d317ee82823e60
DIST yq-3.2.3.tar.gz 31952 BLAKE2B b0c4548efa08aecc98b77b5988e5dbf652951ecfab3ab01bfbf9610151cee3c3a0b9c3139434cba3bfc08a2176a617a2c9d19c0fcf47bb8a6d3cc3886fa5de6d SHA512 8b60907536b5f3ae7c18dc157ed8ccf4632f2734803711a18b71111fbd6e6efff24ddc9c2221fb926ca99bf538c3bba14517529e6edb37bc487fb69441ad7928
diff --git a/app-misc/yq/files/yq-3.1.1-tomli.patch b/app-misc/yq/files/yq-3.1.1-tomli.patch
deleted file mode 100644
index b4ef5ef3dfb9..000000000000
--- a/app-misc/yq/files/yq-3.1.1-tomli.patch
+++ /dev/null
@@ -1,80 +0,0 @@
-diff --git a/README.rst b/README.rst
-index 69d77e1..237b89e 100644
---- a/README.rst
-+++ b/README.rst
-@@ -109,7 +109,9 @@ the ``xq --xml-output``/``xq -x`` option. Multiple XML documents can be passed i
- TOML support
- ------------
- ``yq`` supports `TOML <https://toml.io/>`_ as well. The ``yq`` package installs an executable, ``tomlq``, which uses the
--`toml library <https://github.com/uiri/toml>`_ to transcode TOML to JSON, then pipes it to ``jq``. Roundtrip transcoding
-+`tomllib module <https://docs.python.org/3.11/library/tomllib.html>` or `tomli library
-+<https://github.com/hukkin/tomli>`_ to transcode TOML to JSON, then pipes it to ``jq``. Transcoding to TOML uses the
-+`tomli-w <https://github.com/hukkin/toml-w`_ package. Roundtrip transcoding
- is available with the ``tomlq --toml-output``/``tomlq -t`` option.
-
- .. admonition:: Compatibility note
-diff --git a/setup.py b/setup.py
-index 9de217e..7d34f8c 100755
---- a/setup.py
-+++ b/setup.py
-@@ -19,7 +19,8 @@ setup(
- install_requires=[
- "PyYAML >= 5.3.1",
- "xmltodict >= 0.11.0",
-- "toml >= 0.10.0",
-+ "tomli >= 1.2.3; python_version < '3.11'",
-+ "tomli-w",
- "argcomplete >= 1.8.1",
- ],
- extras_require={
-diff --git a/yq/__init__.py b/yq/__init__.py
-index 0ccb8e8..88da1d7 100644
---- a/yq/__init__.py
-+++ b/yq/__init__.py
-@@ -246,9 +246,12 @@ def yq(
- json.dump(doc, json_buffer, cls=JSONDateTimeEncoder)
- json_buffer.write("\n")
- elif input_format == "toml":
-- import toml
-+ if sys.version_info >= (3, 11):
-+ import tomllib
-+ else:
-+ import tomli as tomllib
-
-- doc = toml.load(input_stream) # type: ignore
-+ doc = tomllib.loads(input_stream.read()) # type: ignore
- json.dump(doc, json_buffer, cls=JSONDateTimeEncoder)
- json_buffer.write("\n")
- else:
-@@ -295,13 +298,13 @@ def yq(
- raise
- output_stream.write(b"\n" if sys.version_info < (3, 0) else "\n")
- elif output_format == "toml":
-- import toml
-+ import tomli_w
-
- for doc in decode_docs(jq_out, json_decoder):
- if not isinstance(doc, dict):
- msg = "{}: Error converting JSON to TOML: cannot represent non-object types at top level."
- exit_func(msg.format(program_name))
-- toml.dump(doc, output_stream)
-+ output_stream.write(tomli_w.dumps(doc))
- else:
- if input_format == "yaml":
- loader_class = get_loader(
-@@ -327,10 +330,13 @@ def yq(
- )
- jq.stdin.write("\n") # type: ignore
- elif input_format == "toml":
-- import toml
-+ if sys.version_info >= (3, 11):
-+ import tomllib
-+ else:
-+ import tomli as tomllib
-
- for input_stream in input_streams:
-- json.dump(toml.load(input_stream), jq.stdin, cls=JSONDateTimeEncoder) # type: ignore
-+ json.dump(tomllib.loads(input_stream.read()), jq.stdin, cls=JSONDateTimeEncoder) # type: ignore
- jq.stdin.write("\n") # type: ignore
- else:
- raise Exception("Unknown input format")