summaryrefslogtreecommitdiff
path: root/app-misc/yq/yq-3.2.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-29 00:07:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-29 00:07:15 +0100
commit5c4786a868bad6e3f46aecf32ad6c6dc5de98408 (patch)
tree1a1792815761a5b6f645c8d55b6b698e102dca48 /app-misc/yq/yq-3.2.2.ebuild
parent3c1648a0749c1d66b300d857e6b417c1162890da (diff)
gentoo auto-resync : 29:05:2024 - 00:07:15
Diffstat (limited to 'app-misc/yq/yq-3.2.2.ebuild')
-rw-r--r--app-misc/yq/yq-3.2.2.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/app-misc/yq/yq-3.2.2.ebuild b/app-misc/yq/yq-3.2.2.ebuild
deleted file mode 100644
index 98fbab95f2e3..000000000000
--- a/app-misc/yq/yq-3.2.2.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-DISTUTILS_USE_PEP517=setuptools
-
-inherit pypi distutils-r1
-
-DESCRIPTION="Command-line YAML processor - jq wrapper for YAML documents"
-HOMEPAGE="
- https://yq.readthedocs.io/
- https://github.com/kislyuk/yq/
- https://pypi.org/project/yq/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- app-misc/jq
- dev-python/argcomplete[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
- dev-python/xmltodict[${PYTHON_USEDEP}]
- >=dev-python/tomlkit-0.11.6[${PYTHON_USEDEP}]
-"
-DEPEND="
- ${RDEPEND}
- test? (
- dev-python/wheel[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/yq-2.13.0-tests.patch"
-)
-
-python_prepare_all() {
- sed -e 's:unittest.main():unittest.main(verbosity=2):' \
- -i test/test.py || die
-
- sed -r -e 's:[[:space:]]*"coverage",:: ; s:[[:space:]]*"flake8",::' \
- -i setup.py || die
-
- sed -e '/license_file/ d' -i setup.cfg || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- "${EPYTHON}" test/test.py </dev/null || die "tests failed under ${EPYTHON}"
-}