summaryrefslogtreecommitdiff
path: root/app-misc/worker/worker-2.19.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/worker/worker-2.19.6.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/worker/worker-2.19.6.ebuild')
-rw-r--r--app-misc/worker/worker-2.19.6.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/app-misc/worker/worker-2.19.6.ebuild b/app-misc/worker/worker-2.19.6.ebuild
new file mode 100644
index 000000000000..349dd3d81505
--- /dev/null
+++ b/app-misc/worker/worker-2.19.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Worker Filemanager: Amiga Directory Opus 4 clone"
+HOMEPAGE="http://www.boomerangsworld.de/cms/worker/"
+SRC_URI="http://www.boomerangsworld.de/cms/worker/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~hppa ppc ~ppc64 x86"
+IUSE="avfs debug dbus examples libnotify +magic xinerama xft"
+
+RDEPEND="x11-libs/libSM
+ x11-libs/libX11
+ avfs? ( >=sys-fs/avfs-0.9.5 )
+ dbus? ( dev-libs/dbus-glib )
+ magic? ( sys-apps/file )
+ xft? ( x11-libs/libXft )
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS ChangeLog INSTALL NEWS README README_LARGEFILES THANKS )
+
+src_prepare() {
+ # respect AR, bug #466014
+ sed -i -e "/AR/s/ar/$(tc-getAR)/" src/aguix/Makefile.in || die 'sed on Makefile.in failed'
+
+ epatch_user
+}
+
+src_configure() {
+ # there is no option for disabling libXinerama support
+ use xinerama || export ac_cv_lib_Xinerama_XineramaQueryScreens=no
+ econf \
+ --without-hal \
+ $(use_with avfs) \
+ $(use_with dbus) \
+ $(use_enable debug) \
+ $(use_enable libnotify inotify) \
+ $(use_with magic libmagic) \
+ $(use_enable xft)
+}
+
+src_install() {
+ default
+ if use examples; then
+ docinto examples
+ dodoc examples/config-*
+ fi
+}