summaryrefslogtreecommitdiff
path: root/app-misc/wipe
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/wipe
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/wipe')
-rw-r--r--app-misc/wipe/Manifest4
-rw-r--r--app-misc/wipe/files/wipe-2.3.1-LDFLAGS.patch19
-rw-r--r--app-misc/wipe/metadata.xml11
-rw-r--r--app-misc/wipe/wipe-2.3.1.ebuild43
4 files changed, 77 insertions, 0 deletions
diff --git a/app-misc/wipe/Manifest b/app-misc/wipe/Manifest
new file mode 100644
index 000000000000..571e6a1993a5
--- /dev/null
+++ b/app-misc/wipe/Manifest
@@ -0,0 +1,4 @@
+AUX wipe-2.3.1-LDFLAGS.patch 470 BLAKE2B 76b63c80c561bea0fa5bea750b7eae9c6b07b516c6b4ae7b0949fa3e60b2b9c665afb28d48abf5b1c6f6a97062faec16a8f8145a24a461e71cbecb1d67a75b1b SHA512 e44d409f8177466c22c5a76fcb242e424d4584e587c6a8e25c5d3d8adb976b11a5cce2e0a77b99833a06879a4df3bdb2c71e468f08b7c7b2888b5ed1907dbd79
+DIST wipe-2.3.1.tar.bz2 72297 BLAKE2B e4c15e3b2f64d21d05b915af2c841518f686bec297a6b97eb91b57c1af2e5fb70193f54718ca2f9fa9d04ba684ca21f116b75328695e29f757fe44c62c8504e8 SHA512 63870e68fa5dbf90abb686052f8dcc216ccb93b0c4f5cc10d60ccf43f3606ba91b46dc1e3d8b34d201f7ea657f70b45a61d5d04facf5b2a3e47d2286c46e7110
+EBUILD wipe-2.3.1.ebuild 792 BLAKE2B 6f93fee4cc851e862cb3a35a39d27ae66e7cd78221095ce620f2babd641b8d6c6dfd88a493f80cd0aeb316acc00f5b6c8e0306b5471ac1c61deb5e3837e3bb8d SHA512 33d3351e8e5f15481f7c82ca86107d5f97ec6e95ae126cf3f073993223a64b737ed128066446ca5feba1a2ca6834435e7e1de072288e8ff8e6a88f4c80cbdd46
+MISC metadata.xml 317 BLAKE2B 3b1e4414ce9e5ed8fc5e6b88c064937c1b484a1bd39117a3d1709bcae5ab185d66c4879c7e7f18027aa9f5788fe55df1aaabaaf9d2843b7ad15b8ae487e83501 SHA512 d4c733a3d33e0b3528b2fa38555f9318897900ec1a9e4ae35efdf0ffb0ab1af68059786dd9ab99d1d943310829887e8c01954c3c597a752e086a94d513b85e3b
diff --git a/app-misc/wipe/files/wipe-2.3.1-LDFLAGS.patch b/app-misc/wipe/files/wipe-2.3.1-LDFLAGS.patch
new file mode 100644
index 000000000000..23a5d19d1cd7
--- /dev/null
+++ b/app-misc/wipe/files/wipe-2.3.1-LDFLAGS.patch
@@ -0,0 +1,19 @@
+--- wipe-2.3.1/Makefile.in
++++ wipe-2.3.1/Makefile.in
+@@ -5,6 +5,7 @@
+
+ CC=@CC@
+ CFLAGS=@CFLAGS@ -I@srcdir@ -D@OSTYPE@ $(DEFINES)
++LDFLAGS=@LDFLAGS@
+ DEBUG=@DEBUG@ -I@srcdir@ -D@OSTYPE@ $(DEFINES)
+
+ LIBS=@LIBS@
+@@ -31,7 +32,7 @@
+ all: $(REQ) $(BIN)
+
+ $(BIN): main.o wipe.o rand.o dir.o file.o blkdev.o lock.o text.o str.o percent.o prompt.o io.o mt.o
+- $(CC) $(LIBS) *.o -o $@
++ $(CC) $(LIBS) *.o -o $@ $(LDFLAGS)
+
+
+ # restores everything to a pre-configured state
diff --git a/app-misc/wipe/metadata.xml b/app-misc/wipe/metadata.xml
new file mode 100644
index 000000000000..8e517081e108
--- /dev/null
+++ b/app-misc/wipe/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">wipe</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-misc/wipe/wipe-2.3.1.ebuild b/app-misc/wipe/wipe-2.3.1.ebuild
new file mode 100644
index 000000000000..8775ae458c90
--- /dev/null
+++ b/app-misc/wipe/wipe-2.3.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Secure file wiping utility based on Peter Gutman's patterns"
+HOMEPAGE="http://wipe.sourceforge.net/"
+SRC_URI="mirror://sourceforge/wipe/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-LDFLAGS.patch )
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin wipe
+ doman wipe.1
+ einstalldocs
+ dodoc TESTING
+}
+
+pkg_postinst() {
+ elog "Note that wipe is useless on journaling filesystems,"
+ elog "such as reiserfs, XFS, or ext3."
+ elog "See documentation for more info."
+}