summaryrefslogtreecommitdiff
path: root/app-misc/when
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/when
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/when')
-rw-r--r--app-misc/when/Manifest5
-rw-r--r--app-misc/when/metadata.xml8
-rw-r--r--app-misc/when/when-1.1.36.ebuild41
-rw-r--r--app-misc/when/when-1.1.37.ebuild41
4 files changed, 95 insertions, 0 deletions
diff --git a/app-misc/when/Manifest b/app-misc/when/Manifest
new file mode 100644
index 000000000000..cff2ac621d58
--- /dev/null
+++ b/app-misc/when/Manifest
@@ -0,0 +1,5 @@
+DIST when-1.1.36.tar.gz 50926 BLAKE2B 339e50db6b3c7e4867569e2a400563e9d53966904cf904044b3e7f7deee8e60872582011d90e1a685d69c4a1a5b9ffe2a727470bb09c8d6e1ca7780c9d0abce7 SHA512 04b2efbcebae79325d8410a5aa5cdf59662fe42c06229ebc91f3b7163091d305a6ba91914a2a9117d86807d5ca0c875d48679dbc3545162a7263679bf605a52e
+DIST when-1.1.37.tar.gz 51020 BLAKE2B 242d7833c91279bc7a73effc108a0f7d5edad9838006d8ff632c46215b7cd2a2187660075e2525a352a458a494abc648a9518945cdf18e2e7d58261e428efd8f SHA512 b1f0cb9cb797a5a32263ef2851498dfbf6a769d3e708b79ca1c5b37c7c877124194dd9b5ae78bfafebc0e73e82f306b3ae734a5ef7140fe3bf0e6b2cfcc4bb18
+EBUILD when-1.1.36.ebuild 897 BLAKE2B 7afb73f40599a10363e5a59872b337ec44c794ff9be4646cb480ffb4aff23cf745da783c10fa6608bd7a5ab0635367fb9c03671931fb47a1ee836a7ed73b32c2 SHA512 3e7ffda7ef158f9ef86933f97e041cc99014897ca1cb56dc6ef8d34e3b628ca2d8a5bcefb30790b03713993d8d5cc66bcf736118f6c8b428e9872de4eccb2a96
+EBUILD when-1.1.37.ebuild 900 BLAKE2B 70c62c2825ae71b966a08738f5eb1d03b9c300a488c67521c231503d637f8bc393040e4fe020d2d64cd90e2a78128f769095a563401c4a81ffcba6988c2d901c SHA512 1b70fb605f8e9df5670a0ca737672b1c61c64a73fa1189fe1c3f61442e6cdaba40ef5f0edd30f45bd3c724583a099c93878d409f8396dcec01bdf414ece65057
+MISC metadata.xml 271 BLAKE2B 46146f4bf13e9f4d33435225ec1012dd9bb89b20812963dc50368cab2a60a3c542052cb72f8963cc72074b2c13a5b054c77152de1d108027752601a349bc4ef8 SHA512 3e98f5382cf789992bdfc0f32e6e36eba31944be654c03f2ed9bd00baf56c8b768c256c4f8778d5775d6df38da4afcf8e32b6e6495a1ecfc8e7982c7c8943b1b
diff --git a/app-misc/when/metadata.xml b/app-misc/when/metadata.xml
new file mode 100644
index 000000000000..3e927f8d7480
--- /dev/null
+++ b/app-misc/when/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>shell-tools@gentoo.org</email>
+ <name>Gentoo Shell Tools Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-misc/when/when-1.1.36.ebuild b/app-misc/when/when-1.1.36.ebuild
new file mode 100644
index 000000000000..3caacc09cdc3
--- /dev/null
+++ b/app-misc/when/when-1.1.36.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Minimalistic personal calendar program"
+HOMEPAGE="http://www.lightandmatter.com/when/when.html"
+SRC_URI="http://www.lightandmatter.com/when/when.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/when_dist"
+
+DOCS=( README )
+
+src_prepare() {
+ default
+
+ # Fix path for tests
+ sed -i 's,^ when, ./when,' Makefile || die 'sed failed'
+}
+
+src_compile() { :; }
+
+src_test() {
+ # The when command requires these files, or attempts to run setup function.
+ mkdir "${HOME}"/.when || die 'mkdir failed'
+ touch "${HOME}"/.when/{calendar,preferences} || die 'touch failed'
+ emake test
+}
+
+src_install() {
+ dobin "${PN}"
+ doman "${PN}.1"
+ einstalldocs
+}
diff --git a/app-misc/when/when-1.1.37.ebuild b/app-misc/when/when-1.1.37.ebuild
new file mode 100644
index 000000000000..533d342eb72f
--- /dev/null
+++ b/app-misc/when/when-1.1.37.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Minimalistic personal calendar program"
+HOMEPAGE="http://www.lightandmatter.com/when/when.html"
+SRC_URI="http://www.lightandmatter.com/when/when.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/when_dist"
+
+DOCS=( README )
+
+src_prepare() {
+ default
+
+ # Fix path for tests
+ sed -i 's,^ when, ./when,' Makefile || die 'sed failed'
+}
+
+src_compile() { :; }
+
+src_test() {
+ # The when command requires these files, or attempts to run setup function.
+ mkdir "${HOME}"/.when || die 'mkdir failed'
+ touch "${HOME}"/.when/{calendar,preferences} || die 'touch failed'
+ emake test
+}
+
+src_install() {
+ dobin "${PN}"
+ doman "${PN}.1"
+ einstalldocs
+}