summaryrefslogtreecommitdiff
path: root/app-misc/wayland-utils/wayland-utils-1.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-10 21:52:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-10 21:52:51 +0100
commitfbba40085f5d1591a67b49f5aa48b4071b7560f1 (patch)
tree09e69d990e9c6d078ad475802b8728fa703bac9a /app-misc/wayland-utils/wayland-utils-1.2.0.ebuild
parent42e82780761e75f17a5cc96626558a297782f385 (diff)
gentoo auto-resync : 10:06:2023 - 21:52:51
Diffstat (limited to 'app-misc/wayland-utils/wayland-utils-1.2.0.ebuild')
-rw-r--r--app-misc/wayland-utils/wayland-utils-1.2.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-misc/wayland-utils/wayland-utils-1.2.0.ebuild b/app-misc/wayland-utils/wayland-utils-1.2.0.ebuild
new file mode 100644
index 000000000000..8ed4e3533def
--- /dev/null
+++ b/app-misc/wayland-utils/wayland-utils-1.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Display information about supported Wayland protocols and current compositor"
+HOMEPAGE="https://gitlab.freedesktop.org/wayland/wayland-utils"
+SRC_URI="https://gitlab.freedesktop.org/wayland/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-libs/wayland-1.20.0
+ >=x11-libs/libdrm-2.4.109
+"
+DEPEND="${RDEPEND}
+ dev-libs/wayland-protocols
+"
+BDEPEND="dev-util/wayland-scanner"
+
+src_configure() {
+ local emesonargs=(
+ -Ddrm=enabled
+ )
+ meson_src_configure
+}