summaryrefslogtreecommitdiff
path: root/app-misc/votrify
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
commit51af5f0eb4cddbe6aa7953717873691d77aae9ff (patch)
tree1541525274162b033ebbc3ed38abaf335fbbd49a /app-misc/votrify
parent7014a5a3ea0feffab9701fdd6b64cc7667a985af (diff)
gentoo resync : 11.07.2019
Diffstat (limited to 'app-misc/votrify')
-rw-r--r--app-misc/votrify/Manifest3
-rw-r--r--app-misc/votrify/metadata.xml8
-rw-r--r--app-misc/votrify/votrify-1.ebuild36
3 files changed, 47 insertions, 0 deletions
diff --git a/app-misc/votrify/Manifest b/app-misc/votrify/Manifest
new file mode 100644
index 000000000000..167f60bd5d36
--- /dev/null
+++ b/app-misc/votrify/Manifest
@@ -0,0 +1,3 @@
+DIST votrify-1.tar.gz 6936 BLAKE2B 7c9a5668842c5b1783e5c8b2341d42aa21257b96a82210c16e44bee8f71b690c7dba5acf48a39beff0189106db1fe141ef1ec30d68f25573a19a53c12618d346 SHA512 14fdb4ee185d96f416b47df7b29175cebc6e003aca7c1faf927b258f7dbe39b7ed69c4defb25900c6856b6e9abde3b03a69ca02152755d8532708b6cfb7f51a0
+EBUILD votrify-1.ebuild 922 BLAKE2B c5432dc33657da9ba22fdaad4b19d1e2d601e3b9e8b54198d0552d29cb857d7d73ee8034e7691cfbdf4217bb38c5b4a9a6e07da67fa5d0f59eb20408712f9109 SHA512 e43e607cb3bf8e8aa62dab8e96a7da93f1b874760125e8486af376f831e565bae66c9b7c97e3087b3c9811b9e7c52ec03610e7c8da18ba803788978f455373a4
+MISC metadata.xml 247 BLAKE2B 1750cec57189e711ca5eba89a78e1d317f0839fa53564fbd39b4e955c28d98f4ae04caf9069afc20a18536cdc92b30fe7b15eb086767c742bad07d9980cfd24b SHA512 d6e2ea8a9d74791bcbf3d6311a66bafc20b8f4db3a576d9a8d54b86d7afb231122b8d87f71f3f46360980adf8d815c633b6d5041f9a30fc8656e8fb66057a282
diff --git a/app-misc/votrify/metadata.xml b/app-misc/votrify/metadata.xml
new file mode 100644
index 000000000000..0319eec4c8be
--- /dev/null
+++ b/app-misc/votrify/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-misc/votrify/votrify-1.ebuild b/app-misc/votrify/votrify-1.ebuild
new file mode 100644
index 000000000000..f067073ac0cc
--- /dev/null
+++ b/app-misc/votrify/votrify-1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit python-single-r1
+
+DESCRIPTION="Tool for community verification of Gentoo elections"
+HOMEPAGE="https://github.com/mgorny/votrify"
+SRC_URI="https://github.com/mgorny/votrify/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-misc/gentoo-elections"
+
+src_configure() {
+ # update default location for election scripts
+ sed -i -e "s^os.path.dirname(__file__)^'${EPREFIX}/usr/lib'^" \
+ make-confirmation.py || die
+
+ # update script names
+ sed -i -e 's:\(./\)\?\(make-confirmation\|verify-confirmations\).py:votrify-\2:g' \
+ README.rst || die
+
+ python_fix_shebang *.py
+}
+
+src_install() {
+ newbin make-confirmation.py votrify-make-confirmation
+ newbin verify-confirmations.py votrify-verify-confirmations
+ einstalldocs
+}