summaryrefslogtreecommitdiff
path: root/app-misc/votrify
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /app-misc/votrify
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'app-misc/votrify')
-rw-r--r--app-misc/votrify/Manifest3
-rw-r--r--app-misc/votrify/metadata.xml4
-rw-r--r--app-misc/votrify/votrify-5-r1.ebuild58
3 files changed, 64 insertions, 1 deletions
diff --git a/app-misc/votrify/Manifest b/app-misc/votrify/Manifest
index 47f9f9331cf8..8d5b51afd1c2 100644
--- a/app-misc/votrify/Manifest
+++ b/app-misc/votrify/Manifest
@@ -1,3 +1,4 @@
DIST votrify-5.tar.gz 9192 BLAKE2B 5df0ccd0b5a843b384e002c2bd1001df06cb5bcf039f10c689abeda07f1a05c545a917b0a42bd78c06c537eacca58ef7b4c2920a0fe6809f4450d4c98ee2fade SHA512 3d441eb42f860e4e571541300a04c1a52a01abbe20f76615adc1c9764bafbff35faf0f1dbe9f9267ad3c4dc0e4cb4bc715b87e2104cdef8997e7918ab834bb5d
+EBUILD votrify-5-r1.ebuild 1361 BLAKE2B 4b64dd61fe3b153cb4d9ec4977df9df7f353caeae6162e6f95b8a62abd3811c8bb766ca40e2016714da3cac2b57b57f33804fe1b48eb686be1460849df4c6e96 SHA512 14cff2531d0aa8efe3763d3a4b3d8f959a51d0ab1a8876953339963acbbc3d83aa6333adb10ce974bfc0960cb5b4445bc1a51468d4ad4c39bb98c1f673b91233
EBUILD votrify-5.ebuild 1358 BLAKE2B 058a6a5bc20dc1dd54d946d3786e23590ef7595a4464e9452bdfc840a63118a5e06af22199ccada7500edf5dc39fe920252634d26a8b25d02db10b8b20bee64e SHA512 9dd64daf1a3022dbfeb48a52a689193b841914874413cd238c4eac535f26c3efb3a3343b672390128b46bea3fb4183505cf1f1e1b023eea866e39829561ab73f
-MISC metadata.xml 248 BLAKE2B f308d2aa052d11e427850af58bbebf95e7773f5562ed221f39043474b4c3827d724d49667edf1874272a5586a13201159f40e8f5eafb7e400e79c6566e1a6ac2 SHA512 b875c838394523483ae7d93585207eb3c642a345bbb08e1dcef3ceb737c813fa779e2f5479d48cdcc30732b8a0a9e6ecc648df940def6731e4dff43b23786e6d
+MISC metadata.xml 351 BLAKE2B 612bc076784d8be688a57e365fe3999103bef94beabe76addfaaaf36b03b5fa4d35331bb08ec96627ee7cea55224fe20d845e9b936bf6d8640a7fcf9cb214bc7 SHA512 fe84a21128deeef5ed37bb01efc34f0089b3cb2ad7db3dc5350178ed0c63138d82dd364d1c02749b87c179f5c357001d164687f32b21174a7f1ae05dd8be70bb
diff --git a/app-misc/votrify/metadata.xml b/app-misc/votrify/metadata.xml
index 076793e3f54b..cb57e8bc4008 100644
--- a/app-misc/votrify/metadata.xml
+++ b/app-misc/votrify/metadata.xml
@@ -5,4 +5,8 @@
<email>mgorny@gentoo.org</email>
<name>Michał Górny</name>
</maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">mgorny/votrify</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/app-misc/votrify/votrify-5-r1.ebuild b/app-misc/votrify/votrify-5-r1.ebuild
new file mode 100644
index 000000000000..1d8d0d94c282
--- /dev/null
+++ b/app-misc/votrify/votrify-5-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit python-single-r1
+
+DESCRIPTION="Tool for community verification of Gentoo elections"
+HOMEPAGE="https://github.com/mgorny/votrify/"
+SRC_URI="
+ https://github.com/mgorny/votrify/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ app-misc/gentoo-elections
+"
+
+src_configure() {
+ # update default location for election scripts
+ sed -i -e "s^os.path.dirname(__file__)^'${EPREFIX}/usr/lib'^" \
+ votrify-make-confirmation || die
+
+ python_fix_shebang votrify-{make,verify}-*
+}
+
+make_wrappers() {
+ local election=${1}
+
+ newbin - "votrify-${election}-make" \
+ < <(sed -e "s^@ELECTION@^${election}^" \
+ votrify-wrapper-make.bash.in || die)
+ newbin - "votrify-${election}-verify" \
+ < <(sed -e "s^@ELECTION@^${election}^" \
+ votrify-wrapper-verify.bash.in || die)
+}
+
+src_install() {
+ dobin votrify-{make,verify}-*
+ make_wrappers council-201906
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "In order to interactively create confirmation for Council 2019 election:"
+ elog " votrify-council-201906-make"
+ elog
+ elog "In order to verify the results for Council 2019 election:"
+ elog " votrify-council-201906-verify"
+}