summaryrefslogtreecommitdiff
path: root/app-misc/vcp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/vcp
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/vcp')
-rw-r--r--app-misc/vcp/Manifest4
-rw-r--r--app-misc/vcp/files/vcp-2.2-tinfo.patch11
-rw-r--r--app-misc/vcp/metadata.xml8
-rw-r--r--app-misc/vcp/vcp-2.2-r2.ebuild35
4 files changed, 58 insertions, 0 deletions
diff --git a/app-misc/vcp/Manifest b/app-misc/vcp/Manifest
new file mode 100644
index 000000000000..b8b3d340d759
--- /dev/null
+++ b/app-misc/vcp/Manifest
@@ -0,0 +1,4 @@
+AUX vcp-2.2-tinfo.patch 310 BLAKE2B 31ebbb498615f7eb9c0472cd99f85643a44a84e94dcae7d671044cc2aea9001e31e925506958db397516074f45d62ea834b28302448d158ab87038c0208244b8 SHA512 886a20474591c5fee3c70bf978977b2bc19f362dc38898eff6f44365b6edebd2eaff1cf09befc764163d32f0f2a84a80d032647266af0e7fb343b9ee6c5f82d3
+DIST vcp-2.2.tar.gz 20075 BLAKE2B 862ed1a816c45e50374e17d387d33bda3d758e155e6a38c1636000ce87de3b54928acaac5f89b0580098acb9b796e803406c9d95dec76c029fdc580d65a496b2 SHA512 3f9f60bce875f16a825b935fd241b11cc75d45b85b66133b27d16b86644c4bbfe69fa5f22571703e0ed6d235498f920a8796f6d74259db51a1abbd626c6f5137
+EBUILD vcp-2.2-r2.ebuild 741 BLAKE2B df056f3fcae3294a5b77a485f758ae3c9a253368541777c08178d5e2adf0d8b59cbe65134cab5f63cd1907b0a055dd5bdf3a3d62c9f591856df91cad2f51c02d SHA512 69900311ae134a54d5eddb17898e90e3921cfbd3c72845d09df88c0e81b1690f9645143c8c09c75813d6589d5d8242a2c4202ba63278d5b3cf5d673f0e80a29c
+MISC metadata.xml 265 BLAKE2B 75452ad720a31a08fc0dcd02eec704c18b11bc0660686f9a320b85fc879f55a564ce9c3b6a8c710781b74c5e8eb3d0544c02a042fb35a0b62a5e1491f675296a SHA512 176f814d8c555e8726f36e012367b698e8a19a0662982621029a7f9190beecc5e6798e43c51698dc149364966cdeff7061121e54fa9d4cf2a3559a6ce4904e25
diff --git a/app-misc/vcp/files/vcp-2.2-tinfo.patch b/app-misc/vcp/files/vcp-2.2-tinfo.patch
new file mode 100644
index 000000000000..715b6f1a6584
--- /dev/null
+++ b/app-misc/vcp/files/vcp-2.2-tinfo.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -4,7 +4,7 @@
+ OBJS = main.o copyall.o copy.o screen.o log.o path.o misc.o color.o
+
+ all: $(OBJS)
+- $(CC) $(CFLAGS) -o vcp $(OBJS) -lcurses
++ $(CC) $(CFLAGS) $(LDFLAGS) -o vcp $(OBJS) $(shell $(PKG_CONFIG) --libs ncurses)
+
+ .c.o:
+ $(CC) $(CFLAGS) -c -I/usr/include/ -o $@ $<
diff --git a/app-misc/vcp/metadata.xml b/app-misc/vcp/metadata.xml
new file mode 100644
index 000000000000..3cf14bf74636
--- /dev/null
+++ b/app-misc/vcp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>shell-tools@gentoo.org</email>
+ <name>Gentoo Shell Tools Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-misc/vcp/vcp-2.2-r2.ebuild b/app-misc/vcp/vcp-2.2-r2.ebuild
new file mode 100644
index 000000000000..c53cc103faa9
--- /dev/null
+++ b/app-misc/vcp/vcp-2.2-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Copy files/directories in a curses interface"
+HOMEPAGE="http://members.iinet.net.au/~lynx/vcp/"
+SRC_URI="http://members.iinet.net.au/~lynx/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ppc ~sparc x86"
+
+DEPEND="sys-libs/ncurses:0="
+RDEPEND="${DEPEND}"
+
+DOCS=( Changelog README INSTALL )
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.2-tinfo.patch
+)
+
+src_compile() {
+ filter-lfs-flags
+ emake CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ dobin "${PN}"
+ doman "${PN}.1"
+ insinto /etc
+ newins "${PN}.conf.sample" "${PN}.conf"
+ einstalldocs
+}