summaryrefslogtreecommitdiff
path: root/app-misc/vcp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
commit129160ec854dca4c3fedb5bcfbcb56930371da0f (patch)
tree53bf797418ac5e9b99c41ca0382c87b82421e5de /app-misc/vcp
parent441d1370330332b7d78f238d2f5e13f7aed5e4e0 (diff)
gentoo new year resync : 01.01.2021
Diffstat (limited to 'app-misc/vcp')
-rw-r--r--app-misc/vcp/Manifest3
-rw-r--r--app-misc/vcp/files/vcp-2.2-fno-common.patch47
-rw-r--r--app-misc/vcp/vcp-2.2-r2.ebuild8
3 files changed, 54 insertions, 4 deletions
diff --git a/app-misc/vcp/Manifest b/app-misc/vcp/Manifest
index b8b3d340d759..8d17fcc7aa1a 100644
--- a/app-misc/vcp/Manifest
+++ b/app-misc/vcp/Manifest
@@ -1,4 +1,5 @@
+AUX vcp-2.2-fno-common.patch 905 BLAKE2B 8c38e14d3b90176d196d30bae5f2770b2b13b5f95d02f78180eebfce283819d8d9cbdb2795128bf41130e6772b8f3625d1e238a83c8603a2cd8b8611802f119a SHA512 92d229db834ec3c26405d037a80b42a0404f74034ac9c23925ff0320b70e5060148dffed0a96c7090b14a4ae5479c1168741175b70342ff21682dde5af8aabb3
AUX vcp-2.2-tinfo.patch 310 BLAKE2B 31ebbb498615f7eb9c0472cd99f85643a44a84e94dcae7d671044cc2aea9001e31e925506958db397516074f45d62ea834b28302448d158ab87038c0208244b8 SHA512 886a20474591c5fee3c70bf978977b2bc19f362dc38898eff6f44365b6edebd2eaff1cf09befc764163d32f0f2a84a80d032647266af0e7fb343b9ee6c5f82d3
DIST vcp-2.2.tar.gz 20075 BLAKE2B 862ed1a816c45e50374e17d387d33bda3d758e155e6a38c1636000ce87de3b54928acaac5f89b0580098acb9b796e803406c9d95dec76c029fdc580d65a496b2 SHA512 3f9f60bce875f16a825b935fd241b11cc75d45b85b66133b27d16b86644c4bbfe69fa5f22571703e0ed6d235498f920a8796f6d74259db51a1abbd626c6f5137
-EBUILD vcp-2.2-r2.ebuild 741 BLAKE2B df056f3fcae3294a5b77a485f758ae3c9a253368541777c08178d5e2adf0d8b59cbe65134cab5f63cd1907b0a055dd5bdf3a3d62c9f591856df91cad2f51c02d SHA512 69900311ae134a54d5eddb17898e90e3921cfbd3c72845d09df88c0e81b1690f9645143c8c09c75813d6589d5d8242a2c4202ba63278d5b3cf5d673f0e80a29c
+EBUILD vcp-2.2-r2.ebuild 771 BLAKE2B 7e4cf68db4ad7481b59f6fdeec875698eb2fc0a25c31db032fc95c3248ad0d87ef2e5b642bcbad4ee2d6b89d94beb821269e15d64ef0a53799b5925c83dfab37 SHA512 10e549a432bd571b8c3763e4a28f1d8bb7c1e0b6296afac1ddd0ca759487d6ff6a3b58f7481638df95d65dfe51d521176569a4510208af96935e0fd86c4efdfc
MISC metadata.xml 265 BLAKE2B 75452ad720a31a08fc0dcd02eec704c18b11bc0660686f9a320b85fc879f55a564ce9c3b6a8c710781b74c5e8eb3d0544c02a042fb35a0b62a5e1491f675296a SHA512 176f814d8c555e8726f36e012367b698e8a19a0662982621029a7f9190beecc5e6798e43c51698dc149364966cdeff7061121e54fa9d4cf2a3559a6ce4904e25
diff --git a/app-misc/vcp/files/vcp-2.2-fno-common.patch b/app-misc/vcp/files/vcp-2.2-fno-common.patch
new file mode 100644
index 000000000000..394cbaede850
--- /dev/null
+++ b/app-misc/vcp/files/vcp-2.2-fno-common.patch
@@ -0,0 +1,47 @@
+--- a/common.h
++++ b/common.h
+@@ -23,8 +23,8 @@
+ #define T_DIR 1 /* -> DIR */
+ #define T_NED 2 /* DIR -> NON-EXISTENT DIR */
+
+-WINDOW *mainw;
+-WINDOW *logw;
++extern WINDOW *mainw;
++extern WINDOW *logw;
+
+ struct dest_new {
+ char *opath;
+--- a/log.c
++++ b/log.c
+@@ -13,6 +13,8 @@
+ #include "screen.h"
+ #include "color.h"
+
++extern WINDOW *logw;
++
+ int logaddi(int code, char *base, int var, int var2) {
+
+ if(code == LOG_VRB && !vflag)
+--- a/misc.c
++++ b/misc.c
+@@ -22,6 +22,8 @@
+ #include "color.h"
+ #include "screen.h"
+
++extern WINDOW *logw;
++
+ int statit(char *path,struct stat *st,int cmdline) {
+ if(Rflag) {
+ if(pflag || ((Hflag) && !cmdline))
+--- a/screen.c
++++ b/screen.c
+@@ -17,6 +17,9 @@
+ int winw,winh,mainww;
+ int mainwsbw; /* width of status bar */
+
++WINDOW *mainw;
++WINDOW *logw;
++
+ /* create windows, draw border and title */
+ void scrn_draw() {
+ int dev_null;
diff --git a/app-misc/vcp/vcp-2.2-r2.ebuild b/app-misc/vcp/vcp-2.2-r2.ebuild
index c53cc103faa9..686e5ab2df44 100644
--- a/app-misc/vcp/vcp-2.2-r2.ebuild
+++ b/app-misc/vcp/vcp-2.2-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit flag-o-matic toolchain-funcs
@@ -17,8 +17,10 @@ DEPEND="sys-libs/ncurses:0="
RDEPEND="${DEPEND}"
DOCS=( Changelog README INSTALL )
+
PATCHES=(
- "${FILESDIR}"/${PN}-2.2-tinfo.patch
+ "${FILESDIR}"/${P}-tinfo.patch
+ "${FILESDIR}"/${P}-fno-common.patch
)
src_compile() {