summaryrefslogtreecommitdiff
path: root/app-misc/vcontrold/vcontrold-0.98.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-25 19:33:39 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-25 19:33:39 +0100
commita5b65c81168c90928784a1e92cda84ed5d6b9eb3 (patch)
tree4aa7483cd0ad7de54338afc8e7971417abe1dd81 /app-misc/vcontrold/vcontrold-0.98.8.ebuild
parente8f81810baa21f490d6910e8e2d424546b72a333 (diff)
gentoo resync : 25.09.2019
Diffstat (limited to 'app-misc/vcontrold/vcontrold-0.98.8.ebuild')
-rw-r--r--app-misc/vcontrold/vcontrold-0.98.8.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-misc/vcontrold/vcontrold-0.98.8.ebuild b/app-misc/vcontrold/vcontrold-0.98.8.ebuild
new file mode 100644
index 000000000000..67b70f6ed21c
--- /dev/null
+++ b/app-misc/vcontrold/vcontrold-0.98.8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Daemon for communication with Viessmann Vito heatings"
+HOMEPAGE="https://github.com/openv/vcontrold/"
+SRC_URI="https://github.com/openv/vcontrold/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+man +vclient vsim"
+
+RDEPEND="dev-libs/libxml2:2"
+DEPEND="${RDEPEND}
+ man? ( dev-python/docutils )"
+
+src_prepare() {
+ sed "s/@VERSION@/${PV}/" "src/version.h.in" \
+ > "src/version.h" || die "Setting version failed"
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DMANPAGES="$(usex man)"
+ -DVCLIENT="$(usex vclient)"
+ -DVSIM="$(usex vsim)"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ doinitd "${FILESDIR}/vcontrold"
+ insinto /etc/vcontrold/
+ doins -r xml
+}