summaryrefslogtreecommitdiff
path: root/app-misc/unfoo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/unfoo
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/unfoo')
-rw-r--r--app-misc/unfoo/Manifest3
-rw-r--r--app-misc/unfoo/metadata.xml14
-rw-r--r--app-misc/unfoo/unfoo-1.0.8.ebuild50
3 files changed, 67 insertions, 0 deletions
diff --git a/app-misc/unfoo/Manifest b/app-misc/unfoo/Manifest
new file mode 100644
index 000000000000..0278827a85a9
--- /dev/null
+++ b/app-misc/unfoo/Manifest
@@ -0,0 +1,3 @@
+DIST unfoo-1.0.8.tar.gz 31862 BLAKE2B adba517a24a1fde7e1733b10a0c69d1ee5b0827adfadf89a7073366f77bfa2439413c1ce682d9a6d24f8b7b0402f409c84754f75dd5ee31c03ab51ffe3918f81 SHA512 b4a2489ca4ae5a81feacc57aa7c9c6437e3fbb0cec997d1b5e182e9ea7e19c13998968f23094e78908e6d41e699d50a1353ae475ec32146c63298eff06182281
+EBUILD unfoo-1.0.8.ebuild 1257 BLAKE2B df7a151daa8ebc3ac5ec29489ff9852d9efcd76d5f9b654b3f96ee1e6f2df545cf4cf7851ae37c4f6175d3bdd1e197ec3070ba3609281ea0e39b0c352adf1b00 SHA512 482c1a29dd5d23ce398495b0838257d4ffa41e4a48ee1fbb616e7c590e83a7d5309d23f211263af966f7e7699e52a651698530cf7f502c560bf4ff7c1bdba4b1
+MISC metadata.xml 443 BLAKE2B df80de233a6c7d23093b4770b2f4064c389ae85837b7a405a1b3132c42bd050ea99b6ff922d75d118e616c011191f4d708a0080b094aa40e938fcefb556f6f14 SHA512 d51afbee4941d3a6d5239b983e2beec524d9991c67131f691cf0f424b4ab5e798405fe89f7d8019c912a4e54413bf38f611bbb1574c4cef809440d7a1a60ee3e
diff --git a/app-misc/unfoo/metadata.xml b/app-misc/unfoo/metadata.xml
new file mode 100644
index 000000000000..ef237e78bfe9
--- /dev/null
+++ b/app-misc/unfoo/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>shell-tools@gentoo.org</email>
+ <name>Gentoo Shell Tools Project</name>
+ </maintainer>
+ <use>
+ <flag name="minimal">Do not install all support archive binaries</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">jlec/unfoo</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-misc/unfoo/unfoo-1.0.8.ebuild b/app-misc/unfoo/unfoo-1.0.8.ebuild
new file mode 100644
index 000000000000..cc38a96c3784
--- /dev/null
+++ b/app-misc/unfoo/unfoo-1.0.8.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A simple bash driven frontend to simplify decompression of files"
+HOMEPAGE="http://obsoleet.org/code/unfoo"
+SRC_URI="https://github.com/jlec/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 ~s390 x86 ~amd64-linux ~x86-linux"
+IUSE="+minimal test"
+
+COMMON_DEPS="
+ || (
+ app-arch/bzip2
+ app-arch/lbzip2[symlink]
+ app-arch/pbzip2[symlink] )
+ || (
+ app-arch/gzip
+ app-arch/pigz[symlink] )
+ app-arch/p7zip
+ || (
+ app-arch/rar
+ app-arch/unrar )
+ app-arch/unace
+ app-arch/unzip
+ app-arch/xz-utils"
+RDEPEND="!minimal? ( ${COMMON_DEPS} )"
+DEPEND="test? ( ${COMMON_DEPS} )"
+
+src_compile() { :; }
+
+src_install() {
+ dodoc README*
+ dobin ${PN}
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ echo
+ elog "unfoo can handle far more than just .tar*, but it requires some"
+ elog "optional packages to do so. For a list, either consult the source"
+ elog "(less /usr/bin/unfoo), or see http://obsoleet.org/code/unfoo"
+ elog "To get full support please use USE=-minimal"
+ elif [[ ${REPLACING_VERSIONS} < 1.0.7 ]]; then
+ elog "To get full support please use USE=-minimal"
+ fi
+}