summaryrefslogtreecommitdiff
path: root/app-misc/ttyload/ttyload-0.5.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/ttyload/ttyload-0.5.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/ttyload/ttyload-0.5.3.ebuild')
-rw-r--r--app-misc/ttyload/ttyload-0.5.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-misc/ttyload/ttyload-0.5.3.ebuild b/app-misc/ttyload/ttyload-0.5.3.ebuild
new file mode 100644
index 000000000000..0ef762b01215
--- /dev/null
+++ b/app-misc/ttyload/ttyload-0.5.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="color-coded graph of load averages over time"
+HOMEPAGE="http://www.daveltd.com/src/util/ttyload https://github.com/lindes/ttyload"
+SRC_URI="http://www.daveltd.com/src/util/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="ISC"
+SLOT="0"
+
+DEPEND="sys-libs/ncurses:0="
+
+RESTRICT="test"
+
+DOCS=( BUGS HISTORY LICENSE README.md TODO )
+
+src_prepare() {
+ default
+ sed -i '10i#include <time.h>' "${PN}.h" || die
+ sed -i -e "s#make#$\(MAKE\)#" Makefile || die
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ dobin "${PN}"
+ doman "${PN}.1"
+ einstalldocs
+}