summaryrefslogtreecommitdiff
path: root/app-misc/transfolio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /app-misc/transfolio
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'app-misc/transfolio')
-rw-r--r--app-misc/transfolio/Manifest3
-rw-r--r--app-misc/transfolio/metadata.xml13
-rw-r--r--app-misc/transfolio/transfolio-1.0.1.ebuild31
3 files changed, 47 insertions, 0 deletions
diff --git a/app-misc/transfolio/Manifest b/app-misc/transfolio/Manifest
new file mode 100644
index 000000000000..2e9ffd3be6dd
--- /dev/null
+++ b/app-misc/transfolio/Manifest
@@ -0,0 +1,3 @@
+DIST transfolio-1.0.1.zip 158362 BLAKE2B 291e80e3576c3d92f00905c49d891c9ff926229cc2d843520b9b69f44660ec16ea274b4b68f4d8f3e353d140a6f8549697f3d2456310a5cd3a0e736ff6e0b61a SHA512 5d8c348cabcc3765c192a200ec011344960704085e815d249db23ac3669760c15ec343b16ecdce3469f49f76872f6f93563d50a96cf305f75ed19235d3a5d665
+EBUILD transfolio-1.0.1.ebuild 615 BLAKE2B e38d0ce4bd582cf15d3150b1fbc395e597dd116b545029da4330abf72e600bf3553ab236e6bac31779a1dbab4ecf165d5e4b1e84138fe27ec96d1d2e6fa01388 SHA512 9912631f08b9e20352833c1d22c80e1c28180cda56f9c11a2bb53353acf4e5ebeee00a6a26b69ae9714f9840bac3ed3d0a49b450c81746302914154ca4455925
+MISC metadata.xml 455 BLAKE2B daac1fc9779cbf0d98aa7e7bb3a42bb5b39b23a2e37f286252f7a427a327e6f15bb7357cf08d98a7f13331fc2b34d721f3723d28d5ca770b82eecaff07e96835 SHA512 b3422e3bf6f540318733516149e402521f2ccb83c3ebe89d5554a1fb505023eae6bdba8649a85c820208704213ec355555309189a49815cbc2408fafb7e5f99e
diff --git a/app-misc/transfolio/metadata.xml b/app-misc/transfolio/metadata.xml
new file mode 100644
index 000000000000..ca128838bc3e
--- /dev/null
+++ b/app-misc/transfolio/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>conikost@gentoo.org</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <longdescription>
+ TransFolio is a command line tool for Linux and Windows,
+ which enables data transfer between the PC and the Atari Portfolio,
+ as did Atari's DOS program FT.COM.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-misc/transfolio/transfolio-1.0.1.ebuild b/app-misc/transfolio/transfolio-1.0.1.ebuild
new file mode 100644
index 000000000000..e05ba9d60081
--- /dev/null
+++ b/app-misc/transfolio/transfolio-1.0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Enables data transfer between the PC and the Atari Portfolio"
+HOMEPAGE="http://leute.server.de/peichl/"
+SRC_URI="http://leute.server.de/peichl/transfolio.zip -> ${P}.zip"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="app-arch/unzip"
+
+src_prepare() {
+ default
+
+ # Respect users CC, CFLAGS and disable striping
+ sed -e 's/cc/${CC}/' -e 's/-O2/${CFLAGS}/' -e '/strip/d' -i Makefile || die
+
+ tc-export CC
+}
+
+src_install() {
+ dobin transfolio
+
+ einstalldocs
+}