summaryrefslogtreecommitdiff
path: root/app-misc/tpipe
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/tpipe
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/tpipe')
-rw-r--r--app-misc/tpipe/Manifest3
-rw-r--r--app-misc/tpipe/metadata.xml11
-rw-r--r--app-misc/tpipe/tpipe-1.6-r1.ebuild29
3 files changed, 43 insertions, 0 deletions
diff --git a/app-misc/tpipe/Manifest b/app-misc/tpipe/Manifest
new file mode 100644
index 000000000000..231135b8b04b
--- /dev/null
+++ b/app-misc/tpipe/Manifest
@@ -0,0 +1,3 @@
+DIST tpipe-1.6.tar.gz 12425 BLAKE2B 858af3a98efa0f27fd07aa49ad99928326ff8d458c6eddd790bcc487bdda26971a031d3bc539b07e8a031ec5190fd089d5bcd8490da1c26c1df480b3367d5f05 SHA512 3429a7ee0711f47e87ed2c46009c43dd7c3fa378a98083da58f22d1cd0a87cbbe7a900e98abc05d1375ffe8cfe56e02d25991f53a42bca1825556b07983bbb8d
+EBUILD tpipe-1.6-r1.ebuild 593 BLAKE2B fc82932596282b8beb6bdad096c834d30d4287c36bf15799c3562dc56d4f0485ebcf2629a247845496aed26a10f76578e7e0e6d7e6edaa00f404b51b0cefa2eb SHA512 945b18bf06a9f1c7dc44f310c093c94505ea0cff40aa171d6fcd886ae4923cac4c62396ecfbf6944ff915aa6aa324c2ca06d3c00f8624a204da8f8d096d51f3e
+MISC metadata.xml 340 BLAKE2B 1b8e3d8c63bbf9c13abb02d6b481b48c873e490e3b51433aa383e1200e0f4973db3185fc35d4b1d86769e2676472a05121201d6b1097eb9c9967560eb5b47cb9 SHA512 89a4258d97e48449e730ace4f3a7a3b65311a9fac535898d3812bc10f678969c9efeaa82c5b978fc594cfbd89ce04509bb988d97bf063bf1f0b50139888bc4a7
diff --git a/app-misc/tpipe/metadata.xml b/app-misc/tpipe/metadata.xml
new file mode 100644
index 000000000000..02adc18a1cf9
--- /dev/null
+++ b/app-misc/tpipe/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>robbat2@gentoo.org</email>
+</maintainer>
+<maintainer type="project">
+ <email>shell-tools@gentoo.org</email>
+ <name>Gentoo Shell Tools Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/app-misc/tpipe/tpipe-1.6-r1.ebuild b/app-misc/tpipe/tpipe-1.6-r1.ebuild
new file mode 100644
index 000000000000..034575fcdaa3
--- /dev/null
+++ b/app-misc/tpipe/tpipe-1.6-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Command to duplicate standard input to more than one program"
+HOMEPAGE="http://www.eurogaran.com/downloads/tpipe"
+SRC_URI="http://www.eurogaran.com/downloads/tpipe/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+DOCS=( README.txt )
+
+src_compile() {
+ emake OPTFLAGS="-ansi -pedantic ${CFLAGS}" \
+ PREFIX=/usr \
+ CC="$(tc-getCC)" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin "${PN}"
+ doman "${PN}.1"
+ einstalldocs
+}