summaryrefslogtreecommitdiff
path: root/app-misc/tpipe
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-01 03:14:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-01 03:14:33 +0100
commit0c764edfecb7e9e124d4669acd98bed09e23b6c0 (patch)
tree2862ab17d2f88cb7c9614b7fbe579f25ae604b8d /app-misc/tpipe
parentae1bf373db295b495e1f685d116e3411bf10df0b (diff)
gentoo auto-resync : 01:08:2022 - 03:14:32
Diffstat (limited to 'app-misc/tpipe')
-rw-r--r--app-misc/tpipe/Manifest4
-rw-r--r--app-misc/tpipe/files/tpipe-1.6-Wimplicit-function-declaration.patch21
-rw-r--r--app-misc/tpipe/files/tpipe-1.6-makefile.patch32
-rw-r--r--app-misc/tpipe/tpipe-1.6-r2.ebuild (renamed from app-misc/tpipe/tpipe-1.6-r1.ebuild)20
4 files changed, 66 insertions, 11 deletions
diff --git a/app-misc/tpipe/Manifest b/app-misc/tpipe/Manifest
index 283cbd3d9449..3f84449561c2 100644
--- a/app-misc/tpipe/Manifest
+++ b/app-misc/tpipe/Manifest
@@ -1,3 +1,5 @@
+AUX tpipe-1.6-Wimplicit-function-declaration.patch 406 BLAKE2B 886ad30347ec83e2b1f346b41fc80377731e6a2e25d06203253395b2bd89b23d91a8e50fe11ffa0f0094de5c1588cd5d32edda55299c37a6fe60cac1ab8941f4 SHA512 c94647e626c1b4d3820326dfd62287b1e6fa1eece598fd461cadbcd10840bdf98ad147f628b7fceb6404d86aaf6b7dc96f370dac66e491732c06d7d805e4cb59
+AUX tpipe-1.6-makefile.patch 621 BLAKE2B e7bf677de284cabaf4efdc325d8413492882e9ef2135b586bce59052be3e766488d67069e92d61665918cb432ad0e343616ade7050cab35229894fe208b0a188 SHA512 1ab97858e76782c38eea25968cf66b32bc46a739bfab734ca7d3d548ef83e18e160000032d4bf3e9bb43f6b380c1f3e888e9ed5be975e25bb9385264a6242118
DIST tpipe-1.6.tar.gz 12425 BLAKE2B 858af3a98efa0f27fd07aa49ad99928326ff8d458c6eddd790bcc487bdda26971a031d3bc539b07e8a031ec5190fd089d5bcd8490da1c26c1df480b3367d5f05 SHA512 3429a7ee0711f47e87ed2c46009c43dd7c3fa378a98083da58f22d1cd0a87cbbe7a900e98abc05d1375ffe8cfe56e02d25991f53a42bca1825556b07983bbb8d
-EBUILD tpipe-1.6-r1.ebuild 593 BLAKE2B fc82932596282b8beb6bdad096c834d30d4287c36bf15799c3562dc56d4f0485ebcf2629a247845496aed26a10f76578e7e0e6d7e6edaa00f404b51b0cefa2eb SHA512 945b18bf06a9f1c7dc44f310c093c94505ea0cff40aa171d6fcd886ae4923cac4c62396ecfbf6944ff915aa6aa324c2ca06d3c00f8624a204da8f8d096d51f3e
+EBUILD tpipe-1.6-r2.ebuild 580 BLAKE2B a08ff39a8b7a681764715427d746c3d4b985cc552eb26c03d20900144feb75c89a83d5ab47900a9dfb93c87348a9435102309d889a24fc0426e793c76db16b69 SHA512 e2a82ec9420de039ba633cc9ac75bf0a0ee5418cb58ec9671ad5b36f74ea7e3b7a545b942e743ef92ed21dd66814fbfc71585231966d4f427de49cdf20c45ef0
MISC metadata.xml 341 BLAKE2B 36cc2fe3b5d134609b3b7317a6d6591fd601c8442545770979e26c2b99e531112522703df6aea42f8e9fd871baa617428a3ac34376931a710468f75e5e622637 SHA512 e51e4016e2e1bd296dc1c9d9f58a2ef0af5d34ecdddcf556d07e646fee90d992fd4bd8dc74571fff0877e66898ed90c39eb978d74200cdff1278bafdbc12e39f
diff --git a/app-misc/tpipe/files/tpipe-1.6-Wimplicit-function-declaration.patch b/app-misc/tpipe/files/tpipe-1.6-Wimplicit-function-declaration.patch
new file mode 100644
index 000000000000..9a8a094f06b7
--- /dev/null
+++ b/app-misc/tpipe/files/tpipe-1.6-Wimplicit-function-declaration.patch
@@ -0,0 +1,21 @@
+--- a/tap.c
++++ b/tap.c
+@@ -94,7 +94,7 @@
+ else
+ n = strtoul(argv[1],NULL,0);
+
+- if (!(n)&&(argv[1] != '\0')) {
++ if (!(n)&&(*argv[1] != '\0')) {
+ fprintf (stderr, "%s: Unreadable integer arg.; Assuming 1.\n",argv[0]);
+ n = 1;
+ }
+--- a/tpipe.c
++++ b/tpipe.c
+@@ -41,6 +41,7 @@
+
+ #include <stdio.h>
+ #include <string.h> /* strcmp() */
++#include <stdlib.h>
+
+ #ifndef VERSION
+ #define VERSION "1.6"
diff --git a/app-misc/tpipe/files/tpipe-1.6-makefile.patch b/app-misc/tpipe/files/tpipe-1.6-makefile.patch
new file mode 100644
index 000000000000..7ec3566b107f
--- /dev/null
+++ b/app-misc/tpipe/files/tpipe-1.6-makefile.patch
@@ -0,0 +1,32 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,27 +1,16 @@
+ # Change values of variables to adapt.
+-CC = gcc
+ PRG1 = tpipe
+ OBJS1 = $(PRG1).o
+ PRG2 = tap
+ OBJS2 =$(PRG2).o
+-OPTFLAGS= -ansi -pedantic -O4
+-CFLAGS = -Wall $(OPTFLAGS)
+-LDFLAGS = -L.
++OPTFLAGS= -pedantic
++CFLAGS += -Wall $(OPTFLAGS)
+ PREFIX = /usr/local
+ BINDIR = $(PREFIX)/bin
+ MANDIR = $(PREFIX)/man/man1
+
+ all: $(PRG1) $(PRG2)
+
+-.c.o:
+- $(CC) -c $(CFLAGS) -o $@ $<
+-
+-$(PRG1): $(OBJS1)
+- $(CC) $(CFLAGS) -o $(PRG1) $(OBJS1) $(LDFLAGS) $(LIBS)
+-
+-$(PRG2): $(OBJS2)
+- $(CC) $(CFLAGS) -o $(PRG2) $(OBJS2) $(LDFLAGS) $(LIBS)
+-
+ clean:
+ rm -f *~ *.o $(PRG1) $(PRG2)
+
diff --git a/app-misc/tpipe/tpipe-1.6-r1.ebuild b/app-misc/tpipe/tpipe-1.6-r2.ebuild
index 034575fcdaa3..8b37b96a2605 100644
--- a/app-misc/tpipe/tpipe-1.6-r1.ebuild
+++ b/app-misc/tpipe/tpipe-1.6-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit toolchain-funcs
@@ -13,17 +13,17 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-DOCS=( README.txt )
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile.patch
+ "${FILESDIR}"/${P}-Wimplicit-function-declaration.patch
+)
-src_compile() {
- emake OPTFLAGS="-ansi -pedantic ${CFLAGS}" \
- PREFIX=/usr \
- CC="$(tc-getCC)" \
- LDFLAGS="${LDFLAGS}"
+src_configure() {
+ tc-export CC
}
src_install() {
- dobin "${PN}"
- doman "${PN}.1"
+ dobin tpipe
einstalldocs
+ doman tpipe.1
}