summaryrefslogtreecommitdiff
path: root/app-misc/todo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/todo
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/todo')
-rw-r--r--app-misc/todo/Manifest4
-rw-r--r--app-misc/todo/files/todo-2.10-fix-bash-completion.patch12
-rw-r--r--app-misc/todo/metadata.xml11
-rw-r--r--app-misc/todo/todo-2.10-r2.ebuild58
4 files changed, 85 insertions, 0 deletions
diff --git a/app-misc/todo/Manifest b/app-misc/todo/Manifest
new file mode 100644
index 000000000000..f18afde93eaf
--- /dev/null
+++ b/app-misc/todo/Manifest
@@ -0,0 +1,4 @@
+AUX todo-2.10-fix-bash-completion.patch 344 BLAKE2B 8e19719ce96559e49715bec34e6e4b90ea2c3dae9d4a4ecd1a05be51919f5ae8d7a1a29fa55ae3d70d0c42e8e55b6bab596b598116a5f8399a9a4e95df3415e9 SHA512 eb7bf79eabc912f3a5ca211ff1c4d5ac09cb42b2a8719a8c60a1f0880d89703afbe7073a640ac1b8ef8bf0d8c5ec8e2891faf924123d3bbe04f37479eadac95d
+DIST todo-2.10.tar.gz 56509 BLAKE2B ec89d12506b5025bab8d05bab1122d48ef2e9edb811c4091c1ff96b4b18c2ced54026d3d908a565278804c15c6fbde8aef3ae5a0cb23d4b12bb36133fce5bb2c SHA512 b14d9d13948836d971f72b941770e8e2c59d171d35f074205900619c5c3efd7ca0a482887046c1865890afb6595fe27c69677c54ea5824163d291e16fa5329d3
+EBUILD todo-2.10-r2.ebuild 1382 BLAKE2B ff3db41a533a0b4ce6ab4ff531cd2fdc77efdaf791ee4dbc910ca3406dc5330d5ad457ec7ebd3546b0ac21ca4ad89b17ac3716fa3cd9940a254bf721eb5326e5 SHA512 65deff8ee79cab1ccfafeff098960bbe5c9c1585d48f55c5beb112fbf9090bb15b50e29ea6d3489ba581b80d0a413d47987edb3a6d595af96bdfbd7292bce203
+MISC metadata.xml 340 BLAKE2B 8102ae5fb34dd55116c96b815406f86d08345c3e039d5c2878b8e7f8e0e4d6a60543ae7cbf9d2ba877230b40175dcaf6e7eae6d7877ee536a6ff30786e660584 SHA512 ff000ddeb9f4b80721053c17a66f5d9792b601c4710a3577ae86fc09ddd3456b934aecad94297b5985338a87ace1b59288394fcef05bd002cd2180ccf6f59a84
diff --git a/app-misc/todo/files/todo-2.10-fix-bash-completion.patch b/app-misc/todo/files/todo-2.10-fix-bash-completion.patch
new file mode 100644
index 000000000000..7e6de2f10568
--- /dev/null
+++ b/app-misc/todo/files/todo-2.10-fix-bash-completion.patch
@@ -0,0 +1,12 @@
+--- ./todo_completion 2017-04-08 15:18:23.102736966 +0200
++++ ./todo_completion 2017-04-08 15:18:56.839725605 +0200
+@@ -85,6 +85,9 @@
+ }
+ complete -F _todo todo.sh
+
++# Gentoo bug 614400
++complete -F _todo todotxt
++
+ # If you define an alias (e.g. "t") to todo.sh, you need to explicitly enable
+ # completion for it, too:
+ #complete -F _todo t
diff --git a/app-misc/todo/metadata.xml b/app-misc/todo/metadata.xml
new file mode 100644
index 000000000000..18711a51920c
--- /dev/null
+++ b/app-misc/todo/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>monsieurp@gentoo.org</email>
+ <name>Patrice Clement</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ginatrapani/todo.txt-cli</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-misc/todo/todo-2.10-r2.ebuild b/app-misc/todo/todo-2.10-r2.ebuild
new file mode 100644
index 000000000000..69c2994478d7
--- /dev/null
+++ b/app-misc/todo/todo-2.10-r2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1
+
+DESCRIPTION="A CLI-based TODO list manager"
+HOMEPAGE="http://todotxt.com"
+SRC_URI="https://github.com/ginatrapani/${PN}.txt-cli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="app-shells/bash"
+
+PATCHES=( "${FILESDIR}/${P}-fix-bash-completion.patch" )
+
+DOCS=( README.textile CONTRIBUTING.md LICENSE todo.cfg )
+
+S="${WORKDIR}/${PN}.txt-cli-${PV}"
+
+src_prepare() {
+ default
+
+ # TODO_DIR variable is bogus
+ sed -i -e '/export TODO_DIR/d' todo.cfg || die
+ sed -i -e '4i export TODO_DIR="$HOME/.todo"' todo.cfg || die
+}
+
+src_test() {
+ make test || die "tests failed"
+}
+
+src_install() {
+ newbin "${PN}.sh" "${PN}cli"
+ dosym "${PN}cli" "/usr/bin/${PN}txt"
+ newbashcomp "${PN}_completion" "${PN}cli.sh"
+ bashcomp_alias "${PN}cli.sh" "${PN}txt"
+ einstalldocs
+}
+
+pkg_postinst() {
+ einfo
+ einfo 'Before starting todo, make sure to create'
+ einfo 'a .todo directory in your home directory:'
+ einfo ' $ mkdir -p $HOME/.todo'
+ einfo
+ einfo 'and make sure to copy the default todo'
+ einfo 'configuration file in the same location:'
+ einfo " $ bzcat /usr/share/doc/${PF}/todo.cfg.bz2 > \$HOME/.todo/config"
+ einfo
+ einfo 'You can then edit this file as you see fit.'
+ einfo 'Enjoy!'
+ einfo
+}