summaryrefslogtreecommitdiff
path: root/app-misc/tmux/tmux-2.9a.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /app-misc/tmux/tmux-2.9a.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'app-misc/tmux/tmux-2.9a.ebuild')
-rw-r--r--app-misc/tmux/tmux-2.9a.ebuild86
1 files changed, 0 insertions, 86 deletions
diff --git a/app-misc/tmux/tmux-2.9a.ebuild b/app-misc/tmux/tmux-2.9a.ebuild
deleted file mode 100644
index 5ff428db33a9..000000000000
--- a/app-misc/tmux/tmux-2.9a.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools flag-o-matic
-
-DESCRIPTION="Terminal multiplexer"
-HOMEPAGE="https://tmux.github.io/"
-if [[ "${PV}" == 9999 ]] ; then
- inherit git-r3
- SRC_URI="https://raw.githubusercontent.com/przepompownia/tmux-bash-completion/678a27616b70c649c6701cae9cd8c92b58cc051b/completions/tmux -> tmux-bash-completion-678a27616b70c649c6701cae9cd8c92b58cc051b"
- EGIT_REPO_URI="https://github.com/tmux/tmux.git"
-else
- SRC_URI="https://github.com/tmux/tmux/releases/download/${PV}/${P/_/-}.tar.gz"
- [[ "${PV}" == *_rc* ]] || \
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
- S="${WORKDIR}/${P/_/-}"
-fi
-
-LICENSE="ISC"
-SLOT="0"
-IUSE="debug selinux utempter vim-syntax kernel_FreeBSD kernel_linux"
-
-DEPEND="
- dev-libs/libevent:0=
- sys-libs/ncurses:0=
- utempter? ( sys-libs/libutempter )
-"
-
-BDEPEND="
- virtual/pkgconfig"
-
-RDEPEND="
- ${DEPEND}
- selinux? ( sec-policy/selinux-screen )
- vim-syntax? ( app-vim/vim-tmux )"
-
-DOCS=( CHANGES README TODO )
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.4-flags.patch"
-
- # upstream fixes (can be removed with next version bump)
-)
-
-src_prepare() {
- # bug 438558
- # 1.7 segfaults when entering copy mode if compiled with -Os
- replace-flags -Os -O2
-
- default
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- --sysconfdir="${EPREFIX}"/etc
- $(use_enable debug)
- $(use_enable utempter)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
-
- einstalldocs
-
- dodoc example_tmux.conf
- docompress -x /usr/share/doc/${PF}/example_tmux.conf
-}
-
-pkg_postinst() {
- if ! ver_test 1.9a -ge ${REPLACING_VERSIONS:-1.9a}; then
- echo
- ewarn "Some configuration options changed in this release."
- ewarn "Please read the CHANGES file in /usr/share/doc/${PF}/"
- ewarn
- ewarn "WARNING: After updating to ${P} you will _not_ be able to connect to any"
- ewarn "older, running tmux server instances. You'll have to use an existing client to"
- ewarn "end your old sessions or kill the old server instances. Otherwise you'll have"
- ewarn "to temporarily downgrade to access them."
- echo
- fi
-}