summaryrefslogtreecommitdiff
path: root/app-misc/timew
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-17 17:57:35 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-17 17:57:35 +0100
commit7932d472a02d4c016ff7dff4b7a5479ab9d1883d (patch)
treed07709230f82777cae6ba7dab35aee31896060fb /app-misc/timew
parentd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (diff)
gentoo resync : 17.06.2021
Diffstat (limited to 'app-misc/timew')
-rw-r--r--app-misc/timew/Manifest2
-rw-r--r--app-misc/timew/timew-1.4.3.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/app-misc/timew/Manifest b/app-misc/timew/Manifest
index 89cb5616e969..3868aafb12a0 100644
--- a/app-misc/timew/Manifest
+++ b/app-misc/timew/Manifest
@@ -1,3 +1,5 @@
DIST timew-1.4.2.tar.gz 1316841 BLAKE2B c451f37aeb32e999fe2cdca2eb5f234c7424b76f489324d5723a3649da37f53f5094989bdf8d5c2d27f5daa0d75c72ec4a01e3c19b8b064f28e4db82587498b9 SHA512 fe4c3def6b2cd78793dd97a38a61497b3910cd87a3315f826c64893b96a998bf30363f0df1892b74b718d03a279d51c1a636739225e101c5c126794e434076f0
+DIST timew-1.4.3.tar.gz 3188726 BLAKE2B ded92b2ba801023e7f6bc59c0fc17ce069c8279ee92f39280c50dabec0a2425b8612f73edf7842abdbb0b21772244eda325512070c091f32d17ff69cfcd844fa SHA512 89c98ad19d3a5ab5d4e02819d79e553cca4e93da99ec02bbf845b96b421cd084f6786de160e90c97854b50da49448472e9a4c7d23e75c8a93ecd67dda768b24a
EBUILD timew-1.4.2.ebuild 888 BLAKE2B 41a2e83233277e5722567378b7337c33302b6319ade5605c9d3e32ed99896d523d1833f4ddc164e5345d4f83b5bee9af346f63b5d40dd59849e5c12ef7279263 SHA512 cb84813049c46eb18090f022e77c9eab56ecc4e72011bea60d12ed95f0e8f8b5e048fefd343c48bfa8eacdca447c3e83285f79b80ca9b4350af3e08abf5e1565
+EBUILD timew-1.4.3.ebuild 955 BLAKE2B 2c4c04e5648164f752bf91224240c8fa35c390dc56c979af0f49a8931ccd090f990c711588aa207d8e54ed1272a940e8f18b581457459c245bdb85aff535bfcf SHA512 2f66cf61771d1c04f16f0d230203d37dae2284ae4d81e7bedae228f4a884a1121053f90064856a11cee0e32ebade3bcf650acc372d6ff7c6d7c4b64b558e57c8
MISC metadata.xml 708 BLAKE2B 879f68ac24d859950a032eb1273b95acd3039af650bd1c58566338306263008a9afca6f7aa9198cac0878caf81d22187856076658dbb24ee48a6b3d1f5e9b4f7 SHA512 2455c4358bf999a15ff468dfef75d932dc394385e5d993ec5cb41d69d410279807f80d90bf6cd4a34fd39ca9a43141597bd5d1719d5a550045e460683244c6b1
diff --git a/app-misc/timew/timew-1.4.3.ebuild b/app-misc/timew/timew-1.4.3.ebuild
new file mode 100644
index 000000000000..e037edcce536
--- /dev/null
+++ b/app-misc/timew/timew-1.4.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Tracks your time from the command line, and generates reports"
+HOMEPAGE="https://timewarrior.net"
+SRC_URI="https://github.com/GothenburgBitFactory/timewarrior/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_configure() {
+ mycmakeargs=(
+ -DTIMEW_DOCDIR=share/doc/${PF}
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ cd "${WORKDIR}"/"${P}"_build || die
+
+ eninja test
+}
+
+src_install() {
+ cmake_src_install
+
+ dodoc -r ext
+ docompress -x /usr/share/doc/${PF}/ext/{on-modify.timewarrior,README}
+}
+
+pkg_postinst() {
+ elog "To integrate timewarrior with taskwarrior, issue the following commands:"
+ elog "cp /usr/share/doc/${PF}/ext/on-modify.timewarrior ~/.task/hooks/"
+ elog "chmod +x ~/.task/hooks/on-modify.timewarrior"
+ elog "see https://timewarrior.net/docs/taskwarrior.html"
+}