summaryrefslogtreecommitdiff
path: root/app-misc/timew
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /app-misc/timew
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'app-misc/timew')
-rw-r--r--app-misc/timew/Manifest2
-rw-r--r--app-misc/timew/timew-1.2.0.ebuild25
2 files changed, 27 insertions, 0 deletions
diff --git a/app-misc/timew/Manifest b/app-misc/timew/Manifest
index dd2c0779b365..d558931f3714 100644
--- a/app-misc/timew/Manifest
+++ b/app-misc/timew/Manifest
@@ -1,5 +1,7 @@
DIST timew-1.0.0.tar.gz 140539 BLAKE2B 486c1e99a587597a040e3fb45c15602e56798b5a13ce3f47fb8d73b3995ee270ef2601e49dc4efe3023d1179a111b55c50c92a3feece87d9bad6a26123dc9008 SHA512 0539ff93b2375c154d126c39aa84f21b57b62f51c220c80b2e323a4d6aefd2eda6f87c04112e096222102b019ee3683a78b9ee9d6fbf6736d4a34c529f6152f5
DIST timew-1.1.1.tar.gz 166484 BLAKE2B 64b8560220550299c76207873184252b1100d146ac745e46f38790a90294c59e5da95852836433f1d5213a2f1272063a534c20b2963a88fbaa1bcb888e40b70b SHA512 d262227d6dc99994599252c9fc55d32e4caac9d5ff1f223b8637005ed9f4f7fa238bd5cb7392c8e42a468f6246a7afad9b6fdb02af636e53d3bd813cfc3ee110
+DIST timew-1.2.0.tar.gz 181477 BLAKE2B 03c815dddbcc1801bd5d6849b4a6b97291ccfcae98421a3c89582b97b0214e57886a2ed485b506aafd11e16e5e8444bcfe6f457289598eb1ac671ac85004b5df SHA512 e576aff06dde1e3d5d46f4a9a425991c91c8484aa8f2eeeb8dda7a4bd40716863432740e7810c2acb43adf223a090af4e95d77994ceba03c043c57bcab745c21
EBUILD timew-1.0.0.ebuild 512 BLAKE2B 6050789317fa16dd7c5e9ff926cefef8778c2a5d06ff2e8fdce163ed8c1de33faab0a8fb77c80bdd223b4ec2602b7efc4139da62fbf5db832adbd3d97a72d85c SHA512 0029cd62f73134e30e313929dc41bb499a081054715f7ec16234b83affffedda3e958abcc0b417267002dcb80bcc35000b91c07bc66e2d4b015bb14be3cca890
EBUILD timew-1.1.1.ebuild 512 BLAKE2B 15a91014bb2bea1ae3fa306129df3cff014be92a528db86c6ad2361a7de9153c95c2184001799c6204e7297accd6105d3a5cc7ae298c3d376151772f35805dc6 SHA512 d6b4128865a695302bab3bd14e2fafae27e437c3362663dff545485e61642b06c1aa4703aa4361de6c0878df1cee852595b8411ec4e04aff75d853798975ed9f
+EBUILD timew-1.2.0.ebuild 553 BLAKE2B e97ba552d3aededa5367e46dbd688f049d1ef9a7f0dcd3d01e76111b0017c8306e69be3074e9f7bef5b395cff432ac0e869eb0ad94111a33bff019f1ca0d2e7f SHA512 31eaa7c7cdd658e2f2b4524d8bfaf7f6f2bdff126d81fabd66d0cb96f4718bca4096b1b0aab193eb4ab2737253c2c563998308e0d1969ac7332ec140ee5b8bf2
MISC metadata.xml 254 BLAKE2B a18499b4ce0a448cf0321b4c94f7e3d3499ba025e4a7a66fa6a67342470f163f988161a80c183443a7ad222894594ffa2a5a8452cbf39ac890b660ceb319019f SHA512 b3850bc7c75c11c1cd29ad3560299a281a67d1c39cfb052c1964422209446da77036d4072ad192a2bd9c793aab2f0878426ff9a3ac723ea18553a0564271225d
diff --git a/app-misc/timew/timew-1.2.0.ebuild b/app-misc/timew/timew-1.2.0.ebuild
new file mode 100644
index 000000000000..b5cc50bd8639
--- /dev/null
+++ b/app-misc/timew/timew-1.2.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Tracks your time from the command line, and generates reports"
+HOMEPAGE="https://taskwarrior.org/news/news.20160821.html"
+SRC_URI="https://github.com/GothenburgBitFactory/timewarrior/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ -DTIMEW_DOCDIR=share/doc/${PF}
+ )
+ cmake-utils_src_configure
+}