summaryrefslogtreecommitdiff
path: root/app-misc/timew-report
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /app-misc/timew-report
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'app-misc/timew-report')
-rw-r--r--app-misc/timew-report/Manifest3
-rw-r--r--app-misc/timew-report/metadata.xml16
-rw-r--r--app-misc/timew-report/timew-report-1.4.0.ebuild30
3 files changed, 49 insertions, 0 deletions
diff --git a/app-misc/timew-report/Manifest b/app-misc/timew-report/Manifest
new file mode 100644
index 000000000000..fd39dca883ce
--- /dev/null
+++ b/app-misc/timew-report/Manifest
@@ -0,0 +1,3 @@
+DIST timew-report-1.4.0.tar.gz 6815 BLAKE2B a0529f575d324a92955eef2b94f302fc61fd09f9b85a092e4b7c5993c1710a189007be900e212bc15a3a29db73feb14d246e2f78a5e2965e26eec05204cc1e34 SHA512 bb1144b0268788c569fef68d10e16311e09f390e66992e71d850ef241de21c3cb67b8f696d776e673856ef53f5205873970b1fc2e06b62696181074090bd58a8
+EBUILD timew-report-1.4.0.ebuild 721 BLAKE2B e93c9e866d186182d566317dcb1ffdb28306af83a5f4328984e25db9263935924eea40dd970a5872709305c125e120dac686491a66b2de0330e77ffbea999060 SHA512 644bc404c022c4b86cc5c18761d1bef62702718bbe7c93bf5e4cd02a3566bb47243d7a881e98354c718d99eddaa2a0407d8e912682a3e6d6f043a48ffd6d1c12
+MISC metadata.xml 538 BLAKE2B d5c37bbed16762b081541a6e70b6e0e29a0249685be62784cf735cc842459f5b94fc039dab76bf7f2c87c22a45132def3606b125e86765ae8577dd36e87bcf58 SHA512 0262e2b08b0a8609ec22c1cb6f5cc450bbe47e0ad85a60eb5f751ae40203c8348a3e28082a770257b838bc21e5b6e7e24dea5f8f74136610cf3c72ec6eb681b6
diff --git a/app-misc/timew-report/metadata.xml b/app-misc/timew-report/metadata.xml
new file mode 100644
index 000000000000..93dc8a6362d8
--- /dev/null
+++ b/app-misc/timew-report/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>nerdboy@gentoo.org</email>
+ <name>Steve Arnold</name>
+ </maintainer>
+ <longdescription lang="en">
+ timew-report is an interface for generating custom reports
+ from timewarrior tracking data (drop your python scripts in
+ the timew extensions directory).
+ </longdescription>
+ <upstream>
+ <remote-id type="github"> lauft/timew-report</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-misc/timew-report/timew-report-1.4.0.ebuild b/app-misc/timew-report/timew-report-1.4.0.ebuild
new file mode 100644
index 000000000000..222a707352ae
--- /dev/null
+++ b/app-misc/timew-report/timew-report-1.4.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+inherit distutils-r1
+
+DESCRIPTION="An interface for Timewarrior report data"
+HOMEPAGE="https://github.com/lauft/timew-report"
+SRC_URI="https://github.com/lauft/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="${PYTHON_DEPS}
+ app-misc/timew"
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/deprecation[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ test? ( >=dev-python/pytest-3.0.3[${PYTHON_USEDEP}] )
+"
+
+RESTRICT="!test? ( test )"
+
+distutils_enable_tests pytest